summaryrefslogtreecommitdiff
path: root/media-video/vlc/vlc-3.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-13 10:28:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-13 10:28:51 +0000
commitaafdd1dcd9a66da0b1bcdfadbca62add48751897 (patch)
treed328a4fe625235ee8ea443c3b1bec1fd105af11d /media-video/vlc/vlc-3.0.9999.ebuild
parente0345ef79b0b4a444151748ce1f5364fc2dd147b (diff)
gentoo auto-resync : 13:11:2023 - 10:28:51
Diffstat (limited to 'media-video/vlc/vlc-3.0.9999.ebuild')
-rw-r--r--media-video/vlc/vlc-3.0.9999.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/media-video/vlc/vlc-3.0.9999.ebuild b/media-video/vlc/vlc-3.0.9999.ebuild
index b8b55bfe7c0b..b683670524d6 100644
--- a/media-video/vlc/vlc-3.0.9999.ebuild
+++ b/media-video/vlc/vlc-3.0.9999.ebuild
@@ -48,7 +48,7 @@ REQUIRED_USE="
libtar? ( skins )
libtiger? ( kate )
lua? ( ${LUA_REQUIRED_USE} )
- skins? ( gui truetype X xml )
+ skins? ( archive gui truetype X xml )
ssl? ( gcrypt )
vaapi? ( ffmpeg X )
vdpau? ( ffmpeg X )
@@ -440,8 +440,12 @@ src_configure() {
)
# ^ We don't have these disabled libraries in the Portage tree yet.
+ # https://code.videolan.org/videolan/vlc/-/issues/17626 (bug #861143)
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# Compatibility fix for Samba 4.
- use samba && append-cppflags "-I/usr/include/samba-4.0"
+ use samba && append-cppflags "-I${ESYSROOT}/usr/include/samba-4.0"
if use x86; then
# We need to disable -fstack-check if use >=gcc 4.8.0. bug #499996
@@ -450,12 +454,6 @@ src_configure() {
replace-flags -Os -O2
fi
- if use omxil; then
- # bug #723006
- # https://trac.videolan.org/vlc/ticket/24617
- append-cflags -fcommon
- fi
-
# FIXME: Needs libresid-builder from libsidplay:2 which is in another directory...
append-ldflags "-L${ESYSROOT}/usr/$(get_libdir)/sidplay/builders/"