summaryrefslogtreecommitdiff
path: root/media-video/vidcutter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /media-video/vidcutter
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'media-video/vidcutter')
-rw-r--r--media-video/vidcutter/Manifest4
-rw-r--r--media-video/vidcutter/metadata.xml11
-rw-r--r--media-video/vidcutter/vidcutter-6.0.0.ebuild40
-rw-r--r--media-video/vidcutter/vidcutter-9999.ebuild40
4 files changed, 95 insertions, 0 deletions
diff --git a/media-video/vidcutter/Manifest b/media-video/vidcutter/Manifest
new file mode 100644
index 000000000000..f0873a107659
--- /dev/null
+++ b/media-video/vidcutter/Manifest
@@ -0,0 +1,4 @@
+DIST vidcutter-6.0.0.tar.gz 9877867 BLAKE2B 91f153222f37d452ed8af5c4f24e32790189f058b5cbb3c80f7805ed48b5e953bfeeb8be92f04e049384dc30f416d0ee603237b8a59a329b0bc0cd61bf0fdbe2 SHA512 9970d9918cca9a7681bc5ca8d8b5d16212cf3dad0f2bc3e9c6727340c340801696dcb7ff4e901c2c0a25b86e9cb165bb3f783c18b4a8fd5f4ddba8490a7fd7a0
+EBUILD vidcutter-6.0.0.ebuild 937 BLAKE2B 9d8ac9428cfff9d2b5ce92819ac904af7cfe2f7ddb76e0d305e5e919f67c95d2bcb31df12add844ec6bf4a10604bd64e66a8ab2ad38d0f55c7795dabb4578214 SHA512 0b03f716111381019c0c679784dd8f9aa2359036951387150a01ee3bb3a06aea77052c31f49fab4021afbd59cfcde6401920f4a4d6074b8283606ed980743109
+EBUILD vidcutter-9999.ebuild 937 BLAKE2B 9d8ac9428cfff9d2b5ce92819ac904af7cfe2f7ddb76e0d305e5e919f67c95d2bcb31df12add844ec6bf4a10604bd64e66a8ab2ad38d0f55c7795dabb4578214 SHA512 0b03f716111381019c0c679784dd8f9aa2359036951387150a01ee3bb3a06aea77052c31f49fab4021afbd59cfcde6401920f4a4d6074b8283606ed980743109
+MISC metadata.xml 341 BLAKE2B b4ba35e0ab8990d8adff9beca129b517683baf99330f3df941a01beffaaf3f736b1dcd0d7978b368bc8267fc93d7234649b952c0eba83f8940a56278461fae13 SHA512 89d95e914de7d3ac60dea1040efbcebd2c4c7e048aafa0daa531ffa628dfb6bb9eb75c4c69a888499a8aa4bdf76a53ea2dde595f1134e46d17d334fa81b6809f
diff --git a/media-video/vidcutter/metadata.xml b/media-video/vidcutter/metadata.xml
new file mode 100644
index 000000000000..a56d19341fbd
--- /dev/null
+++ b/media-video/vidcutter/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ozmartian/vidcutter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/vidcutter/vidcutter-6.0.0.ebuild b/media-video/vidcutter/vidcutter-6.0.0.ebuild
new file mode 100644
index 000000000000..925afa62e558
--- /dev/null
+++ b/media-video/vidcutter/vidcutter-6.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="FFmpeg-based simple video cutter & joiner with a modern PyQt5 GUI"
+HOMEPAGE="http://vidcutter.ozmartians.com https://github.com/ozmartian/vidcutter"
+
+if [[ ${PV} == 9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ozmartian/vidcutter"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ozmartian/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=media-video/mpv-0.25[libmpv]
+"
+RDEPEND="${DEPEND}
+ >=dev-python/PyQt5-5.7[dbus,multimedia,${PYTHON_USEDEP}]
+ media-video/mediainfo
+ virtual/ffmpeg[X,encode]"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${P}"
+}
diff --git a/media-video/vidcutter/vidcutter-9999.ebuild b/media-video/vidcutter/vidcutter-9999.ebuild
new file mode 100644
index 000000000000..925afa62e558
--- /dev/null
+++ b/media-video/vidcutter/vidcutter-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="FFmpeg-based simple video cutter & joiner with a modern PyQt5 GUI"
+HOMEPAGE="http://vidcutter.ozmartians.com https://github.com/ozmartian/vidcutter"
+
+if [[ ${PV} == 9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ozmartian/vidcutter"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ozmartian/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=media-video/mpv-0.25[libmpv]
+"
+RDEPEND="${DEPEND}
+ >=dev-python/PyQt5-5.7[dbus,multimedia,${PYTHON_USEDEP}]
+ media-video/mediainfo
+ virtual/ffmpeg[X,encode]"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${P}"
+}