summaryrefslogtreecommitdiff
path: root/media-video/transcode/transcode-1.1.7-r6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 01:41:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 01:41:15 +0100
commite0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (patch)
tree7a71d24a0bfba0874deeb5e8131d579dfb40e1d1 /media-video/transcode/transcode-1.1.7-r6.ebuild
parent7cffc3e7845d1a3ae331145c5e1226e314badf4a (diff)
gentoo auto-resync : 15:07:2022 - 01:41:14
Diffstat (limited to 'media-video/transcode/transcode-1.1.7-r6.ebuild')
-rw-r--r--media-video/transcode/transcode-1.1.7-r6.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/media-video/transcode/transcode-1.1.7-r6.ebuild b/media-video/transcode/transcode-1.1.7-r6.ebuild
index 27b8a8cfff4b..2c446a83b2d3 100644
--- a/media-video/transcode/transcode-1.1.7-r6.ebuild
+++ b/media-video/transcode/transcode-1.1.7-r6.ebuild
@@ -1,11 +1,12 @@
# Copyright 2002-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit autotools
DESCRIPTION="Utilities for transcoding video and audio codecs in different containers"
-HOMEPAGE="http://www.transcoding.org/ https://bitbucket.org/france/transcode-tcforge"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="https://www.bitbucket.org/france/${PN}-tcforge/downloads/${P}.tar.bz2
https://dev.gentoo.org/~mgorny/dist/${P}-patchset.tar.bz2
https://dev.gentoo.org/~whissi/dist/${PN}/${PN}-1.1.7-ffmpeg4.patch.xz"
@@ -15,6 +16,13 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm64 ppc ppc64 ~riscv sparc x86"
IUSE="cpu_flags_x86_3dnow a52 aac alsa altivec dv dvd +iconv imagemagick jpeg lzo mjpeg cpu_flags_x86_mmx mp3 mpeg nuv ogg oss pic postproc quicktime sdl cpu_flags_x86_sse cpu_flags_x86_sse2 theora truetype v4l vorbis X x264 xml xvid"
+REQUIRED_USE="
+ cpu_flags_x86_sse? ( cpu_flags_x86_mmx )
+ cpu_flags_x86_sse2? ( cpu_flags_x86_mmx cpu_flags_x86_sse )
+ cpu_flags_x86_3dnow? ( cpu_flags_x86_mmx )
+ nuv? ( lzo )
+"
+
RDEPEND="
>=media-video/ffmpeg-0.10
a52? ( media-libs/a52dec )
@@ -37,25 +45,21 @@ RDEPEND="
truetype? ( >=media-libs/freetype-2 )
v4l? ( media-libs/libv4l )
vorbis? ( media-libs/libvorbis )
- X? ( x11-libs/libXpm x11-libs/libXaw x11-libs/libXv )
+ X? (
+ x11-libs/libXaw
+ x11-libs/libXpm
+ x11-libs/libXv
+ )
x264? ( media-libs/x264:= )
xml? ( dev-libs/libxml2 )
xvid? ( media-libs/xvid )
- "
-
+"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
v4l? ( >=sys-kernel/linux-headers-2.6.11 )
"
-REQUIRED_USE="
- cpu_flags_x86_sse? ( cpu_flags_x86_mmx )
- cpu_flags_x86_sse2? ( cpu_flags_x86_mmx cpu_flags_x86_sse )
- cpu_flags_x86_3dnow? ( cpu_flags_x86_mmx )
- nuv? ( lzo )
- "
-
PATCHES=(
"${WORKDIR}"/${P}-patchset/${P}-ffmpeg.patch
"${WORKDIR}"/${P}-patchset/${P}-ffmpeg-0.10.patch
@@ -67,7 +71,7 @@ PATCHES=(
"${WORKDIR}"/${P}-patchset/${P}-ffmpeg2.patch
"${WORKDIR}"/${P}-patchset/${P}-freetype251.patch
"${WORKDIR}"/${P}-patchset/${P}-ffmpeg24.patch
- "${FILESDIR}"/${P}-swresample.patch #722296
+ "${FILESDIR}"/${P}-swresample.patch # bug 722296
"${FILESDIR}"/${P}-gcc10-fno-common.patch
"${FILESDIR}"/${P}-glibc-2.32.patch
)
@@ -82,7 +86,7 @@ src_prepare() {
fi
if has_version '>=media-video/ffmpeg-4' ; then
- PATCHES+=( "${WORKDIR}/transcode-1.1.7-ffmpeg4.patch" )
+ PATCHES+=( "${WORKDIR}"/${P}-ffmpeg4.patch )
fi
default
@@ -92,7 +96,7 @@ src_prepare() {
src_configure() {
local myconf
- use x86 && myconf="$(use_enable !pic x86-textrels)" #271476
+ use x86 && myconf="$(use_enable !pic x86-textrels)" # bug 271476
local myeconfargs=(
$(use_enable cpu_flags_x86_mmx mmx)