summaryrefslogtreecommitdiff
path: root/media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild')
-rw-r--r--media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild b/media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild
new file mode 100644
index 000000000000..d1e7738874fe
--- /dev/null
+++ b/media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="for mjpegtools for adding subtitles, pictures, and effects embedded in the picture"
+HOMEPAGE="http://panteltje.com/panteltje/subtitles/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS/s:= -O2:+=:' \
+ -e '/CFLAGS/s:gcc:$(CC):' \
+ -e 's:gcc -o:$(CC) $(LDFLAGS) -o:' \
+ -e 's:-L/usr/X11R6/lib/::' \
+ -e 's:-lXpm:-lX11:' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc CHANGES HOWTO_USE_THIS README*
+ insinto /usr/share/${PN}
+ doins *.{ppm,ppml,zip}
+}