summaryrefslogtreecommitdiff
path: root/media-video/subdownloader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/subdownloader
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/subdownloader')
-rw-r--r--media-video/subdownloader/Manifest5
-rw-r--r--media-video/subdownloader/metadata.xml19
-rw-r--r--media-video/subdownloader/subdownloader-2.0.18-r1.ebuild35
3 files changed, 59 insertions, 0 deletions
diff --git a/media-video/subdownloader/Manifest b/media-video/subdownloader/Manifest
new file mode 100644
index 000000000000..eb0e27ad2914
--- /dev/null
+++ b/media-video/subdownloader/Manifest
@@ -0,0 +1,5 @@
+DIST subdownloader-2.0.18.tar.gz 1259520 SHA256 2f9ec46d1537cb5677b717dcaf5668cdc61a84456bc52178b40595759ba35655 SHA512 ecddf606ce374af43fff39c225ee896af4d8bd2384a2f300dcbb4b443377807edd5233a0531e95d338b0f9c84a274b3afd4109d9216510a5a4bc8fa17485b999 WHIRLPOOL 2b735f0c25a19a49444011a81b28b855d3ce4b2ba01f1efbc65d9f4fe3f541081db13805d99d9a8e52cbb3ef3b95dae3fa80c3f9a06023c629285f4dd9dca5ac
+EBUILD subdownloader-2.0.18-r1.ebuild 978 SHA256 f722d190cd5f4f665ab6951a974bedf8fff977f89693e334f317289e51ee6667 SHA512 94d57b0a379be5ebbae07fa8ab92480d3e6245f976cf6ad57918b1557d75427271fa044b1371684fac2572e218bee5c2cfdaafd7cafb589621d40d545c070b23 WHIRLPOOL 31939a78fcf2c92544c81e4b0efbbb2f91f7a4feb779fcd7626a2234af7610868d4451ae74531e12afdbf278638178665469e8a62d96db7aff65370120f1784c
+MISC ChangeLog 3055 SHA256 9370d9baa02346a86ccbbc37bda8aeb301692537c1e8f9ace4a62d8e04145281 SHA512 924d6072297146e7351267a2b7a4fab4bf1e31b71f0538b75ffed48eb3fd96195a1dedc2b1a352b3fcbd629c6039c974ac0cad7634b514cecc8166cc2c3eb5c2 WHIRLPOOL d98591911b21455aba0255df0406626c2a8c88e4dac2e4b15f51abeab6347eb28cbe3aa8e334666f1c06cc409d540990f4fe29b46ee7619b083eb5dc00883b7f
+MISC ChangeLog-2015 1637 SHA256 735760f63334e7a41ce07eed8b810d47e188814a1dd46ef6ec66d362ffb6a5e2 SHA512 f379d4111ade6d964037e62b64e1b74f82236f55a549d64731119e883234d20370c1c47cb5887c756862d88d3ac9c195e2fcf8e0694373908505d90187f4bafa WHIRLPOOL 4d96cd6b64f9e015b9a4fec82ace53d4d12da9dc76d4977214038b49ad9179b3088549a0da883fdeb8391868916a17bfb967934814d7b8341bc5d51050a45b60
+MISC metadata.xml 649 SHA256 bc9314b506f9718fa9e9053bd4b3f0bad37587ceab371ec89092925cdd3782c6 SHA512 95f94664006d3dcf24c48fa77177bcd611a10c04793c96c6582847d905c8169dfaefd713047e7539d00d08947bbc7fc9c6601a5a0586658e53de3172c9b21409 WHIRLPOOL 2950ed69ee63741f1d2f521445aad6055f6ab921b2d9cdd662dc8890834da1ebd469691ae443ff61662177b66a7b8c18573184c2a5dd2cdf4bd64c970cb56ba0
diff --git a/media-video/subdownloader/metadata.xml b/media-video/subdownloader/metadata.xml
new file mode 100644
index 000000000000..9a00093051a0
--- /dev/null
+++ b/media-video/subdownloader/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ThyArmageddon+Gentoo@Gmail.com</email>
+ <name>Elijah El Lazkani</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ SubDownloader is a program for automatic download/upload subtitles for
+ videofiles (DIVX,MPEG,AVI,VOB,etc) and DVD's using fast hashing
+ </longdescription>
+ <upstream>
+ <remote-id type="launchpad">subdownloader</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild b/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
new file mode 100644
index 000000000000..0237c1ee661f
--- /dev/null
+++ b/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="GUI application for automatic downloading/uploading of subtitles for videofiles"
+HOMEPAGE="http://www.subdownloader.net/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_2.0.18.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/kaa-metadata[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_install() {
+ python_fix_shebang "${S}"/run.py
+ insinto /usr/share/"${PN}"
+ doins -r cli FileManagement gui languages locale modules run.py
+ fperms 755 /usr/share/"${PN}"/run.py
+ dosym /usr/share/"${PN}"/run.py /usr/bin/"${PN}"
+ doman subdownloader.1
+ dodoc README ChangeLog
+ doicon gui/images/subdownloader.png
+ domenu subdownloader.desktop
+}