summaryrefslogtreecommitdiff
path: root/media-video/simplescreenrecorder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/simplescreenrecorder
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/simplescreenrecorder')
-rw-r--r--media-video/simplescreenrecorder/Manifest4
-rw-r--r--media-video/simplescreenrecorder/metadata.xml15
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-0.3.8.ebuild92
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild92
4 files changed, 203 insertions, 0 deletions
diff --git a/media-video/simplescreenrecorder/Manifest b/media-video/simplescreenrecorder/Manifest
new file mode 100644
index 000000000000..4081ae7a6792
--- /dev/null
+++ b/media-video/simplescreenrecorder/Manifest
@@ -0,0 +1,4 @@
+DIST simplescreenrecorder-0.3.8.tar.gz 2037017 SHA256 ef05f1b4c36e1d82a4e96f59c5f29aaae986ad6711ccc311d0e21c8e6c191c6d SHA512 f94c7ac7d5f6fdebd1c68da7469b6c46a21b399e2ad8744c52d3e9959d2ec74d15e6ac061d7fe41f02ebb9ee9a89fbd8feecf4e0a10110975f3857a7fbb66365 WHIRLPOOL 23a811f5af9921bfdaf8d5546b9497e4a46d923d6eeb38d572b4d243ca55e75f0528df4b31936f23684e9a3cd54f47c1289682d196a04d97927501e19362013b
+EBUILD simplescreenrecorder-0.3.8.ebuild 2610 SHA256 7abbf2de35cbc0f36254b1772b59c1b4adf81b578ff1cd5f85ed9567d78f898d SHA512 d3f0af48d44419b4483502ffa0e09f679fedc6273b8ebbe81a184ac253a41230fb2e35b6cc9367b1d48d46f713a19f88f2f2c3a0e30243b817d4bdd527275167 WHIRLPOOL 1d37c25e9d48ac2e65ee6f8e6df8c91095e9218d5e7038abb311ddeafa2f084845debab89239d4435f069146a48264a5bd74c57076a22fcb19599bc835396a39
+EBUILD simplescreenrecorder-9999.ebuild 2610 SHA256 7abbf2de35cbc0f36254b1772b59c1b4adf81b578ff1cd5f85ed9567d78f898d SHA512 d3f0af48d44419b4483502ffa0e09f679fedc6273b8ebbe81a184ac253a41230fb2e35b6cc9367b1d48d46f713a19f88f2f2c3a0e30243b817d4bdd527275167 WHIRLPOOL 1d37c25e9d48ac2e65ee6f8e6df8c91095e9218d5e7038abb311ddeafa2f084845debab89239d4435f069146a48264a5bd74c57076a22fcb19599bc835396a39
+MISC metadata.xml 508 SHA256 981dc9fc3f67ce9eb1296497b135bbe7eaf0c4aa0dde62c0a3fda16eff59cacf SHA512 d4879cb7f57f23d273e45b429ab5548d30a0a6eefe63e28c2c60e7cef9a44b295d8455bfedaf9d9294ff4cf16b4f841f0ddb34541c62c25cbf190f7b6c7538ce WHIRLPOOL bd590b199c5912857041f371760d04f74b7efc00532dc9c4d652127f8a82f1bcb57e2ad5f9babe62453121c2e7670f478a4a672dae87e39d60f00c5568b24e9b
diff --git a/media-video/simplescreenrecorder/metadata.xml b/media-video/simplescreenrecorder/metadata.xml
new file mode 100644
index 000000000000..9778ada8fb0f
--- /dev/null
+++ b/media-video/simplescreenrecorder/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <use>
+ <flag name="asm">Enable x86 assembly optimisation.</flag>
+ <flag name="vpx">Enable VP8 codec support via <pkg>media-libs/libvpx</pkg>.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">MaartenBaert/ssr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-0.3.8.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-0.3.8.ebuild
new file mode 100644
index 000000000000..22b763bb40ea
--- /dev/null
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-0.3.8.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic multilib-minimal
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="A Simple Screen Recorder"
+HOMEPAGE="https://www.maartenbaert.be/simplescreenrecorder"
+LICENSE="GPL-3"
+PKGNAME="ssr"
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/MaartenBaert/${PKGNAME}.git"
+ EGIT_BOOTSTRAP=""
+else
+ SRC_URI="https://github.com/MaartenBaert/${PKGNAME}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PKGNAME}-${PV}"
+fi
+
+SLOT="0"
+IUSE="+asm debug jack mp3 pulseaudio theora vorbis vpx x264"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/alsa-lib:0=
+ media-libs/mesa[${MULTILIB_USEDEP}]
+ || (
+ media-video/ffmpeg[vorbis?,vpx?,x264?,mp3?,theora?]
+ media-video/libav[vorbis?,vpx?,x264?,mp3?,theora?]
+ )
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ jack? ( virtual/jack )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if [[ ${ABI} == amd64 ]]; then
+ elog "You may want to add USE flag 'abi_x86_32' when running a 64bit system"
+ elog "When added 32bit GLInject libraries are also included. This is"
+ elog "required if you want to use OpenGL recording on 32bit applications."
+ elog
+ fi
+
+ if { has_version media-video/ffmpeg[x264] || has_version media-video/libav[x264] ; } && has_version media-libs/x264[10bit] ; then
+ ewarn
+ ewarn "media-libs/x264 is currently built with 10bit useflag."
+ ewarn "This is known to prevent simplescreenrecorder from recording x264 videos"
+ ewarn "correctly. Please build media-libs/x264 without 10bit if you want to "
+ ewarn "record videos with x264."
+ ewarn
+ fi
+
+ # QT requires -fPIC. Compile fails otherwise.
+ # Recently removed from the default compile options upstream
+ # https://github.com/MaartenBaert/ssr/commit/25fe1743058f0d1f95f6fbb39014b6ac146b5180
+ append-flags -fPIC
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(multilib_native_use_enable debug assert)
+ $(multilib_native_use_with pulseaudio)
+ $(multilib_native_use_with jack)
+ $(use_enable asm x86-asm)
+ )
+
+ # libav doesn't have AVFrame::channels
+ # https://github.com/MaartenBaert/ssr/issues/195#issuecomment-45646159
+ if has_version media-video/libav; then
+ myconf+=( --disable-ffmpeg-versions )
+ fi
+
+ if multilib_is_native_abi ; then
+ myconf+=( --with-qt5 )
+ else
+ myconf+=( --disable-ssrprogram )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
new file mode 100644
index 000000000000..22b763bb40ea
--- /dev/null
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic multilib-minimal
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="A Simple Screen Recorder"
+HOMEPAGE="https://www.maartenbaert.be/simplescreenrecorder"
+LICENSE="GPL-3"
+PKGNAME="ssr"
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/MaartenBaert/${PKGNAME}.git"
+ EGIT_BOOTSTRAP=""
+else
+ SRC_URI="https://github.com/MaartenBaert/${PKGNAME}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PKGNAME}-${PV}"
+fi
+
+SLOT="0"
+IUSE="+asm debug jack mp3 pulseaudio theora vorbis vpx x264"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/alsa-lib:0=
+ media-libs/mesa[${MULTILIB_USEDEP}]
+ || (
+ media-video/ffmpeg[vorbis?,vpx?,x264?,mp3?,theora?]
+ media-video/libav[vorbis?,vpx?,x264?,mp3?,theora?]
+ )
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ jack? ( virtual/jack )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if [[ ${ABI} == amd64 ]]; then
+ elog "You may want to add USE flag 'abi_x86_32' when running a 64bit system"
+ elog "When added 32bit GLInject libraries are also included. This is"
+ elog "required if you want to use OpenGL recording on 32bit applications."
+ elog
+ fi
+
+ if { has_version media-video/ffmpeg[x264] || has_version media-video/libav[x264] ; } && has_version media-libs/x264[10bit] ; then
+ ewarn
+ ewarn "media-libs/x264 is currently built with 10bit useflag."
+ ewarn "This is known to prevent simplescreenrecorder from recording x264 videos"
+ ewarn "correctly. Please build media-libs/x264 without 10bit if you want to "
+ ewarn "record videos with x264."
+ ewarn
+ fi
+
+ # QT requires -fPIC. Compile fails otherwise.
+ # Recently removed from the default compile options upstream
+ # https://github.com/MaartenBaert/ssr/commit/25fe1743058f0d1f95f6fbb39014b6ac146b5180
+ append-flags -fPIC
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(multilib_native_use_enable debug assert)
+ $(multilib_native_use_with pulseaudio)
+ $(multilib_native_use_with jack)
+ $(use_enable asm x86-asm)
+ )
+
+ # libav doesn't have AVFrame::channels
+ # https://github.com/MaartenBaert/ssr/issues/195#issuecomment-45646159
+ if has_version media-video/libav; then
+ myconf+=( --disable-ffmpeg-versions )
+ fi
+
+ if multilib_is_native_abi ; then
+ myconf+=( --with-qt5 )
+ else
+ myconf+=( --disable-ssrprogram )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}