summaryrefslogtreecommitdiff
path: root/media-video/shotcut/shotcut-21.06.29.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /media-video/shotcut/shotcut-21.06.29.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'media-video/shotcut/shotcut-21.06.29.ebuild')
-rw-r--r--media-video/shotcut/shotcut-21.06.29.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/media-video/shotcut/shotcut-21.06.29.ebuild b/media-video/shotcut/shotcut-21.06.29.ebuild
deleted file mode 100644
index 94b278e81817..000000000000
--- a/media-video/shotcut/shotcut-21.06.29.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit qmake-utils xdg
-
-DESCRIPTION="A free, open source, cross-platform video editor"
-HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
-if [[ ${PV} != 9999* ]] ; then
- SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
-fi
-
-IUSE="debug"
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-BDEPEND="
- dev-qt/linguist-tools:5
-"
-COMMON_DEPEND="
- dev-qt/qtcore:5
- dev-qt/qtdeclarative:5[widgets]
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qtprintsupport:5
- dev-qt/qtquickcontrols2:5
- dev-qt/qtsql:5
- dev-qt/qtwebsockets:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- >=media-libs/mlt-7.0.1[ffmpeg,frei0r,fftw(+),jack,opengl,qt5,sdl,xml]
- media-video/ffmpeg
-"
-DEPEND="${COMMON_DEPEND}
- dev-qt/qtconcurrent:5
- dev-qt/qtx11extras:5
-"
-RDEPEND="${COMMON_DEPEND}
- dev-qt/qtgraphicaleffects:5
- dev-qt/qtquickcontrols:5
- virtual/jack
-"
-
-src_configure() {
- local myqmakeargs=(
- PREFIX="${EPREFIX}/usr"
- SHOTCUT_VERSION="${PV}"
- DEFINES+=SHOTCUT_NOUPGRADE
- )
- use debug || myqmakeargs+=(DEFINES+=NDEBUG)
-
- eqmake5 "${myqmakeargs[@]}"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
- einstalldocs
-}