summaryrefslogtreecommitdiff
path: root/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160217-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160217-r1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160217-r1.ebuild')
-rw-r--r--media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160217-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160217-r1.ebuild b/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160217-r1.ebuild
new file mode 100644
index 000000000000..862d38275e34
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160217-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs flag-o-matic
+
+GIT_COMMIT="15a490b"
+DESCRIPTION="Command line media player for the Raspberry Pi"
+HOMEPAGE="https://github.com/popcornmix/omxplayer"
+SRC_URI="https://github.com/popcornmix/omxplayer/tarball/${GIT_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE=""
+
+RDEPEND="dev-libs/libpcre
+ media-fonts/freefont
+ || ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin )
+ sys-apps/dbus
+ sys-apps/fbset
+ media-video/ffmpeg
+ x11-apps/xrefresh
+ x11-apps/xset"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/popcornmix-omxplayer-${GIT_COMMIT}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/Makefile-0_p20160217.patch \
+ "${FILESDIR}"/fonts-path.patch
+
+ cat > Makefile.include << EOF
+LIBS=-lvchiq_arm -lvcos -lbcm_host -lEGL -lGLESv2 -lopenmaxil -lrt -lpthread
+EOF
+
+ tc-export CXX
+}
+
+src_compile() {
+ emake omxplayer.bin
+}
+
+src_install() {
+ dobin omxplayer omxplayer.bin
+ dodoc README.md
+}