summaryrefslogtreecommitdiff
path: root/media-video/raspberrypi-omxplayer/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-video/raspberrypi-omxplayer/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-video/raspberrypi-omxplayer/files')
-rw-r--r--media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch26
-rw-r--r--media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch8
2 files changed, 4 insertions, 30 deletions
diff --git a/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch b/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch
deleted file mode 100644
index c6f945209b95..000000000000
--- a/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- omxplayer-9999/Makefile
-+++ omxplayer-9999/Makefile
-@@ -2,9 +2,11 @@
-
- CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
-
--LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
-+PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
-+
-+LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib
-
--INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
-+INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
-
- DIST ?= omxplayer-dist
-
-@@ -51,8 +47,7 @@
- bash gen_version.sh > version.h
-
- omxplayer.bin: version $(OBJS)
-- $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
-- $(STRIP) omxplayer.bin
-+ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) $(LIBS)
-
- help.h: README.md Makefile
- awk '/SYNOPSIS/{p=1;print;next} p&&/KEY BINDINGS/{p=0};p' $< \
diff --git a/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch b/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch
index eb65f5d7ad70..d71e6b376080 100644
--- a/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch
+++ b/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch
@@ -1,5 +1,5 @@
---- omxplayer-9999/Makefile
-+++ omxplayer-9999/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -2,9 +2,11 @@
CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
@@ -7,10 +7,10 @@
-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
+PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
+
-+LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib
++LIBS+=-lrt -lpthread $(shell ${PKG_CONFIG} --libs $(PKGS)) -L/opt/vc/lib
-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
-+INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
++INCLUDES+=$(shell ${PKG_CONFIG} --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
DIST ?= omxplayer-dist