summaryrefslogtreecommitdiff
path: root/media-video/qmplay2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-23 21:50:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-23 21:50:52 +0100
commitba3d6ddada23eaa04f85228bee3438ab479b4442 (patch)
tree87c61faa67018943d552f24d91f0aeaece2b771e /media-video/qmplay2
parent2e6d363c5e87569efc23848513e71f2233b7e9d9 (diff)
gentoo auto-resync : 23:10:2022 - 21:50:51
Diffstat (limited to 'media-video/qmplay2')
-rw-r--r--media-video/qmplay2/Manifest3
-rw-r--r--media-video/qmplay2/files/qmplay2-22.10.23-fix-includes.patch44
-rw-r--r--media-video/qmplay2/qmplay2-22.10.23.ebuild141
3 files changed, 188 insertions, 0 deletions
diff --git a/media-video/qmplay2/Manifest b/media-video/qmplay2/Manifest
index de9ec1baa787..a58219a0b11d 100644
--- a/media-video/qmplay2/Manifest
+++ b/media-video/qmplay2/Manifest
@@ -1,4 +1,7 @@
+AUX qmplay2-22.10.23-fix-includes.patch 869 BLAKE2B e84d97476114c0b48930530ebeaf90032af650080ac517d78986dfe443bf9beb0e128381c39880a78df1762eb85e51f0eab5275d7b148e631138e50d656ec33b SHA512 05025c688e7885c10856669b4e943daf54dfd9580d1e4ae77d344ac0d7ab97856b588e6765ae5a4cdbf7508d24e8affaf897efb01d0c328679b2916f98a3405a
DIST QMPlay2-src-22.08.21.tar.xz 1618824 BLAKE2B ac980c4ad018749d4ee5dcd2dc580c96cccb82a73ff4fd52c65beb1d7131e294d2af65814c8966ffbe2a04eb489f9b9ba23b2764b83aa3f3d57546125dde4ceb SHA512 a6abc71bf87a8bcb2c2c0c63889f75de4e2de4375de0a528cb6950d2fb1ac6e767386d13a0e3f26b59cfccb88b4db4a8c26cbf57299da2031239a73e4971a4de
+DIST QMPlay2-src-22.10.23.tar.xz 1414804 BLAKE2B c0db1187538be8ab0806abd41fbfdae5a71dda450505af1956989a3ccc10fa52997b8652f280cd66837d12a84a7a058783b65df3d4bd35665c92f1262cd8d004 SHA512 80c9408a9085084857b5b433f009bf62784cf73ceb90218ec09132be227aae97136095811ffa1211375dcbfc1f51cbefaa3690c56fc8df51d9b1cf022ce0709f
EBUILD qmplay2-22.08.21.ebuild 3326 BLAKE2B f5038c99fbd446e8ed67ec09a14bf45823618b8d30f415baedb71b5ec72274c20f5c91ec42e230419dec45a610572de80bb9a1a079853c258f24224a7014b5fa SHA512 83d6efceca7050ed8df053488cbf0b19004daa6d0723602bb5cd408b1653515ea980bcc5b295f95bfdeb6f46b38a1e92c5dc0a989a26de67dc00386e50993789
+EBUILD qmplay2-22.10.23.ebuild 3381 BLAKE2B 7fe62b58b88d5b42dc91c1984aa8c1d1964611c7224e258b7413af8c8d71b57408332b4c235ca82bb489896d9c223c3bd496ba2f7ae05d07542f2fd88523ec45 SHA512 582a316117b54870686c734c6ddc283c8102881502e8dfc4d0e6f4ad1f918431361694cab88b2206f75afc07e318aaa2b13ea7d19abcfd21fc3578c5ea4fa19f
EBUILD qmplay2-9999.ebuild 3326 BLAKE2B f5038c99fbd446e8ed67ec09a14bf45823618b8d30f415baedb71b5ec72274c20f5c91ec42e230419dec45a610572de80bb9a1a079853c258f24224a7014b5fa SHA512 83d6efceca7050ed8df053488cbf0b19004daa6d0723602bb5cd408b1653515ea980bcc5b295f95bfdeb6f46b38a1e92c5dc0a989a26de67dc00386e50993789
MISC metadata.xml 1342 BLAKE2B c3e3b0477c49c00aec65e05ec5d940f8fc126efe074460a1f67c39b98654ccc3819669e47ad5ba83ed977a72f9ee41606d9409ef3a377cfb511bdc01aff0ce70 SHA512 2eb6b7c2b72abf37a2165f35ed7cab51653a425d294f4ec866d0c6b4dd53ffbf8b30306a987bb4bba1e952ea246815dc59e22a6e9141151a844ae1b7cbd36bde
diff --git a/media-video/qmplay2/files/qmplay2-22.10.23-fix-includes.patch b/media-video/qmplay2/files/qmplay2-22.10.23-fix-includes.patch
new file mode 100644
index 000000000000..eb77927f6ea9
--- /dev/null
+++ b/media-video/qmplay2/files/qmplay2-22.10.23-fix-includes.patch
@@ -0,0 +1,44 @@
+https://github.com/zaps166/QMPlay2/pull/541
+
+fix include memory with USE_VULKAN=OFF
+
+Those header files are using std::shared_ptr from memory header even
+when USE_VULKAN is OFF, so we must include them unconditionally.
+
+Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
+--- a/src/qmplay2/LibASS.hpp
++++ b/src/qmplay2/LibASS.hpp
+@@ -23,6 +23,7 @@
+ #include <QByteArray>
+ #include <QList>
+
++#include <memory>
+ #include <set>
+
+ class Settings;
+@@ -35,7 +36,6 @@ struct ass_renderer;
+ struct ass_image;
+
+ #ifdef USE_VULKAN
+-#include <memory>
+ namespace QmVk {
+ class BufferPool;
+ }
+--- a/src/qmplay2/QMPlay2OSD.hpp
++++ b/src/qmplay2/QMPlay2OSD.hpp
+@@ -25,14 +25,13 @@
+ #include <QRect>
+
+ #include <functional>
++#include <memory>
+ #include <vector>
+ #include <mutex>
+
+ #ifdef USE_VULKAN
+ # include <QVector4D>
+
+-# include <memory>
+-
+ namespace QmVk {
+
+ class Buffer;
diff --git a/media-video/qmplay2/qmplay2-22.10.23.ebuild b/media-video/qmplay2/qmplay2-22.10.23.ebuild
new file mode 100644
index 000000000000..1ef2e8a50818
--- /dev/null
+++ b/media-video/qmplay2/qmplay2-22.10.23.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="A Qt-based video player, which can play most formats and codecs"
+HOMEPAGE="https://github.com/zaps166/QMPlay2"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zaps166/QMPlay2"
+else
+ SRC_URI="https://github.com/zaps166/QMPlay2/releases/download/${PV}/QMPlay2-src-${PV}.tar.xz"
+ S="${WORKDIR}/QMPlay2-src-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+IUSE="avdevice +audiofilters +alsa cdio cuvid extensions gme inputs libass
+ modplug notifications opengl pipewire portaudio pulseaudio sid shaders
+ +taglib vaapi vdpau videofilters visualizations vulkan xv"
+
+REQUIRED_USE="
+ audiofilters? ( || ( alsa pipewire portaudio pulseaudio ) )
+ shaders? ( vulkan )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-video/ffmpeg
+ || (
+ dev-qt/qtgui:5[X(-)]
+ dev-qt/qtgui:5[xcb(-)]
+ )
+ alsa? ( media-libs/alsa-lib )
+ cdio? ( dev-libs/libcdio[cddb] )
+ extensions? ( dev-qt/qtdeclarative:5 )
+ gme? ( media-libs/game-music-emu )
+ libass? ( media-libs/libass )
+ opengl? ( virtual/opengl )
+ pipewire? ( media-video/pipewire )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sid? ( media-libs/libsidplayfp )
+ shaders? ( >=media-libs/shaderc-2020.1 )
+ taglib? ( media-libs/taglib )
+ vaapi? (
+ >=media-video/ffmpeg-4.1.3[vaapi]
+ media-libs/libva[X]
+ )
+ vdpau? ( media-video/ffmpeg[vdpau] )
+ videofilters? ( dev-qt/qtconcurrent:5 )
+ vulkan? (
+ >=dev-qt/qtgui-5.14.1:5[vulkan]
+ >=media-libs/vulkan-loader-1.2.133
+ )
+ xv? ( x11-libs/libXv )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-includes.patch"
+)
+
+src_prepare() {
+ # disable compress man pages
+ sed -r \
+ -e 's/if\(GZIP\)/if\(TRUE\)/' \
+ -e 's/(install.+QMPlay2\.1)\.gz/\1/' \
+ -i src/gui/CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # core
+ -DUSE_LINK_TIME_OPTIMIZATION=false
+ -DUSE_UPDATES=OFF
+ -DUSE_ALSA=$(usex alsa)
+ -DUSE_AUDIOCD=$(usex cdio)
+ -DUSE_DBUS_SUSPEND=ON
+ -DUSE_FREEDESKTOP_NOTIFICATIONS=ON
+ -DUSE_LIBASS=$(usex libass)
+ -DUSE_NOTIFY=$(usex notifications)
+ -DUSE_OPENGL=$(usex opengl)
+ -DUSE_VULKAN=$(usex vulkan)
+ -DUSE_GLSLC=$(usex shaders)
+ -DUSE_XVIDEO=$(usex xv)
+
+ # ffmpeg
+ -DUSE_FFMPEG_AVDEVICE=$(usex avdevice)
+ -DUSE_FFMPEG_VAAPI=$(usex vaapi)
+ -DUSE_FFMPEG_VDPAU=$(usex vdpau)
+
+ # chiptune
+ -DUSE_CHIPTUNE_GME=$(usex gme)
+ -DUSE_CHIPTUNE_SID=$(usex sid)
+
+ # modules
+ -DUSE_AUDIOFILTERS=$(usex audiofilters)
+ -DUSE_CUVID=$(usex cuvid)
+ -DUSE_INPUTS=$(usex inputs)
+ -DUSE_MODPLUG=$(usex modplug)
+ -DUSE_PIPEWIRE=$(usex pipewire)
+ -DUSE_PORTAUDIO=$(usex portaudio)
+ -DUSE_PULSEAUDIO=$(usex pulseaudio)
+ -DUSE_TAGLIB=$(usex taglib)
+ -DUSE_VIDEOFILTERS=$(usex videofilters)
+ -DUSE_VISUALIZATIONS=$(usex visualizations)
+
+ # extensions
+ -DUSE_EXTENSIONS=$(usex extensions)
+ )
+
+ if use extensions; then
+ # Move inside an if, to remove unused option warning
+ mycmakeargs+=(
+ -DUSE_LASTFM=ON
+ -DUSE_LYRICS=ON
+ -DUSE_MEDIABROWSER=ON
+ -DUSE_MPRIS2=ON
+ )
+ fi
+
+ if [[ ${PV} == *9999 ]]; then
+ mycmakeargs+=( -DUSE_GIT_VERSION=true )
+ else
+ mycmakeargs+=( -DUSE_GIT_VERSION=false )
+ fi
+
+ cmake_src_configure
+}