summaryrefslogtreecommitdiff
path: root/media-video/noad/noad-0.8.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 08:00:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 08:00:22 +0000
commit8ba94db1fe69019bb2d3b4f50fe9d1ccf3d94b3a (patch)
tree7487d237046db5ece113639b353f68cee3cad04e /media-video/noad/noad-0.8.7.ebuild
parent7b744169f910185aacfd39dbd71d58b58a2e1d2f (diff)
gentoo auto-resync : 15:02:2023 - 08:00:21
Diffstat (limited to 'media-video/noad/noad-0.8.7.ebuild')
-rw-r--r--media-video/noad/noad-0.8.7.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/media-video/noad/noad-0.8.7.ebuild b/media-video/noad/noad-0.8.7.ebuild
deleted file mode 100644
index f89605e63649..000000000000
--- a/media-video/noad/noad-0.8.7.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools toolchain-funcs
-
-DESCRIPTION="Mark commercial breaks in VDR recordings"
-HOMEPAGE="https://github.com/madmartin/noad"
-SRC_URI="https://github.com/madmartin/noad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+ffmpeg imagemagick libmpeg2"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="
- libmpeg2? ( media-libs/libmpeg2:= )
- ffmpeg? ( media-video/ffmpeg )
- imagemagick? ( media-gfx/imagemagick )"
-RDEPEND="${DEPEND}"
-
-REQUIRED_USE="|| ( ffmpeg libmpeg2 )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(usex imagemagick '--with-magick') \
- $(usex ffmpeg '' '--without-ffmpeg') \
- $(usex libmpeg2 '' '--without-libmpeg2') \
- --with-tools
-}
-
-src_install() {
- dobin noad showindex checkMarks
- use imagemagick && dobin markpics
-
- dodoc README* INSTALL
- # example scripts are installed as dokumentation
- dodoc allnewnoad allnoad allnoadnice allnoaduncut checkAllMarks clearlogos noadcall.sh noadifnew stat2html statupd
-
- newconfd "${FILESDIR}"/confd_vdraddon.noad vdraddon.noad
-
- insinto /usr/share/vdr/record
- doins "${FILESDIR}"/record-50-noad.sh
-
- insinto /usr/share/vdr/shutdown
- doins "${FILESDIR}"/pre-shutdown-15-noad.sh
-
- insinto /etc/vdr/reccmds
- doins "${FILESDIR}"/reccmds.noad.conf
-
- exeinto /usr/share/vdr/bin
- doexe "${FILESDIR}"/noad-reccmd
-}
-
-pkg_postinst() {
- elog
- elog "To integrate noad in VDR you should do this:"
- elog
- elog "start and set Parameter in /etc/conf.d/vdraddon.noad"
- elog
- elog "Note: You can use here all parameters for noad,"
- elog "please look in the documentation of noad."
-}