summaryrefslogtreecommitdiff
path: root/media-video/noad/noad-0.8.6-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /media-video/noad/noad-0.8.6-r4.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'media-video/noad/noad-0.8.6-r4.ebuild')
-rw-r--r--media-video/noad/noad-0.8.6-r4.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/media-video/noad/noad-0.8.6-r4.ebuild b/media-video/noad/noad-0.8.6-r4.ebuild
deleted file mode 100644
index 170684dc966e..000000000000
--- a/media-video/noad/noad-0.8.6-r4.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools toolchain-funcs
-
-DESCRIPTION="Mark commercial breaks in VDR recordings"
-HOMEPAGE="https://github.com/madmartin/noad"
-SRC_URI="https://github.com/madmartin/noad/archive/v0.8.6.tar.gz -> ${P}.tar.gz
- http://vdr.websitec.de/download/${PN}/${P}-ffmpeg3.4.diff.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ffmpeg imagemagick libmpeg2"
-
-RDEPEND="
- libmpeg2? ( media-libs/libmpeg2:= )
- ffmpeg? ( virtual/ffmpeg )
- imagemagick? ( media-gfx/imagemagick )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-REQUIRED_USE="|| ( ffmpeg libmpeg2 )"
-
-src_prepare() {
- default
-
- #compile tested libav-13, ffmepg-3.4
- eapply "${WORKDIR}/${P}-ffmpeg3.4.diff"
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(usex imagemagick '--with-magick') \
- $(usex ffmpeg '' '--without-ffmpeg') \
- $(usex libmpeg2 '' '--without-libmpeg2') \
- --with-tools
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" # see bug #469810
-}
-
-src_install() {
- dobin noad showindex checkMarks
- use imagemagick && dobin markpics
-
- dodoc README INSTALL
- # example scripts are installed as dokumentation
- dodoc allnewnoad allnoad allnoadnice clearlogos noadcall.sh noadifnew stat2html statupd
-
- newconfd "${FILESDIR}"/confd_vdraddon.noad vdraddon.noad
-
- insinto /usr/share/vdr/record
- doins "${FILESDIR}"/record-50-noad.sh
-
- insinto /usr/share/vdr/shutdown
- doins "${FILESDIR}"/pre-shutdown-15-noad.sh
-
- insinto /etc/vdr/reccmds
- doins "${FILESDIR}"/reccmds.noad.conf
-
- exeinto /usr/share/vdr/bin
- doexe "${FILESDIR}"/noad-reccmd
-}
-
-pkg_postinst() {
- elog
- elog "To integrate noad in VDR you should do this:"
- elog
- elog "start and set Parameter in /etc/conf.d/vdraddon.noad"
- elog
- elog "Note: You can use here all parameters for noad,"
- elog "please look in the documentation of noad."
-}