summaryrefslogtreecommitdiff
path: root/media-video/mjpg-streamer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-10 23:34:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-10 23:34:33 +0000
commit0771aa27d30f102abe2c5733a138ffe570da4d15 (patch)
tree1ce3f24ab882caa90bf65381e4f0794872fc7d93 /media-video/mjpg-streamer
parent0bb42730e8fc9c8e571f12e3189c6c6f8d532c24 (diff)
gentoo auto-resync : 10:02:2024 - 23:34:33
Diffstat (limited to 'media-video/mjpg-streamer')
-rw-r--r--media-video/mjpg-streamer/Manifest1
-rw-r--r--media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r2.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/media-video/mjpg-streamer/Manifest b/media-video/mjpg-streamer/Manifest
index 388c1cfe3df1..2206f99914c4 100644
--- a/media-video/mjpg-streamer/Manifest
+++ b/media-video/mjpg-streamer/Manifest
@@ -6,4 +6,5 @@ DIST mjpg-streamer-0_pre20120621.tar.bz2 471546 BLAKE2B 3ede2a60062bba7c91ddfa0d
DIST mjpg-streamer-0_pre20200524.tar.gz 711183 BLAKE2B 3a40f20f518a53c0c6046cf37728c46c2a843a1dd0ef0086c77940b5133f1337445b1edb2c21edc1bbacc588f7c7b45b1530871c944695c2ae02cf327fde6847 SHA512 d6e910f6693b27c16c33749458affcb4d9336bd15c642156c452fcbc4a8c2ba9f4a6102e6b94f698fc6fb48da9564a09cb0f804a5ac52201e566adf798a70ba2
EBUILD mjpg-streamer-0_pre20120621-r2.ebuild 1879 BLAKE2B 1bc5482504e7ccae9c5de4240dc7033046761d82cf066f6f02f02ef9259c578dbb032f388566fa985a36a11598429b9b63896d320d2ccbe25beb97c6e92fd663 SHA512 d330b8e7015e62f72e146d2555522d38c97661bafb4c4b41e7953324523fc85175d6eb5a61c7827646b11efb85e6e9e34df811c770c4bbfe0f0ef0659d68cbed
EBUILD mjpg-streamer-0_pre20200524-r1.ebuild 3062 BLAKE2B 89b868577061d92b6cd37c0749ab627d1da0148b6fbda18c6cdbb9908ae3a1c0909da74eb31980cc4936ae918d0e89c55ac0eea2998637618ca1d10e151a2511 SHA512 a9e302dcc0befd0df2b65b4c43f01d11593ed8a18334614c5f94fe384522af01faff8b4d58c6d7b61c475df0ade90b313b9633284cb23d8a13f7dba9576716a8
+EBUILD mjpg-streamer-0_pre20200524-r2.ebuild 2947 BLAKE2B 607e721c9f08337cd5b7a200ac837fe46ad02dbe6f12c6ecabd2868b003f89df4c2f62893900e89aa35bd5f3d571ad0e817887cb10df1e706dec76fdbcd6ea55 SHA512 6ce0b05023ba3555c326932b151df44759488417fa5fa8c8c67423108777b979ccf34b4a4a014e5212cac4b439a86434d1e3bfc86a817a60cd764c4c0db0b653
MISC metadata.xml 2303 BLAKE2B b837eb93c8c63e864eb04c397f228206e132ee1451a914d7bc0d294761eb41861f00aba09a2bded4067fdd5434cb976e6d6df2ae092c8b6cc7afc561f35f2a61 SHA512 30c30baf3250ee16b0e8afee2ffd1dcf2784a06965e234cc6c2deb1839cd0c601fd78100e1f009e0df95ed2610cd78eea4ddc1e5d9c1f051fee67d6b17d06f35
diff --git a/media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r2.ebuild b/media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r2.ebuild
new file mode 100644
index 000000000000..4348f911ad5d
--- /dev/null
+++ b/media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="MJPG-streamer takes JPGs from Linux-UVC compatible webcams"
+HOMEPAGE="https://github.com/jacksonliam/mjpg-streamer"
+EGIT_COMMIT="85f89a8c321e799fabb1693c5d133f3fb48ee748"
+SRC_URI="https://github.com/jacksonliam/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+INPUT_PLUGINS="input-testpicture input-control input-file input-uvc input-http input-ptp2"
+OUTPUT_PLUGINS="output-file output-udp output-http output-autofocus output-rtsp output-viewer output-zmqserver"
+IUSE_PLUGINS="${INPUT_PLUGINS} ${OUTPUT_PLUGINS}"
+IUSE="input-testpicture input-control +input-file input-uvc input-http input-ptp2
+ output-file output-udp +output-http output-autofocus output-rtsp output-viewer output-zmqserver
+ www http-management wxp-compat"
+REQUIRED_USE="|| ( ${INPUT_PLUGINS} )
+ || ( ${OUTPUT_PLUGINS} )"
+
+RDEPEND="media-libs/libjpeg-turbo:=
+ input-uvc? ( media-libs/libv4l acct-group/video )
+ input-ptp2? ( media-libs/libgphoto2 )
+ output-zmqserver? (
+ dev-libs/protobuf-c
+ net-libs/zeromq
+ )"
+DEPEND="${RDEPEND}
+ input-testpicture? ( media-gfx/imagemagick )"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}/${PN}-experimental"
+
+src_prepare() {
+ sed -i -e "s|.*RPATH.*||g" CMakeLists.txt || die
+ if use wxp-compat; then
+ sed -i -e \
+ 's|^add_feature_option(WXP_COMPAT "Enable compatibility with WebcamXP" OFF)|add_feature_option(WXP_COMPAT "Enable compatibility with WebcamXP" ON)|g' \
+ CMakeLists.txt || die
+ fi
+
+ local flag switch
+ for flag in ${IUSE_PLUGINS}; do
+ use ${flag} && switch='' || switch='#'
+ flag=${flag/input-/input_}
+ flag=${flag/output-/output_}
+ sed -i -e \
+ "s|^add_subdirectory(plugins\/${flag})|${switch}add_subdirectory(plugins/${flag})|" \
+ CMakeLists.txt || die
+ done
+ if use http-management; then
+ sed -i -e \
+ 's|^add_feature_option(ENABLE_HTTP_MANAGEMENT "Enable experimental HTTP management option" OFF)|add_feature_option(ENABLE_HTTP_MANAGEMENT "Enable experimental HTTP management option" ON)|g' \
+ plugins/output_http/CMakeLists.txt || die
+ fi
+ sed -e "s|@LIBDIR@|$(get_libdir)/${PN}/$(get_libdir)|g" "${FILESDIR}/${PN}.initd" > ${PN}.initd || die
+
+ default
+}
+
+src_install() {
+ into /usr
+ dobin ${PN//-/_}
+ into "/usr/$(get_libdir)/${PN}"
+ dolib.so *.so
+
+ if use www ; then
+ insinto /usr/share/${PN}
+ doins -r www
+ fi
+
+ dodoc README.md TODO
+
+ newinitd ${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit mjpg_streamer@.service
+}
+
+pkg_postinst() {
+ einfo
+ elog "Remember to set an input and output plugin for mjpg-streamer."
+
+ if use input-uvc ; then
+ elog "To use the UVC plugin as a regular user, you must be a part of the video group"
+ fi
+
+ if use www ; then
+ einfo
+ elog "An example webinterface has been installed into"
+ elog "/usr/share/mjpg-streamer/www for your usage."
+ fi
+ einfo
+}