summaryrefslogtreecommitdiff
path: root/media-video/gxine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /media-video/gxine
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'media-video/gxine')
-rw-r--r--media-video/gxine/Manifest2
-rw-r--r--media-video/gxine/files/gxine-0.5.909-fno-common.patch22
-rw-r--r--media-video/gxine/gxine-0.5.909-r1.ebuild71
3 files changed, 95 insertions, 0 deletions
diff --git a/media-video/gxine/Manifest b/media-video/gxine/Manifest
index 0b7eebc01fa4..766d9e891c2e 100644
--- a/media-video/gxine/Manifest
+++ b/media-video/gxine/Manifest
@@ -1,3 +1,5 @@
+AUX gxine-0.5.909-fno-common.patch 559 BLAKE2B 070ac7218be823a96287e067fec31c3f7f70ab4d6aaff495eaea940e3cd77c3ef27d3f11b64c84a47bb5dd5352d855d996b91e32dd993a895771f2f5cd3a88a8 SHA512 6bff8ce76588f9a25e3006f0b669332d1f0dc0326334f449e7dd3b7f3840d8c0e631e8c301b7d7726d5ad9e3630dc50d318b2f918ab4f2508c60de06568a8030
DIST gxine-0.5.909.tar.xz 928544 BLAKE2B 4b649aca2602eafb5931f5f869d00d9e50f8e23c416bba0a661d895630f70840591cd3286626fc024deb45fe1484d8f640c2fb1412f536b665e6ff6b8091ce40 SHA512 87e65bb87fa416535f76253e4394447c6cd7dfaaa209b76c07b9aa81aeca0ca09399991bb2be8e6928fa3883ff61b155e173610c6c28aab10f5b1487e0699215
+EBUILD gxine-0.5.909-r1.ebuild 1532 BLAKE2B d228dacbd8115e5c5033f911b466aac2208c75e687ab66f8691f7bb7909437f957c2f35568ad71db30e840a8a88c72ad00347c76dcbc5ef686c029d4b64d24eb SHA512 604509ec7e0dc6a8d963a33358e4477e3a1138bcff69d4386767ca27163b225326b016cbbe690943d848e20cc7557b88d03af9eeaad5a10e29292e2c6b86f8b3
EBUILD gxine-0.5.909.ebuild 2040 BLAKE2B 68a161a5a1639615b8d976df2e78ba22a969140377e3bce3d4f900617b5074875e87243f8e1c76efd0eb9741dc193e0ff52e0fd7733b4de13a8624109dbe057e SHA512 4705f92285382af777273ae36d77ea72fae400f3cdc82ec5b1b6c9e21bc13848da73e1b968aa444b1f791c9ebb1422739155241fa6a55999ea968e8784e30e4b
MISC metadata.xml 305 BLAKE2B 0704c2d6ae4a0e249d693a63f719b4ec470a08e1cf1b64342571dad7514fd2a14616bf0812aa8f6a0732049c702ee3e00ab005c5b650723577526413c8337ad5 SHA512 396865e52e9dc380cbf6d3dbf33deb69877495356dc6c6a09ba35ab3062608a93e7ab3d5d22564192070ddc186f3a5ff9ceea639911cc554ca6db5084a413587
diff --git a/media-video/gxine/files/gxine-0.5.909-fno-common.patch b/media-video/gxine/files/gxine-0.5.909-fno-common.patch
new file mode 100644
index 000000000000..32ad6c3770b2
--- /dev/null
+++ b/media-video/gxine/files/gxine-0.5.909-fno-common.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/709306
+--- a/src/main.c
++++ b/src/main.c
+@@ -75,6 +75,7 @@
+ * globals
+ */
+
++extern int gxine_init_count;
+ int verbosity;
+ GtkWidget *app = NULL;
+ const char *plugindir, *bindir, *logodir, *pixmapdir, *icondir, *miscdir, *confdir;
+--- a/src/utils.h
++++ b/src/utils.h
+@@ -108,7 +108,7 @@ void do_pending_events (void);
+
+ const char *get_copyright_notice (void);
+
+-int gxine_init_count;
++extern int gxine_init_count;
+ static inline void gxine_init_add (GSourceFunc func, gpointer data)
+ {
+ ++gxine_init_count;
diff --git a/media-video/gxine/gxine-0.5.909-r1.ebuild b/media-video/gxine/gxine-0.5.909-r1.ebuild
new file mode 100644
index 000000000000..5c5965807691
--- /dev/null
+++ b/media-video/gxine/gxine-0.5.909-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="GTK+ Front-End for libxine"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="l10n_cs l10n_de lirc nls udev xinerama"
+
+DEPEND="
+ media-libs/xine-lib[gtk]
+ x11-libs/gtk+:2
+ dev-lang/spidermonkey:0
+ dev-libs/glib
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libxcb
+ lirc? ( app-misc/lirc )
+ nls? ( virtual/libintl )
+ udev? ( dev-libs/libgudev:= )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
+src_prepare() {
+ default
+ # need to disable calling of xine-list when running without
+ # userpriv, otherwise we get sandbox violations (bug #233847)
+ if [[ ${EUID} == 0 ]]; then
+ sed -i -e 's:^XINE_LIST=.*$:XINE_LIST=:' configure.ac || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-watchdog \
+ --with-xcb \
+ --without-browser-plugin \
+ --without-dbus \
+ --without-hal \
+ $(use_enable nls) \
+ $(use_enable lirc) \
+ $(use_with udev gudev) \
+ $(use_with xinerama)
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ docsdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
+
+ dodoc AUTHORS BUGS ChangeLog README{,_l10n} TODO
+
+ use l10n_cs && dodoc README.cs
+ use l10n_de && dodoc README.de
+}