summaryrefslogtreecommitdiff
path: root/media-video/ffmpeg/ffmpeg-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-10 01:33:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-10 01:33:06 +0100
commit1603847507a63218a29aada46e43f133d16d07eb (patch)
treed016ef447a3a8c16f799a1ac08cdd241e7893e39 /media-video/ffmpeg/ffmpeg-9999.ebuild
parent861ffe012c63c48053fb77b5110cbe900f651dfd (diff)
gentoo auto-resync : 10:10:2022 - 01:33:06
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild12
1 files changed, 2 insertions, 10 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 04786c9205ad..32bd6b856f20 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# Subslot: libavutil major.libavcodec major.libavformat major
# Since FFmpeg ships several libraries, subslot is kind of limited here.
@@ -498,14 +498,7 @@ multilib_src_configure() {
$(multilib_native_enable manpages)
)
- # Fixed in 5.0.1? Waiting for verification from someone who hit the issue.
- local extra_libs
- if use arm || use ppc || use mips || [[ ${CHOST} == *i486* ]] ; then
- # bug #782811
- # bug #790590
- extra_libs+="$(test-flags-CCLD -latomic) "
- fi
-
+ # Use --extra-libs if needed for LIBS
set -- "${S}/configure" \
--prefix="${EPREFIX}/usr" \
--libdir="${EPREFIX}/usr/$(get_libdir)" \
@@ -521,7 +514,6 @@ multilib_src_configure() {
--ranlib="$(tc-getRANLIB)" \
--pkg-config="$(tc-getPKG_CONFIG)" \
--optflags="${CFLAGS}" \
- --extra-libs="${extra_libs}" \
$(use_enable static-libs static) \
"${myconf[@]}" \
${EXTRA_FFMPEG_CONF}