summaryrefslogtreecommitdiff
path: root/media-video/bino/bino-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 06:00:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 06:00:45 +0000
commite660fe12946bfa241d169ebb2467939907de75d8 (patch)
tree4b2ba6aedbeadcf69d25b78526ac31be8e432a90 /media-video/bino/bino-2.0.ebuild
parentca7fcaa76aaf1f94284894a8d9a01bb153e80b11 (diff)
gentoo auto-resync : 20:01:2023 - 06:00:45
Diffstat (limited to 'media-video/bino/bino-2.0.ebuild')
-rw-r--r--media-video/bino/bino-2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-video/bino/bino-2.0.ebuild b/media-video/bino/bino-2.0.ebuild
new file mode 100644
index 000000000000..aafb2d96915f
--- /dev/null
+++ b/media-video/bino/bino-2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Stereoscopic and multi-display media player"
+HOMEPAGE="https://bino3d.org/"
+SRC_URI="https://bino3d.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtbase:6[gui,opengl,widgets]
+ dev-qt/qtmultimedia:6
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/qttools:6[linguist]
+ virtual/pandoc
+"
+
+src_compile() {
+ local mycmakeargs=(
+ # Unpackaged
+ -DCMAKE_DISABLE_FIND_PACKAGE_QVR=ON
+ )
+
+ cmake_src_configure
+}