summaryrefslogtreecommitdiff
path: root/media-tv/nvtv/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-tv/nvtv/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-tv/nvtv/files')
-rw-r--r--media-tv/nvtv/files/nvtv.start20
-rw-r--r--media-tv/nvtv/files/respect-cflags.patch31
2 files changed, 51 insertions, 0 deletions
diff --git a/media-tv/nvtv/files/nvtv.start b/media-tv/nvtv/files/nvtv.start
new file mode 100644
index 000000000000..57b471a0986b
--- /dev/null
+++ b/media-tv/nvtv/files/nvtv.start
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use modules logger
+}
+
+start() {
+ ebegin "Starting NVidia TV-Out Server"
+ start-stop-daemon --start --quiet --exec /usr/sbin/nvtvd \
+ --background 1>&2
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping NVidia TV-Out Server"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/nvtvd 1>&2
+ eend $?
+}
diff --git a/media-tv/nvtv/files/respect-cflags.patch b/media-tv/nvtv/files/respect-cflags.patch
new file mode 100644
index 000000000000..2fa991f72638
--- /dev/null
+++ b/media-tv/nvtv/files/respect-cflags.patch
@@ -0,0 +1,31 @@
+The rest of the build system will respect the user's CFLAGS if we
+don't wipe them out, so just delete the line that does that. The
+removal of the gtk-1.x stuff is so that we can run eautoreconf and
+have it work; we don't support gtk1 in Gentoo anyway.
+
+diff --git a/configure.in b/configure.in
+index f8f48cc..d8f1261 100755
+--- a/configure.in
++++ b/configure.in
+@@ -57,9 +57,6 @@ dnl
+ dnl Debugging enables, CFLAGS
+ dnl
+
+-dnl Clear -g -O2 from CFLAGS
+-CFLAGS=""
+-
+ AC_MSG_CHECKING(for debugging info)
+
+ AC_ARG_ENABLE(debug,
+@@ -110,11 +107,6 @@ if test ${with_gtk} = no ; then
+ fi
+
+ if test ${have_gtk} = no ; then
+- if test ${with_gtk} = yes -o ${with_gtk} = gtk1 ; then
+- AM_PATH_GTK(1.2.0, have_gtk=gtk1)
+- fi
+-fi
+-if test ${have_gtk} = no ; then
+ if test ${with_gtk} = yes -o ${with_gtk} = gtk2 ; then
+ AM_PATH_GTK_2_0(2.0.0, have_gtk=gtk2)
+ fi