summaryrefslogtreecommitdiff
path: root/media-tv/kodi/kodi-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /media-tv/kodi/kodi-9999.ebuild
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'media-tv/kodi/kodi-9999.ebuild')
-rw-r--r--media-tv/kodi/kodi-9999.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/media-tv/kodi/kodi-9999.ebuild b/media-tv/kodi/kodi-9999.ebuild
index 7a6c254d702f..e60c2a97fb5f 100644
--- a/media-tv/kodi/kodi-9999.ebuild
+++ b/media-tv/kodi/kodi-9999.ebuild
@@ -3,13 +3,13 @@
EAPI=7
-PYTHON_REQ_USE="libressl?,sqlite,ssl"
+PYTHON_REQ_USE="sqlite,ssl"
LIBDVDCSS_VERSION="1.4.2-Leia-Beta-5"
LIBDVDREAD_VERSION="6.0.0-Leia-Alpha-3"
LIBDVDNAV_VERSION="6.0.0-Leia-Alpha-3"
-FFMPEG_VERSION="4.3.2"
-CODENAME="Matrix"
-FFMPEG_KODI_VERSION="19.1"
+FFMPEG_VERSION="4.4"
+CODENAME="N"
+FFMPEG_KODI_VERSION="Alpha1"
PYTHON_COMPAT=( python3_{6,7,8,9} )
SRC_URI="https://github.com/xbmc/libdvdcss/archive/${LIBDVDCSS_VERSION}.tar.gz -> libdvdcss-${LIBDVDCSS_VERSION}.tar.gz
https://github.com/xbmc/libdvdread/archive/${LIBDVDREAD_VERSION}.tar.gz -> libdvdread-${LIBDVDREAD_VERSION}.tar.gz
@@ -39,7 +39,7 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus eventclients gbm gles lcms libressl libusb lirc mariadb mysql nfs +optical power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus eventclients gbm gles lcms libusb lirc mariadb mysql nfs +optical power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
IUSE="${IUSE} cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_arm_neon"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -107,8 +107,7 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
>=media-libs/taglib-1.11.1
system-ffmpeg? (
>=media-video/ffmpeg-${FFMPEG_VERSION}:=[dav1d?,encode,postproc]
- libressl? ( media-video/ffmpeg[libressl,-openssl] )
- !libressl? ( media-video/ffmpeg[-libressl,openssl] )
+ media-video/ffmpeg[openssl]
)
!system-ffmpeg? (
app-arch/bzip2
@@ -119,8 +118,7 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
>=net-misc/curl-7.68.0[http2]
nfs? ( >=net-fs/libnfs-2.0.0:= )
!gles? ( media-libs/glu )
- !libressl? ( >=dev-libs/openssl-1.0.2l:0= )
- libressl? ( dev-libs/libressl:0= )
+ >=dev-libs/openssl-1.0.2l:0=
raspberry-pi? (
|| ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin media-libs/mesa[egl,gles2,video_cards_vc4] )
)