summaryrefslogtreecommitdiff
path: root/media-tv/dvbtune/dvbtune-0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /media-tv/dvbtune/dvbtune-0.5-r1.ebuild
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'media-tv/dvbtune/dvbtune-0.5-r1.ebuild')
-rw-r--r--media-tv/dvbtune/dvbtune-0.5-r1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/media-tv/dvbtune/dvbtune-0.5-r1.ebuild b/media-tv/dvbtune/dvbtune-0.5-r1.ebuild
index ccd198855ffc..e4cb2c114c24 100644
--- a/media-tv/dvbtune/dvbtune-0.5-r1.ebuild
+++ b/media-tv/dvbtune/dvbtune-0.5-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch
+inherit toolchain-funcs
DESCRIPTION="simple tuning app for DVB cards"
HOMEPAGE="https://sourceforge.net/projects/dvbtools"
@@ -18,9 +18,15 @@ RDEPEND="xml? ( dev-libs/libxml2 )"
DEPEND="${RDEPEND}
virtual/linuxtv-dvb-headers"
+PATCHES=(
+ "${FILESDIR}"/${PF}-gentoo.diff
+ "${FILESDIR}"/${PN}-0.5-stdint.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PF}-gentoo.diff
- epatch "${FILESDIR}"/${PN}-0.5-stdint.patch
+ default
+
+ tc-export CC
}
src_compile() {