summaryrefslogtreecommitdiff
path: root/media-tv/dtv-scan-tables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /media-tv/dtv-scan-tables
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'media-tv/dtv-scan-tables')
-rw-r--r--media-tv/dtv-scan-tables/Manifest4
-rw-r--r--media-tv/dtv-scan-tables/dtv-scan-tables-0_p20171003.ebuild32
-rw-r--r--media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild32
-rw-r--r--media-tv/dtv-scan-tables/metadata.xml8
4 files changed, 76 insertions, 0 deletions
diff --git a/media-tv/dtv-scan-tables/Manifest b/media-tv/dtv-scan-tables/Manifest
new file mode 100644
index 000000000000..15fbdf54c8d0
--- /dev/null
+++ b/media-tv/dtv-scan-tables/Manifest
@@ -0,0 +1,4 @@
+DIST dtv-scan-tables-2017-10-03-c1986d5148d8.tar.bz2 168709 BLAKE2B fb4a7ad5b6892a7e7eed1d57ebb49b1f4493076f6f744953d2d5c51c0e1cf7fdaf864ad050c578c2697f5b11d72c245b96ee369522cb58d38a1a2cef035099a7 SHA512 e2b0cf8f52b536be6a532b4a2896421a8150fdc19613e92c92d0c8275fcfd306cb091db32fa26f97bbec0a51ef4ba61b5f98e8c974280a3f6dd36b67a3bf4aad
+EBUILD dtv-scan-tables-0_p20171003.ebuild 730 BLAKE2B 72e4c584017945a4cb3bd70c6966099c71f7817ee40532ac42bb7e8f80a3572b6110eab019f3fb678e3ef381096c60afe25df3a1535e4705f6b600170c8037fc SHA512 1db9fbc172bfef0df1948a37226b3349f6afc8ebef66a799717841314006924d33e2f34306bfcdd6893cae8b5799e7f3a529295f70df016df0b43e638741e753
+EBUILD dtv-scan-tables-9999.ebuild 730 BLAKE2B 72e4c584017945a4cb3bd70c6966099c71f7817ee40532ac42bb7e8f80a3572b6110eab019f3fb678e3ef381096c60afe25df3a1535e4705f6b600170c8037fc SHA512 1db9fbc172bfef0df1948a37226b3349f6afc8ebef66a799717841314006924d33e2f34306bfcdd6893cae8b5799e7f3a529295f70df016df0b43e638741e753
+MISC metadata.xml 247 BLAKE2B 158fa8dff063e01e64b4835fa1f199518ecf7d81282ee8c893efc0d4d73454e16adb3189ee8cd1272bbada6fb5ffc2b5aadbd796490c829cba1a4b8e3e20f29f SHA512 8bffd29ab89c8dc401ad49655e30a6bd3a953bf8f6c9309b318f3b03ed7bcf2e5c10533ac70967e549edcd512f6be13b9bce3e36175286370ba499dcb119f6fc
diff --git a/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20171003.ebuild b/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20171003.ebuild
new file mode 100644
index 000000000000..08c15c3ef583
--- /dev/null
+++ b/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20171003.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV#9999} != ${PV} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.linuxtv.org/dtv-scan-tables.git"
+else
+ COMMIT="c1986d5148d8"
+ SRC_URI="https://linuxtv.org/downloads/dtv-scan-tables/dtv-scan-tables-${PV:3:4}-${PV:7:2}-${PV:9:2}-${COMMIT}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/usr/share/dvb"
+fi
+
+DESCRIPTION="Digital TV scan tables in v3 and v5 format"
+HOMEPAGE="https://linuxtv.org/"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+DEPEND=">=media-tv/v4l-utils-1.4"
+
+DOCS=( README )
+
+src_compile() {
+ emake dvbv3 dvbv5
+}
+
+src_install() {
+ emake PREFIX="${ED}usr" install install_v3
+ einstalldocs
+}
diff --git a/media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild b/media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild
new file mode 100644
index 000000000000..08c15c3ef583
--- /dev/null
+++ b/media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV#9999} != ${PV} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.linuxtv.org/dtv-scan-tables.git"
+else
+ COMMIT="c1986d5148d8"
+ SRC_URI="https://linuxtv.org/downloads/dtv-scan-tables/dtv-scan-tables-${PV:3:4}-${PV:7:2}-${PV:9:2}-${COMMIT}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/usr/share/dvb"
+fi
+
+DESCRIPTION="Digital TV scan tables in v3 and v5 format"
+HOMEPAGE="https://linuxtv.org/"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+DEPEND=">=media-tv/v4l-utils-1.4"
+
+DOCS=( README )
+
+src_compile() {
+ emake dvbv3 dvbv5
+}
+
+src_install() {
+ emake PREFIX="${ED}usr" install install_v3
+ einstalldocs
+}
diff --git a/media-tv/dtv-scan-tables/metadata.xml b/media-tv/dtv-scan-tables/metadata.xml
new file mode 100644
index 000000000000..54be7ff7e5d6
--- /dev/null
+++ b/media-tv/dtv-scan-tables/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+</pkgmetadata>