summaryrefslogtreecommitdiff
path: root/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild')
-rw-r--r--media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild b/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild
new file mode 100644
index 000000000000..55e947d46ecc
--- /dev/null
+++ b/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV#9999} != ${PV} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.linuxtv.org/dtv-scan-tables.git"
+else
+ COMMIT="4181e93a30ab"
+ SRC_URI="https://linuxtv.org/downloads/dtv-scan-tables/dtv-scan-tables-${PV:3:4}-${PV:7:2}-${PV:9:2}-${COMMIT}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+ S="${WORKDIR}/usr/share/dvb"
+fi
+
+DESCRIPTION="Digital TV scan tables in v3 and v5 format"
+HOMEPAGE="https://linuxtv.org/"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=media-tv/v4l-utils-1.4[dvb(+)]"
+
+DOCS=( README )
+
+src_compile() {
+ emake dvbv3 dvbv5
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install install_v3
+ einstalldocs
+}