summaryrefslogtreecommitdiff
path: root/media-sound
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-26 15:09:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-26 15:09:32 +0100
commitf3a881e4cb31d574a107320b2f04e2d1f0ddf551 (patch)
tree0fb407d14cee6b3da0742b5060c92e9accb07fe0 /media-sound
parent720452fca3cdf447b4c65bc3bb363032a983309e (diff)
gentoo auto-resync : 26:05:2023 - 15:09:32
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/Manifest.gzbin56907 -> 56905 bytes
-rw-r--r--media-sound/pithos/Manifest2
-rw-r--r--media-sound/pithos/pithos-1.6.1.ebuild69
-rw-r--r--media-sound/playerctl/Manifest2
-rw-r--r--media-sound/playerctl/playerctl-2.4.1.ebuild54
5 files changed, 127 insertions, 0 deletions
diff --git a/media-sound/Manifest.gz b/media-sound/Manifest.gz
index 6daffadc9526..7ca7d04fbbbd 100644
--- a/media-sound/Manifest.gz
+++ b/media-sound/Manifest.gz
Binary files differ
diff --git a/media-sound/pithos/Manifest b/media-sound/pithos/Manifest
index 4f13f2564b53..e8503b8f9e64 100644
--- a/media-sound/pithos/Manifest
+++ b/media-sound/pithos/Manifest
@@ -1,3 +1,5 @@
DIST pithos-1.6.0.tar.gz 122025 BLAKE2B c621fe58998790f0eb0159d29c40ac4abf2feff2be790c12008be86387bf628b170e3256c2f3ac83e9b2be254d96d4aa7e3e56ac780b0d59a446d0e158d96d15 SHA512 9e7b1d1456a769882a58639bf93194ec0228d21b7b7d1404224346016532620bb862e7d79a2c741d8ef44238c22741e4fd67bc22eadc8d207818a0ece33411ab
+DIST pithos-1.6.1.tar.xz 99552 BLAKE2B 048071e4c1df0cf517de64fa19cbe589972c8a34eea2f068c7d183726523c633ce36cc87344e13a8bb31d6aa4a08365b1e9691e822e5d9a7224c318dbfd7df1e SHA512 e1a13d2c789e40bf135ed551d06dfe44bf948bfe84a8bbb3f4afcab70bbcdc4f1d3f82d25f5e8d930888dd6fa04795fa2d9d47515d4199647be854c9c4a84591
EBUILD pithos-1.6.0.ebuild 1545 BLAKE2B f883241547087ea7383bbc12e44c2e34ee86b1656db7fde1d3151bc9e91ed6e45dc4f05f44be3415cc20980eede48d0e0400cb9d2feedc02ad156355a5b184e9 SHA512 16240602fb4f0fadfc51ffdf7be44f0ea30cc1314a56ba356db999147f155b287dda55792d34e4757c092965ff79bad57732d860647102762eeddd189977d468
+EBUILD pithos-1.6.1.ebuild 1548 BLAKE2B d44e1e384ceadabbc7ad813b1e9bc3b619b04778034ac43ca19eee56d6f1ea7bbaafb2591ec633d0edb9889b8c9399222ed11905cd0cb1174a4bff6deb7730f7 SHA512 d32c8834393d616f4b6428a16e28421c002b57b17a0b88bea8983d0d8bce6565f82c2ad94bc9eb0d20591620c8b3dbe8e568805e1ee6246fdddbeb52a9cce98f
MISC metadata.xml 419 BLAKE2B 9e01f2ec478f85435261e38e84ee433d9712c7d595979c916af2d2c01a5954ec0f721b0170fb32109d6a98dbef358d8f63e00a1908c6c5f38b183eb6a0e0882a SHA512 3bf8a538a46181b7ba52f20832237a119a87aaa588a7a75a0a1d881a64110805427f27a25d4f8277ec249b40218b21d291cdb21c98616a57396d0ae20b6345c9
diff --git a/media-sound/pithos/pithos-1.6.1.ebuild b/media-sound/pithos/pithos-1.6.1.ebuild
new file mode 100644
index 000000000000..5a854cf42454
--- /dev/null
+++ b/media-sound/pithos/pithos-1.6.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit xdg meson gnome2-utils virtualx python-r1
+
+DESCRIPTION="Pandora.com client for the GNOME desktop"
+HOMEPAGE="https://pithos.github.io/"
+SRC_URI="https://github.com/pithos/pithos/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="appindicator +keybinder libnotify test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ app-crypt/libsecret[introspection]
+ dev-libs/appstream-glib[introspection]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pylast[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0[aac,http,mp3]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/gnome-icon-theme-symbolic
+ appindicator? ( dev-libs/libdbusmenu[gtk3,introspection] )
+ keybinder? ( dev-libs/keybinder:3[introspection] )
+ libnotify? ( x11-libs/libnotify[introspection] )
+"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-libs/glib:2
+ dev-util/desktop-file-utils
+ )
+"
+
+src_configure() {
+ python_foreach_impl meson_src_configure
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ virtx python_foreach_impl meson_src_test
+}
+
+src_install() {
+ python_foreach_impl meson_src_install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}
diff --git a/media-sound/playerctl/Manifest b/media-sound/playerctl/Manifest
index 7c703f387105..b98670f4d56c 100644
--- a/media-sound/playerctl/Manifest
+++ b/media-sound/playerctl/Manifest
@@ -1,3 +1,5 @@
DIST playerctl-2.3.1.tar.gz 73595 BLAKE2B d6d60d82fb0a8951fba4a3de91ff1e3f4bdba7177563b65b2da53525af4ca40f42755c577f652aaa24d2de308f56a495c8f87840ad67d6cda840cba1411abdb0 SHA512 06a10d193c83f60a9a9c50dddfb0a74e00be8cde34ddaa9d75582b7ce487ac564d1ff0675f6cb0c27d968e7d435b6a427818ac14e0cdd94b86af8f5d89661a93
+DIST playerctl-2.4.1.tar.gz 77371 BLAKE2B ae9f691d714d6235bd7dc3e3d9a2ed21190482bd2aa8642c108ade0c09902ccb20196d0180ed3b1ffe680ca4e6a4ee293de1a6f10d54878589e3d8c81ca81c53 SHA512 2d84f657b07c948cd6990d9e79c4eb6e83f97c387ac53c2322fc0adbeb853950fa935332233329e7555db7d157f3ced6498cc102edaffd78849ca1f7d4c49bdc
EBUILD playerctl-2.3.1.ebuild 1202 BLAKE2B a6aa753d25f13e67f3c07ad2c84eb5a8cfca681fdf79b104697e775495fdcd79834a0f455bf9975713768e15b37c3d895468f897dc58dcb5cb6501f9fc1d7542 SHA512 d542fecca06ef234072c715be3ccca5771864eeb05112750ac30376e95655e4833d6fe1d44f060a4f556b853f1d27f7cfdc956f1179ac1a0f3639a8eba33b418
+EBUILD playerctl-2.4.1.ebuild 1212 BLAKE2B a4e2c1675096a87e8c44b3d9bd48a71f5f5da1fb9a2ddc8205b97cc4b4c463017d7639c99a5a7e0f688ac493e05dbf0dca3f3fa8a1dcaae62ffe35d820872c65 SHA512 fdaea7744cac060bc85b341f738a16c8ec5d5fb5681f96bd9a38f106f8c1e994f176e41b1ed56fea547a3d6f5973521ce1e2c74a5b8d6aec09f3ffa77bfbc9eb
MISC metadata.xml 344 BLAKE2B 291e21642ebc0aed630579a079c007dc54669960a8b2e68f8a62f199a1cf308f0d020118fedfbd5693010d2de61f1c7b6488acf720508422493cf3e83f1ac466 SHA512 d7df9fd6e2a27888c608dd8a39461145489bbaef13fe83d0bde941adba3a496106b62ae33562a89bbb0dfa718785104f57a11fba3cc73a18edbeb5990a7c6a5f
diff --git a/media-sound/playerctl/playerctl-2.4.1.ebuild b/media-sound/playerctl/playerctl-2.4.1.ebuild
new file mode 100644
index 000000000000..710b5c8ab50a
--- /dev/null
+++ b/media-sound/playerctl/playerctl-2.4.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 meson xdg
+
+DESCRIPTION="A CLI utility to control media players over MPRIS"
+HOMEPAGE="https://github.com/acrisci/playerctl"
+SRC_URI="https://github.com/acrisci/playerctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc introspection"
+RESTRICT="test" # Seems to want a system bus, rather than a session one?
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddatadir=share
+ -Dbindir=bin
+ -Dbash-completions=false
+ -Dzsh-completions=false
+ $(meson_use doc gtk-doc)
+ $(meson_use introspection)
+ )
+
+ xdg_environment_reset # bug #596166
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+
+ newbashcomp data/playerctl.bash "${PN}"
+ insinto /usr/share/zsh/site-functions
+ newins data/playerctl.zsh _playerctl
+}