summaryrefslogtreecommitdiff
path: root/media-sound/xwax/xwax-1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /media-sound/xwax/xwax-1.6.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'media-sound/xwax/xwax-1.6.ebuild')
-rw-r--r--media-sound/xwax/xwax-1.6.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/media-sound/xwax/xwax-1.6.ebuild b/media-sound/xwax/xwax-1.6.ebuild
index 89ce08abad33..d265c8017b5c 100644
--- a/media-sound/xwax/xwax-1.6.ebuild
+++ b/media-sound/xwax/xwax-1.6.ebuild
@@ -1,35 +1,40 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit toolchain-funcs user
DESCRIPTION="Digital vinyl emulation software"
-HOMEPAGE="http://xwax.org/"
-SRC_URI="http://xwax.org/releases/${P}.tar.gz"
+HOMEPAGE="https://xwax.org/"
+SRC_URI="https://xwax.org/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="alsa jack oss cdda mp3 +fallback"
+
REQUIRED_USE="|| ( cdda mp3 fallback )
|| ( alsa jack oss )"
-RDEPEND="sys-libs/glibc
- sys-libs/pam
+DEPEND="
+ media-fonts/dejavu
media-libs/libsdl
media-libs/sdl-ttf
- media-fonts/dejavu
+ sys-libs/glibc
+ sys-libs/pam
alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )
cdda? ( media-sound/cdparanoia )
+ fallback? ( virtual/ffmpeg )
+ jack? ( media-sound/jack-audio-connection-kit )
mp3? ( media-sound/mpg123 )
- fallback? ( virtual/ffmpeg )"
-DEPEND="${RDEPEND}"
+"
+RDEPEND="${DEPEND}"
-DOCS="README CHANGES"
+DOCS=( README CHANGES )
src_prepare() {
+ default
# Remove the forced optimization from 'CFLAGS' and 'LDFLAGS' in
# the Makefile
# Also remove the dependency on the .version target so we don't need
@@ -42,7 +47,7 @@ src_prepare() {
src_configure() {
tc-export CC
econf \
- --prefix "${EROOT}usr" \
+ --prefix "${EROOT}/usr" \
$(use_enable alsa) \
$(use_enable jack) \
$(use_enable oss)