summaryrefslogtreecommitdiff
path: root/media-sound/wavegain/wavegain-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/wavegain/wavegain-1.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/wavegain/wavegain-1.3.1.ebuild')
-rw-r--r--media-sound/wavegain/wavegain-1.3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/wavegain/wavegain-1.3.1.ebuild b/media-sound/wavegain/wavegain-1.3.1.ebuild
new file mode 100644
index 000000000000..82d8dd18cfcc
--- /dev/null
+++ b/media-sound/wavegain/wavegain-1.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="ReplayGain for WAVE audio files"
+HOMEPAGE="http://www.rarewares.org/files/others/"
+SRC_URI="http://www.rarewares.org/files/others/${P}srcs.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P/wavegain/WaveGain}
+
+src_compile(){
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} *.c -o ${PN} \
+ -DHAVE_CONFIG_H -lm || die "build failed"
+}
+
+src_install(){
+ dobin ${PN}
+}