summaryrefslogtreecommitdiff
path: root/media-sound/vimpc/vimpc-0.09.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/vimpc/vimpc-0.09.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/vimpc/vimpc-0.09.1.ebuild')
-rw-r--r--media-sound/vimpc/vimpc-0.09.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/vimpc/vimpc-0.09.1.ebuild b/media-sound/vimpc/vimpc-0.09.1.ebuild
new file mode 100644
index 000000000000..832b0849f58a
--- /dev/null
+++ b/media-sound/vimpc/vimpc-0.09.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="An ncurses based mpd client with vi like key bindings"
+HOMEPAGE="http://vimpc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/Release%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="boost taglib"
+
+RDEPEND="dev-libs/libpcre
+ media-libs/libmpdclient
+ boost? ( dev-libs/boost )
+ taglib? ( media-libs/taglib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS README.md doc/vimpcrc.example )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable boost) \
+ $(use_enable taglib) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+
+ # vimpc will look for help.txt
+ docompress -x /usr/share/doc/${PF}/help.txt
+}