summaryrefslogtreecommitdiff
path: root/media-sound/vbrfixc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /media-sound/vbrfixc
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'media-sound/vbrfixc')
-rw-r--r--media-sound/vbrfixc/Manifest4
-rw-r--r--media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch28
-rw-r--r--media-sound/vbrfixc/vbrfixc-0.24-r1.ebuild (renamed from media-sound/vbrfixc/vbrfixc-0.24.ebuild)14
3 files changed, 31 insertions, 15 deletions
diff --git a/media-sound/vbrfixc/Manifest b/media-sound/vbrfixc/Manifest
index e6f8c0e42809..aa43f36cbcdc 100644
--- a/media-sound/vbrfixc/Manifest
+++ b/media-sound/vbrfixc/Manifest
@@ -1,4 +1,4 @@
-AUX vbrfixc-0.24-gcc43.patch 489 BLAKE2B b55b18d7fdd37c0400547abd5f837b2023936889fe7a1812a996919138e476141e7f579db8bc291a6433fc71bc812e80546afe5ff8a813ea7299d994cbcdf365 SHA512 c79a4cb19016a055d2bc460f312798ae2e4626b0151f0f026a1ba0697cc5d3079c79f4e7d131c893f810c5f27ce835625e4533e172b96f0e811aecc7f02dbd9f
+AUX vbrfixc-0.24-gcc43.patch 1207 BLAKE2B 0a380a5e40072999cc8bbe4bb063c93214ffe6304dc66f3683c1447f4a6266d138183e8660a26907cadd924689a93847a4c257496042b3bf0027a7e5af691f1e SHA512 23926f5396291fc0af65db57ec8f28b12fd5291fc2776e0b79bff41ae73ea6f27ec2b58dff70bd19029bd2ce3c419f52761fa32e8eb583c14dc9d8b30725da51
DIST vbrfixc-0.24.tar.gz 656877 BLAKE2B df6e7a31e19d78abcd05781e3d346318ff9b3a091f92cac747862c67baa5b54f6290df3e10e7aa366c7fd7756f4ea340f4cecbc8ad44d22cd6bd943d0fe04584 SHA512 afc6db7ba53999de9b601c0cf65583ae0d0c3ca5177ea0da04d53fdb41d3dd75492b75ec5d7ddf37ec9447888c2afde03d07fb5d090a495f8a51507a2aede745
-EBUILD vbrfixc-0.24.ebuild 548 BLAKE2B 2eb13aff2c32ce583b915dfc12e7a9fe8adbc9d98409032deb37ab5c4449404dd6d41e3109d06f896f4274fcdd73e87baccac698ffea8b0e149b236a3c5deefb SHA512 75a08623a1aeff90ee4bc2548c4c54bab4633e9e426c7ca56177407307a5face3845353bfc497eb27d82091d94a8de810951c475c3cb4aef2be1efdf0dc7cec5
+EBUILD vbrfixc-0.24-r1.ebuild 528 BLAKE2B 885f3f4ea9619338fec2d1498176998b7ea3d1115b0f6844881c4b0ef91b683e3ec51134259c935009ed33a389b4bbbcfd3c0895d4a343114c20cd995d4ba8e2 SHA512 b30e9cb6c7248e50f711af56cd0f8d78f5a381ee187fb36d78fb935102971a90be64597111101379a029b7ee94619f610f179c9fa99e3ed4c21d4c7399a7a033
MISC metadata.xml 439 BLAKE2B 2e4181c2d65bc6847fcbd2ad4e3a067437f353947eb290ed3bc2bbe112ce6917f68893b26249abce53e71741314fad352e672f87d895003c157c48d6d1d1711d SHA512 b621aad7c558c9ea08064b9d93467b94f808f87f46256afc8d1d741cbb08d20d4a859cf55fb466d04e3ee03f6a832d76e8e7cf666efd7d0c45f6d2c343603d89
diff --git a/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch b/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch
index 89e20e3aade0..d2473e81d8f5 100644
--- a/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch
+++ b/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch
@@ -1,11 +1,31 @@
-diff -ur vbrfixc-0.24/vbrfixc/vbrfix.cpp vbrfixc-0.24.dmd/vbrfixc/vbrfix.cpp
---- vbrfixc-0.24/vbrfixc/vbrfix.cpp 2003-07-17 13:58:21.000000000 -0400
-+++ vbrfixc-0.24.dmd/vbrfixc/vbrfix.cpp 2008-06-11 11:26:42.000000000 -0400
-@@ -16,6 +16,7 @@
+--- a/vbrfixc/vbrfix.cpp
++++ b/vbrfixc/vbrfix.cpp
+@@ -16,6 +16,8 @@
***************************************************************************/
#include "vbrfix.h"
//#include "stdafx.h"//include in mfc version
+#include <cstring>
++#include <stdint.h>
int getXHpos(int ver,int chan);
VbrFix::VbrFix(){
frameptrs=NULL;flags=0;
+@@ -295,7 +297,7 @@
+ }
+ lyrics3Pos=mp3.getpos()-8-4;
+ //find its length
+- bool e=false;unsigned char c;uint correctv1=0,correctv2=0,p=0;char ev1[]="LYRICSEND";char ev2[]="LYRICS200";
++ bool e=false;unsigned char c;uint32_t correctv1=0,correctv2=0,p=0;char ev1[]="LYRICSEND";char ev2[]="LYRICS200";
+ while(!e && mp3.getpos()< mp3length){
+ mp3.fRead(&c,1);
+ if(c==255){logi("Error byte value of 255 in the lyrics3 tag!, asuming tag has ended");e=true;}
+--- a/vbrfixc/wputil.h
++++ b/vbrfixc/wputil.h
+@@ -199,7 +199,7 @@
+ ofstream out(output, ios::out|ios::binary|ios::trunc);
+ if(out.fail())return false;
+ // fast portable file copy
+- return out << in.rdbuf();
++ return bool(out << in.rdbuf());
+ }
+ static wps loadSetting(const char *file,wps setting,wps defaultValue){
+ ifstream in(file, ios::in);
diff --git a/media-sound/vbrfixc/vbrfixc-0.24.ebuild b/media-sound/vbrfixc/vbrfixc-0.24-r1.ebuild
index 696cce119952..6aea3451bdef 100644
--- a/media-sound/vbrfixc/vbrfixc-0.24.ebuild
+++ b/media-sound/vbrfixc/vbrfixc-0.24-r1.ebuild
@@ -1,22 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Vbrfix fixes MP3s and re-constructs VBR headers"
-HOMEPAGE="http://home.gna.org/vbrfix/"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="ftp://mirror.bytemark.co.uk/gentoo/distfiles/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-# bin endian ones need vbrfixc-0.24-bigendian.diff from gentoo-x86 cvs Attic
+# big-endian ones need vbrfixc-0.24-bigendian.diff from gentoo-x86 cvs Attic
KEYWORDS="amd64 x86"
-IUSE=""
-DEPEND=""
-RDEPEND=""
-
-PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+PATCHES=( "${FILESDIR}"/${P}-gcc43.patch )
src_install() {
HTML_DOCS=( vbrfixc/docs/en/*.html )