summaryrefslogtreecommitdiff
path: root/media-sound/umix/umix-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/umix/umix-1.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/umix/umix-1.0.2.ebuild')
-rw-r--r--media-sound/umix/umix-1.0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-sound/umix/umix-1.0.2.ebuild b/media-sound/umix/umix-1.0.2.ebuild
new file mode 100644
index 000000000000..959d3b10f057
--- /dev/null
+++ b/media-sound/umix/umix-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+IUSE="ncurses oss"
+
+DESCRIPTION="Program for adjusting soundcard volumes"
+HOMEPAGE="http://umix.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ppc sparc x86"
+
+DEPEND="ncurses? ( >=sys-libs/ncurses-5.2 )"
+
+src_compile() {
+ local myconf
+ use ncurses || myconf="--disable-ncurses"
+ use oss || myconf="${myconf} --disable-oss"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}