summaryrefslogtreecommitdiff
path: root/media-sound/timemachine/timemachine-0.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /media-sound/timemachine/timemachine-0.3.4.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'media-sound/timemachine/timemachine-0.3.4.ebuild')
-rw-r--r--media-sound/timemachine/timemachine-0.3.4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/timemachine/timemachine-0.3.4.ebuild b/media-sound/timemachine/timemachine-0.3.4.ebuild
new file mode 100644
index 000000000000..459c251e230a
--- /dev/null
+++ b/media-sound/timemachine/timemachine-0.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop xdg
+
+DESCRIPTION="JACK client record button remembering the last 10 seconds when pressed"
+HOMEPAGE="http://plugin.org.uk/timemachine/"
+SRC_URI="https://github.com/swh/timemachine/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="lash"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ virtual/jack
+ x11-libs/gtk+:2
+ media-libs/liblo
+ >=media-libs/libsndfile-1.0.5
+ lash? ( >=media-sound/lash-0.5 )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-underlinking.patch" )
+
+src_prepare() {
+ mv configure.{in,ac} || die
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lash)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ newicon pixmaps/timemachine-icon.png "${PN}.png"
+
+ make_desktop_entry timemachine "TimeMachine Recording" timemachine
+}