summaryrefslogtreecommitdiff
path: root/media-sound/synaesthesia
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-20 11:11:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-20 11:11:53 +0100
commit2ce67506e52bee4f16032b08b1be9cee9e84e10d (patch)
treee1d7d7604754a8c356d3e93ed7fabb5221cb3976 /media-sound/synaesthesia
parent0bb372e16b84da4809f561d11ffaa30e983ab26d (diff)
gentoo auto-resync : 20:09:2023 - 11:11:53
Diffstat (limited to 'media-sound/synaesthesia')
-rw-r--r--media-sound/synaesthesia/Manifest2
-rw-r--r--media-sound/synaesthesia/files/synaesthesia-2.4-dropping-register.patch145
-rw-r--r--media-sound/synaesthesia/synaesthesia-2.4-r2.ebuild25
3 files changed, 172 insertions, 0 deletions
diff --git a/media-sound/synaesthesia/Manifest b/media-sound/synaesthesia/Manifest
index 6c61b5e35335..79b4b1fd5a8e 100644
--- a/media-sound/synaesthesia/Manifest
+++ b/media-sound/synaesthesia/Manifest
@@ -1,5 +1,7 @@
+AUX synaesthesia-2.4-dropping-register.patch 5227 BLAKE2B 208ee19e77fcc6e201389ac5a4824ba4ec01d0ad5affb8ea37d90b51844ff35db4278154f11095031c2f7a0690dafdef4698f4bc4f3836fecfc72f372f031881 SHA512 3dafdcd37960fedafd5debdbb78d58129cd4529cc79d200585adfae91d08dcb71a738cfa19b6d2e8d69d6e65794f86de4a6d82328a96205c0ad8cd539e5e6758
AUX synaesthesia-2.4-inline-keyword.patch 558 BLAKE2B aaf978da81fa7edbffbf479c16fa51db7a765a3889356d724dde2d1a2f342b853077d020429b983c9fda75b19f4d7833015b7a5e645cc50d0e389d6aad58ebec SHA512 468e9e94428adc8a639f647be8ebdee9d5c4b0a91489666a1afcf0e19d9eb26825d36ed9968502cf9926e19124d7d1af0d3f27aa375967d4255976b9932bb4d6
AUX synaesthesia-2.4-respect-flags.patch 187 BLAKE2B 96739009fca0649c417b82c281c90f91aac4674e8f432f8be54b5d75a01586f86f84b8f05cfe8839c3ffc6b96e25446d99c492e8b6fe2fc686e9abd7edfe6db7 SHA512 c1a8fc2ef1c5f0bab7ed0cadb183082aff00a9484b25ded5c095653634df9bd69252ecbb3c6ea37ae77edf5423d04a4a60336db9669c44388af17f39b0eee3cc
DIST synaesthesia-2.4.tar.gz 259531 BLAKE2B 2ecf15a58793de77addb2dc2ab6d7640902c4a34838cff158d7bf9ce0ea5ee171cc205d2c8d9ee3a07d5434fd8e0e48f0cf1bf8c9d5b53de9cb9b70799cfc9c7 SHA512 e48f210f055486aa0a7c9a03f6aa7ff6a3292a2b598bfd8536dd592c3934b7672ed0b9b7dfc20427b5ea2b4cd1dcd6e104bf2c41f80ec38ab0b4b0a9497ff905
EBUILD synaesthesia-2.4-r1.ebuild 608 BLAKE2B 5af19d266c0e1a92629970742e222b158cbb239c29aab632557391c4a3b6968460fc81e11077dc2adbea4d03908379ce5164a79a4b7bb5e0d174a4212510ef64 SHA512 e79d716f04dd789ecd88f1dd5703dbeeb99581a7aa99c8bbf0e625a4bb2838bae9178e0371c8d616e00b80b8fb9d66d0cec89f34f0fb378ac5388c9ac6e586d6
+EBUILD synaesthesia-2.4-r2.ebuild 596 BLAKE2B fa3233c0783d7a86bde2b3ef4829ab8e1e4c4375acde28ee5ee3800ff3b4c135dac7052e0890050abaa44aab5f750ed8a8fca8ea291587cc1d7a6f429c365963 SHA512 1eb6d9c62be2d9bcc6e40db3dfcdeb10b67181dea603a62a20205f91372ee1d29151532d40931cf24101effc2b2ea79dc0a7f1f45afc7f598d4675fc16f1ea20
MISC metadata.xml 250 BLAKE2B 3e6dae5d5f3b3ac412806dd8615a1975c7ea8a64bfd72ad54f2c93a9b24c19c620ac3e8b26e1f6cadec899443e138ee4fb7a82ecb83c784d0c03ee91854d8622 SHA512 2bfce2cf73aefce6dda06ea351cb93b2990b9543f48be1ae5406a5a5acf2c34faed1eb2ce715eb689eb50a9a1add5576b39232eb818c233f5a5589e16032aca8
diff --git a/media-sound/synaesthesia/files/synaesthesia-2.4-dropping-register.patch b/media-sound/synaesthesia/files/synaesthesia-2.4-dropping-register.patch
new file mode 100644
index 000000000000..b45e168e1ab4
--- /dev/null
+++ b/media-sound/synaesthesia/files/synaesthesia-2.4-dropping-register.patch
@@ -0,0 +1,145 @@
+# The register keyword has been deprecated since c++14 and completely removed since c++17
+# Hence dropping the keyword
+# Bug: https://bugs.gentoo.org/897798
+--- a/core.cc
++++ b/core.cc
+@@ -117,7 +117,7 @@ inline void addPixelFast(unsigned char *p,int br1,int br2) {
+ }
+
+ void fadeFade() {
+- register uint32_t *ptr = (uint32_t*)output;
++ uint32_t *ptr = (uint32_t*)output;
+ int i = outWidth*outHeight*2/sizeof(uint32_t);
+ do {
+ //Bytewize version was: *(ptr++) -= *ptr+(*ptr>>1)>>4;
+--- a/sdlwrap.cc
++++ b/sdlwrap.cc
+@@ -171,19 +171,19 @@ void SdlScreen::show(void) {
+ attempt(SDL_LockSurface(surface),"locking screen for output.");
+
+ if (scaling == 1) {
+- register uint32_t *ptr2 = (uint32_t*)output;
++ uint32_t *ptr2 = (uint32_t*)output;
+ uint32_t *ptr1 = (uint32_t*)( surface->pixels );
+ int i = outWidth*outHeight/sizeof(*ptr2);
+
+ do {
+ // Asger Alstrup Nielsen's (alstrup@diku.dk)
+ // optimized 32 bit screen loop
+- register unsigned int const r1 = *(ptr2++);
+- register unsigned int const r2 = *(ptr2++);
++ unsigned int const r1 = *(ptr2++);
++ unsigned int const r2 = *(ptr2++);
+
+ //if (r1 || r2) {
+ #ifdef LITTLEENDIAN
+- register unsigned int const v =
++ unsigned int const v =
+ ((r1 & 0x000000f0ul) >> 4)
+ | ((r1 & 0x0000f000ul) >> 8)
+ | ((r1 & 0x00f00000ul) >> 12)
+@@ -194,7 +194,7 @@ void SdlScreen::show(void) {
+ | ((r2 & 0x00f00000ul) << 4)
+ | ((r2 & 0xf0000000ul)));
+ #else
+- register unsigned int const v =
++ unsigned int const v =
+ ((r2 & 0x000000f0ul) >> 4)
+ | ((r2 & 0x0000f000ul) >> 8)
+ | ((r2 & 0x00f00000ul) >> 12)
+--- a/svgawrap.cc
++++ b/svgawrap.cc
+@@ -120,7 +120,7 @@ void SvgaScreen::inputUpdate(int &mouseX,int &mouseY,int &mouseButtons,char &key
+ }
+
+ void SvgaScreen::show(void) {
+- register uint32_t *ptr2 = (uint32_t*)output;
++ uint32_t *ptr2 = (uint32_t*)output;
+ uint32_t *ptr1 = (uint32_t*)scr;
+ int i = 320*200/sizeof(uint32_t);
+ // Asger Alstrup Nielsen's (alstrup@diku.dk)
+@@ -129,15 +129,15 @@ void SvgaScreen::show(void) {
+ //Original bytewize version:
+ //unsigned char v = (*(ptr2++)&15*16);
+ //*(ptr1++) = v|(*(ptr2++)>>4);
+- register uint32_t const r1 = *(ptr2++);
+- register uint32_t const r2 = *(ptr2++);
++ uint32_t const r1 = *(ptr2++);
++ uint32_t const r2 = *(ptr2++);
+
+ //Fade will continue even after value > 16
+ //thus black pixel will be written when values just > 0
+ //thus no need to write true black
+ //if (r1 || r2) {
+ #ifdef LITTLEENDIAN
+- register uint32_t const v =
++ uint32_t const v =
+ ((r1 & 0x000000f0ul) >> 4)
+ | ((r1 & 0x0000f000ul) >> 8)
+ | ((r1 & 0x00f00000ul) >> 12)
+@@ -148,7 +148,7 @@ void SvgaScreen::show(void) {
+ | ((r2 & 0x00f00000ul) << 4)
+ | ((r2 & 0xf0000000ul)));
+ #else
+- register uint32_t const v =
++ uint32_t const v =
+ ((r2 & 0x000000f0ul) >> 4)
+ | ((r2 & 0x0000f000ul) >> 8)
+ | ((r2 & 0x00f00000ul) >> 12)
+--- a/xlibwrap.cc
++++ b/xlibwrap.cc
+@@ -119,24 +119,24 @@ void XScreen::inputUpdate(int &mouseX,int &mouseY,int &mouseButtons,char &keyHit
+ }
+
+ void XScreen::show(void) {
+- register uint32_t *ptr2 = (uint32_t*)output;
++ uint32_t *ptr2 = (uint32_t*)output;
+ uint32_t *ptr1 = (uint32_t*)d->back;
+ int i = outWidth*outHeight/sizeof(uint32_t);
+ if (lowColor)
+ do {
+- register uint32_t const r1 = *(ptr2++);
+- register uint32_t const r2 = *(ptr2++);
++ uint32_t const r1 = *(ptr2++);
++ uint32_t const r2 = *(ptr2++);
+
+ //if (r1 || r2) {
+ #ifdef LITTLEENDIAN
+- register uint32_t const v =
++ uint32_t const v =
+ mapping[((r1&0xe0ul)>>5)|((r1&0xe000ul)>>10)]
+ |mapping[((r1&0xe00000ul)>>21)|((r1&0xe0000000ul)>>26)]*256U;
+ *(ptr1++) = v |
+ mapping[((r2&0xe0ul)>>5)|((r2&0xe000ul)>>10)]*65536U
+ |mapping[((r2&0xe00000ul)>>21)|((r2&0xe0000000ul)>>26)]*16777216U;
+ #else
+- register uint32_t const v =
++ uint32_t const v =
+ mapping[((r2&0xe0ul)>>5)|((r2&0xe000ul)>>10)]
+ |mapping[((r2&0xe00000ul)>>21)|((r2&0xe0000000ul)>>26)]*256U;
+ *(ptr1++) = v |
+@@ -149,12 +149,12 @@ void XScreen::show(void) {
+ do {
+ // Asger Alstrup Nielsen's (alstrup@diku.dk)
+ // optimized 32 bit screen loop
+- register uint32_t const r1 = *(ptr2++);
+- register uint32_t const r2 = *(ptr2++);
++ uint32_t const r1 = *(ptr2++);
++ uint32_t const r2 = *(ptr2++);
+
+ //if (r1 || r2) {
+ #ifdef LITTLEENDIAN
+- register uint32_t const v =
++ uint32_t const v =
+ ((r1 & 0x000000f0ul) >> 4)
+ | ((r1 & 0x0000f000ul) >> 8)
+ | ((r1 & 0x00f00000ul) >> 12)
+@@ -165,7 +165,7 @@ void XScreen::show(void) {
+ | ((r2 & 0x00f00000ul) << 16 -12)
+ | ((r2 & 0xf0000000ul) << 16 -16);
+ #else
+- register uint32_t const v =
++ uint32_t const v =
+ ((r2 & 0x000000f0ul) >> 4)
+ | ((r2 & 0x0000f000ul) >> 8)
+ | ((r2 & 0x00f00000ul) >> 12)
diff --git a/media-sound/synaesthesia/synaesthesia-2.4-r2.ebuild b/media-sound/synaesthesia/synaesthesia-2.4-r2.ebuild
new file mode 100644
index 000000000000..2d4f83edc53c
--- /dev/null
+++ b/media-sound/synaesthesia/synaesthesia-2.4-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Nice graphical accompaniment to music"
+HOMEPAGE="https://www.logarithmic.net/pfh/synaesthesia"
+SRC_URI="https://www.logarithmic.net/pfh-files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ || ( media-libs/libsdl
+ media-libs/svgalib )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-flags.patch
+ "${FILESDIR}"/${P}-inline-keyword.patch
+ "${FILESDIR}"/${P}-dropping-register.patch
+)