summaryrefslogtreecommitdiff
path: root/media-sound/strawberry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /media-sound/strawberry
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'media-sound/strawberry')
-rw-r--r--media-sound/strawberry/Manifest2
-rw-r--r--media-sound/strawberry/strawberry-0.6.9.ebuild114
2 files changed, 116 insertions, 0 deletions
diff --git a/media-sound/strawberry/Manifest b/media-sound/strawberry/Manifest
index 6bab1a34ef36..6eac0bfe7885 100644
--- a/media-sound/strawberry/Manifest
+++ b/media-sound/strawberry/Manifest
@@ -1,4 +1,6 @@
DIST strawberry-0.6.8.tar.xz 9303276 BLAKE2B 852696846d0ce4632fc95482742ca244eda10462577c77d1bc333b3a5dcd0d5e51f6cdaaae0f8c791d2b72c86783a7a183dbde22157b522ff78e25041af73cfb SHA512 1e6ec4802188007b8624705af3ab1a4f48016a174762696e73c3fd23f0d16e88225a72962049819869237f25e630cf6f2cbefa31cec1fe15e415b9aa46e6631d
+DIST strawberry-0.6.9.tar.xz 9230916 BLAKE2B 39affd38e0df906847d2d26be888d6b3cf2434a160901fb6af2d9dac50cdf9ca128cbe6719f62664174c15bf6e97166d8d97f75dbe78b7e56db71921fe1791bd SHA512 c794800034107e65b2a5e879a284f8ba008605ed8e21cfa5e35cf2e2de86a754142f04673859b3dff32e4a798a8ea675f8db85bdb0b1e09a12bbcf8ea71eb666
EBUILD strawberry-0.6.8.ebuild 2827 BLAKE2B 73b82b1519762a8199eebdd02250ed34f544b94ada718bdf027154637fecfdc5807868888d93636c23798a1a583d0a97af17e04c5bd89dbf2466bae4f99e9661 SHA512 4a546a1227c3fab5bc7cedd6a1de97382ba233bd8ed9ab79ce77103aea7d088de8a622dd5cebc1d0521351eca458ef14bd4ce9f434875943446ce36f17d41229
+EBUILD strawberry-0.6.9.ebuild 2827 BLAKE2B 73b82b1519762a8199eebdd02250ed34f544b94ada718bdf027154637fecfdc5807868888d93636c23798a1a583d0a97af17e04c5bd89dbf2466bae4f99e9661 SHA512 4a546a1227c3fab5bc7cedd6a1de97382ba233bd8ed9ab79ce77103aea7d088de8a622dd5cebc1d0521351eca458ef14bd4ce9f434875943446ce36f17d41229
EBUILD strawberry-9999.ebuild 2827 BLAKE2B 73b82b1519762a8199eebdd02250ed34f544b94ada718bdf027154637fecfdc5807868888d93636c23798a1a583d0a97af17e04c5bd89dbf2466bae4f99e9661 SHA512 4a546a1227c3fab5bc7cedd6a1de97382ba233bd8ed9ab79ce77103aea7d088de8a622dd5cebc1d0521351eca458ef14bd4ce9f434875943446ce36f17d41229
MISC metadata.xml 448 BLAKE2B b29c1b35e64c59667f04698cb2d1c039fc7557aa7ad99fb1a8625b68d960b0e7af62e016aaf1ec68d5c44c77126f71047b046164c29a0e80d49cdcda0973ca6d SHA512 2c5af38b8518b1de981bae14422bf5931b76831c0b52b1fce29e187d9ceb25a947d8d0f7db1e7844e90ec14657cc8ab484726b31c89667e89d9fcfb6d2e7dfe7
diff --git a/media-sound/strawberry/strawberry-0.6.9.ebuild b/media-sound/strawberry/strawberry-0.6.9.ebuild
new file mode 100644
index 000000000000..88653335f0ad
--- /dev/null
+++ b/media-sound/strawberry/strawberry-0.6.9.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic l10n virtualx xdg
+
+PLOCALES="de es fr id it nb ru"
+
+DESCRIPTION="Modern music player and library organizer based on Clementine and Qt"
+HOMEPAGE="https://www.strawbs.org/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/jonaski/strawberry.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jonaski/strawberry/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="cdda +dbus debug ipod mms mtp pulseaudio +udisks"
+
+REQUIRED_USE="
+ udisks? ( dbus )
+"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+COMMON_DEPEND="
+ app-crypt/qca:2[qt5(+)]
+ dev-db/sqlite:=
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/protobuf:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ media-libs/chromaprint:=
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-libs/libmygpo-qt-1.0.9[qt5(+)]
+ >=media-libs/taglib-1.11.1_p20181028
+ media-video/vlc
+ sys-libs/zlib
+ virtual/glu
+ x11-libs/libX11
+ cdda? ( dev-libs/libcdio:= )
+ dbus? ( dev-qt/qtdbus:5 )
+ ipod? ( >=media-libs/libgpod-0.8.0 )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+# Note: sqlite driver of dev-qt/qtsql is bundled, so no sqlite use is required; check if this can be overcome someway;
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-soup:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ mms? ( media-plugins/gst-plugins-libmms:1.0 )
+ mtp? ( gnome-base/gvfs[mtp] )
+ udisks? ( sys-fs/udisks:2 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-cpp/gtest-1.8.0
+ dev-libs/boost
+ dev-qt/qtopengl:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+"
+
+DOCS=( Changelog README.md )
+
+src_prepare() {
+ l10n_find_plocales_changes "src/translations" "" ".po"
+
+ cmake_src_prepare
+ rm -r 3rdparty/taglib || die
+}
+
+src_configure() {
+ # spotify is not in portage
+ local mycmakeargs=(
+ -DBUILD_WERROR=OFF
+ # avoid automagically enabling of ccache (bug #611010)
+ -DCCACHE_EXECUTABLE=OFF
+ -DENABLE_GIO=ON
+ -DLINGUAS="$(l10n_get_locales)"
+ -DENABLE_AUDIOCD="$(usex cdda)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5DBus=$(usex !dbus)
+ -DENABLE_LIBGPOD="$(usex ipod)"
+ -DENABLE_LIBMTP="$(usex mtp)"
+ -DENABLE_LIBPULSE="$(usex pulseaudio)"
+ -DENABLE_UDISKS2="$(usex udisks)"
+ )
+
+ use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "Note that list of supported formats is controlled by media-plugins/gst-plugins-meta "
+ elog "USE flags. You may be interested in setting aac, flac, mp3, ogg or wavpack USE flags "
+ elog "depending on your preferences"
+}