summaryrefslogtreecommitdiff
path: root/media-sound/spotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
commite59b99df9503539c0231e655a17bccf83f8a270d (patch)
treedbd3fc51c710879436a4122898a3653c8c0d4ae8 /media-sound/spotify
parent9fce2d9787c37a690336f5e345a49d83ee60bc8a (diff)
gentoo auto-resync : 25:06:2023 - 07:29:14
Diffstat (limited to 'media-sound/spotify')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.2.13.ebuild131
2 files changed, 133 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 0b4f8fa90909..912868ed982b 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,4 +1,6 @@
AUX spotify-wrapper 1377 BLAKE2B b75890e77c96198d7bd788b5d954fb5c10095d9ca59e2c33a48003d5e559231db7aade027206da7d96f9c7bb6c19482c4d382918262e25c912cf47975a990793 SHA512 553d25d286368b1600bb7dc5c3ab681b380e9c9ff30df335796952c86e77912775ddeee03db348220e9d84a4bc32f4a8d85c7a1551a60e4155ee960b4a6d8799
+DIST spotify-client_1.2.13.661.ga588f749_amd64.deb 121793588 BLAKE2B b9b6b659e823e6713b2db5f3c6f7c6e4ce9cedfc0b4222d96b8baec3d086dcf804f021bb0e530f6c3003df9725ff7705aaa0af457a031124e5f104f4bc434ce1 SHA512 5ccac37274ca587414a9f4c5c427fd5d4b93bbde0b39efb94ccf79a1b5947df4a00a79e00686e59a4ccd097eca0bad88e6f030f2e236d86a82c37d8e011217e9
DIST spotify-client_1.2.8.923.g4f94bf0d_amd64.deb 119841576 BLAKE2B 2d7ce02907f00dfbd30020ea0576842253110deb10bb4de12807f9f9eacb84d7c6ee09f91da5aa2647c6e0eee7a1386d9059124012c1749e56ab081022d62815 SHA512 d4bc076d87018c851f851cc8b65e05b1611701994a97963bd63aa816518b1f5fa4d89956fea8ef234a41f1c4d6f8a3aa2bfc4fbd3b39f58f0bed5aec79c60edc
+EBUILD spotify-1.2.13.ebuild 3741 BLAKE2B b3140aeecc7fe4d33149d55d3e910e1b6974f213aec1cd1be392e875ebb46b69241cd2b128dc45783826e6306cff6f69d49e5641fe5c98b7909895f9ec148bb1 SHA512 1b116133d973df89af946bcf91867f8d49950508a053065454558d04a9e1009d34a2734adc835da672c3c5655ae0be4517ecd2ee67465ba50008cc2779c099c4
EBUILD spotify-1.2.8-r1.ebuild 3741 BLAKE2B eeafa9f9e43525666f937cb266c536c5baa8677e981629e94022778bb123df2affc199baed998dad11af927377960973f8811d46724e13128caa0daf0fbdf0c9 SHA512 2946203413c4d8e12b125253ded8cf3bf7850ec419ee4c1398a4d458f7cdec8250579e01e950e1bcf344942da0edc0fce1ff14bef00ddbcdfeec8714f6141472
MISC metadata.xml 521 BLAKE2B 6859f340482640ec95ed103b2ca4b1e6c316509d8b87402068e1164a4efeaac9cf8ac5360ea038eb09c3682dd8e8e10a9cc872a3820c1a8341fcccaab34e0a18 SHA512 7527cfdf2d421e1bd7c156b930f980a464fad60f2ba2fafa5b79e4f04baad97a6ce3176987e8a32c8b5bcae20acf2b416812b26de1f7bc76205e0d8bee4e98e8
diff --git a/media-sound/spotify/spotify-1.2.13.ebuild b/media-sound/spotify/spotify-1.2.13.ebuild
new file mode 100644
index 000000000000..960cb1c7fa5c
--- /dev/null
+++ b/media-sound/spotify/spotify-1.2.13.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature pax-utils unpacker xdg
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/download/linux/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
+BUILD_ID_AMD64="661.ga588f749"
+SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb"
+
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="libnotify local-playback pax-kernel pulseaudio"
+RESTRICT="mirror strip"
+
+BDEPEND="
+ >=dev-util/patchelf-0.10
+ sys-devel/gettext
+"
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/openssl:0=
+ dev-python/dbus-python
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/harfbuzz
+ media-libs/mesa[X(+)]
+ net-misc/curl[ssl]
+ net-print/cups[ssl]
+ sys-apps/dbus
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ !gnome-extra/gnome-integration-spotify
+ libnotify? ( x11-libs/libnotify )
+ local-playback? ( media-video/ffmpeg:0/56.58.58 )
+ pulseaudio? ( media-sound/pulseaudio )
+ !pulseaudio? ( media-sound/apulse )
+"
+ #gnome-integration-spotify causes spotify to fail to launch
+ #sys-libs/glibc
+
+S="${WORKDIR}/"
+
+QA_PREBUILT="
+ opt/spotify/spotify-client/spotify
+ opt/spotify/spotify-client/libEGL.so
+ opt/spotify/spotify-client/libGLESv2.so
+ opt/spotify/spotify-client/libcef.so
+ opt/spotify/spotify-client/libvk_swiftshader.so
+ opt/spotify/spotify-client/libvulkan.so.1
+ opt/spotify/spotify-client/swiftshader/libEGL.so
+ opt/spotify/spotify-client/swiftshader/libGLESv2.so
+"
+
+src_prepare() {
+ default
+ # Spotify links against libcurl-gnutls.so.4, which does not exist in Gentoo.
+ patchelf --replace-needed libcurl-gnutls.so.4 libcurl.so.4 usr/bin/spotify \
+ || die "failed to patch libcurl library dependency"
+}
+
+src_install() {
+ gunzip usr/share/doc/spotify-client/changelog.gz || die
+ dodoc usr/share/doc/spotify-client/changelog
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ SPOTIFY_HOME=${SPOTIFY_HOME} LIBDIR=$(get_libdir) \
+ envsubst '$SPOTIFY_HOME $LIBDIR' \
+ < "${FILESDIR}/spotify-wrapper" > "${D}/usr/bin/spotify" || die
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax-kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax-kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+
+ optfeature "systray integration on non-Gnome DEs" media-sound/spotify-tray
+}