summaryrefslogtreecommitdiff
path: root/media-sound/spotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /media-sound/spotify
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'media-sound/spotify')
-rw-r--r--media-sound/spotify/Manifest1
-rw-r--r--media-sound/spotify/spotify-1.1.26-r2.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index cc5b74226063..efa272562563 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -4,4 +4,5 @@ DIST spotify-client_1.1.26.501.gbe11e53b-15_amd64.deb 120102446 BLAKE2B 481686c9
EBUILD spotify-1.0.72-r1.ebuild 3217 BLAKE2B 83f0aac50e11c914b2e63f0dbfb6245019cccd1a4a3307bc71e7ca897d890c9119a4a0df1d1bd5fa28156cf86b4eb56f4aeefbfc07d03ddbb4c0626e8c201aee SHA512 329198467357064fc1a556437928f2d59ab0b6262c82c0435638338b8b94adac031f94a9dc4f7cad4b11345ca5f0a5e1caa13168dcdd2d1224883f6a3aa42422
EBUILD spotify-1.1.10-r1.ebuild 3155 BLAKE2B d3bc28ef679c0307add8cb7b496cedf3a47dededc46c624b9a14b4b2e31fd40fffaafca87f084519db86b33312fa6f30c64bb222acdbac99dcffee8cc537191b SHA512 5f9fb840160b3b5a11af49836f10735aac5d3cacf21f429e554b63d6b3d924401eb3f3d73b1ef0abeef5c2a1d74fe3be24a740f8a2eb2069c8b29b9f50fb07db
EBUILD spotify-1.1.26-r1.ebuild 3193 BLAKE2B 35f3f47bdaeed4ce6b20b7d856f2b35b3c3930c4347edc807ab72fb9cc3b5a084729ec1223c10155f1cc2801210debd89785ebad819e9bcb265aea247f194520 SHA512 a5ca516fa5cbfcccfa7edd49a860487283e7a3feaf832f2f252291438468f2db3c8c1e855bc0d09d09ab36a995bb88298c3c321ce0ddafa66f23a64de2306553
+EBUILD spotify-1.1.26-r2.ebuild 3449 BLAKE2B 28e9a400ad3bf321efb845b7ad396bc399bda2aeb1c1a3acfdc0dbd1b747c971eb8b59c2c073b8126a0ae056e937cea6c32b4ebd648f0e753cc0a98db0e84618 SHA512 f9e16593cf0c5d8ea6c7f35f984e1a23cda928ec2ea7f2140c6635ee1e46aa80e7f1b0e6bcbd031416f92e8e60504dc07df0a8fd85b85552303086e1ed2f56b1
MISC metadata.xml 542 BLAKE2B 112c082ca9d2775e0225eadf3ec24260438db4ec3122be340395edae3096f378ddb349275fe5c31435c5196d606d099812fea831d06ce2ac913ddc777e65d66d SHA512 a414c96da5c9c5af23491937a86edf26ca5207f4cd9277a187059f2196b8ce9b28cab80f0ee5a326911a9aa5945d2604bea310608bc5270e507fb8052e1bd2ef
diff --git a/media-sound/spotify/spotify-1.1.26-r2.ebuild b/media-sound/spotify/spotify-1.1.26-r2.ebuild
new file mode 100644
index 000000000000..fdf168b74773
--- /dev/null
+++ b/media-sound/spotify/spotify-1.1.26-r2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop pax-utils unpacker xdg
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
+BUILD_ID_AMD64="501.gbe11e53b-15"
+SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify libressl systray pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+BDEPEND=">=dev-util/patchelf-0.10"
+RDEPEND="
+ dev-libs/nss
+ dev-python/dbus-python
+ dev-python/pygobject:3
+ libnotify? ( x11-libs/libnotify )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/harfbuzz
+ media-libs/mesa[X(+)]
+ net-misc/curl[ssl]
+ net-print/cups[ssl]
+ pulseaudio? ( media-sound/pulseaudio )
+ !pulseaudio? ( media-sound/apulse )
+ systray? ( gnome-extra/gnome-integration-spotify )
+ x11-libs/gtk+:2
+ app-accessibility/at-spi2-atk
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/libSM
+ x11-libs/libICE
+"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="
+ opt/spotify/spotify-client/spotify
+ opt/spotify/spotify-client/libEGL.so
+ opt/spotify/spotify-client/libGLESv2.so
+ opt/spotify/spotify-client/libcef.so
+ opt/spotify/spotify-client/swiftshader/libEGL.so
+ opt/spotify/spotify-client/swiftshader/libGLESv2.so
+"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for systray integration
+ if use systray ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+
+ # Spotify links against libcurl-gnutls.so.4, which does not exist in Gentoo.
+ patchelf --replace-needed libcurl-gnutls.so.4 libcurl.so.4 usr/bin/spotify \
+ || die "failed to patch libcurl library dependency"
+}
+
+src_install() {
+ gunzip usr/share/doc/spotify-client/changelog.gz || die
+ dodoc usr/share/doc/spotify-client/changelog
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ LD_LIBRARY_PATH="/usr/$(get_libdir)/apulse" \\
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+}