summaryrefslogtreecommitdiff
path: root/media-sound/sox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-18 15:59:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-18 15:59:06 +0000
commit1778ddeb0f60c074ffc7fa775557ddb37c997127 (patch)
tree8622467260dfc905fd268290438b05e3a9fd06da /media-sound/sox
parentd93ba9788a6ad1e5da2bf47e804456ded6d5c65c (diff)
gentoo auto-resync : 18:12:2022 - 15:59:06
Diffstat (limited to 'media-sound/sox')
-rw-r--r--media-sound/sox/Manifest1
-rw-r--r--media-sound/sox/sox-14.4.2_p20210509-r2.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/media-sound/sox/Manifest b/media-sound/sox/Manifest
index a112c493dcd3..6b1acc9efc53 100644
--- a/media-sound/sox/Manifest
+++ b/media-sound/sox/Manifest
@@ -1,3 +1,4 @@
DIST sox-14.4.2_p20210509.zip 942551 BLAKE2B 2ddd229faacb9190fe18052b1c02da40d4c3f24fc73dd08b28ac99bef267cb05f8bcbf64e0c397c391b3be2467667783ed94f6c60798af069567e1c237ec9ccd SHA512 4868f9b77141b7e2caf2571ceb68a48bd744732e72f63ed787f8e0b9fe39b77de4e998b32d99c2500e10b017a1fd1a3379f4f9f8b67db6093b85d02cb3447934
EBUILD sox-14.4.2_p20210509-r1.ebuild 2883 BLAKE2B 772f12591a7ed73bdda1c47281170e9bb6501787f95cd6e876ea3ba91be72a2cd0ec9c1d91406d0d36ac3552f7baaab0c0c92ca81a6337d2ad88b6dc651e354b SHA512 8f9df4df4c0244e4f92e728df17643dde5ca8b0062f321f36cea10ef2f1b6b423177b414e6fca6df6875f0113264dc938884ffcf2af93cec7c0c27c4f18542a4
+EBUILD sox-14.4.2_p20210509-r2.ebuild 2819 BLAKE2B d42c7e2d4d805f8f0a9cef3ee50e7559e833a3c27b127ffc1469c8454fc853ce77611b30abef8ca5381e5ac1cadafaa23e7832d6aff2d6a0403cd98f1737354d SHA512 e70a93311d8de7566c3b33688a483025dca5c182ffb3fd205c16475fe78413aeeaee173a3420882322dfdd62a2cf2c8bdcc56f0252489d28bb43b06d931e8032
MISC metadata.xml 709 BLAKE2B 29d863a59fa534ccdaf3ccfe73ec03ff931055b7537ce3ef1111a596c8178f944910cd3c917e25f778a1e297d5fd0023833d0a8556adb6cd187fbd59e2ff5703 SHA512 a40c70b421b78a8bf2b7044b1b512600120c0352bf61755ba7d48af621fcc33c82ef3c7eff3df10c913add4b7250f7fb7461ea7171b21a07f306794d7c1cbdbf
diff --git a/media-sound/sox/sox-14.4.2_p20210509-r2.ebuild b/media-sound/sox/sox-14.4.2_p20210509-r2.ebuild
new file mode 100644
index 000000000000..96cbebf6c25a
--- /dev/null
+++ b/media-sound/sox/sox-14.4.2_p20210509-r2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+# We take a snapshot because of the huge number of security
+# and other fixes since the release of 14.4.2.
+# Recommend mirroring the snapshot; unclear if they are stable URIs.
+COMMIT="42b3557e13e0fe01a83465b672d89faddbe65f49"
+MY_P="sox-code-${COMMIT}"
+
+DESCRIPTION="The swiss army knife of sound processing programs"
+HOMEPAGE="http://sox.sourceforge.net"
+# Source: https://sourceforge.net/code-snapshots/git/s/so/sox/code.git/${MY_P}.zip
+SRC_URI="https://dev.gentoo.org/~fordfrog/distfiles/${MY_P}.zip -> ${P}.zip"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="alsa amr ao encode flac id3tag ladspa mad magic ogg openmp oss opus png pulseaudio sndfile sndio static-libs twolame wavpack"
+
+BDEPEND="
+ app-arch/unzip
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-libs/libltdl:0=
+ >=media-sound/gsm-1.0.12-r1
+ sys-apps/file
+ alsa? ( media-libs/alsa-lib )
+ amr? ( media-libs/opencore-amr )
+ ao? ( media-libs/libao:= )
+ encode? ( >=media-sound/lame-3.98.4 )
+ flac? ( >=media-libs/flac-1.1.3:= )
+ id3tag? ( media-libs/libid3tag:= )
+ ladspa? ( media-libs/ladspa-sdk )
+ mad? ( media-libs/libmad )
+ magic? ( sys-apps/file )
+ ogg? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ opus? (
+ media-libs/opus
+ media-libs/opusfile
+ )
+ png? (
+ media-libs/libpng:0=
+ sys-libs/zlib
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ sndfile? ( >=media-libs/libsndfile-1.0.11 )
+ sndio? ( media-sound/sndio:= )
+ twolame? ( media-sound/twolame )
+ wavpack? ( media-sound/wavpack )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_prepare() {
+ default
+
+ # bug #386027
+ sed -i -e 's|CFLAGS="-g"|CFLAGS="$CFLAGS -g"|' configure.ac || die
+
+ # bug #712630
+ if use elibc_musl ; then
+ ewarn "Applying musl workaround for bug #712630."
+ ewarn "File-type detection with pipes may be missing."
+ sed -i '/error FIX NEEDED HERE/d' src/formats.c || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable alsa) \
+ $(use_enable amr amrnb) \
+ $(use_enable amr amrwb) \
+ $(use_enable ao) \
+ $(use_with encode lame) \
+ $(use_enable flac) \
+ $(use_with id3tag) \
+ $(use_with ladspa ladspa dyn) \
+ $(use_with mad) \
+ $(use_with magic) \
+ $(use_enable openmp) \
+ $(use_enable ogg oggvorbis) \
+ $(use_enable oss) \
+ $(use_enable opus) \
+ $(use_with png) \
+ $(use_enable pulseaudio) \
+ $(use_enable sndfile) \
+ $(use_enable sndio) \
+ $(use_enable static-libs static) \
+ $(use_with twolame) \
+ $(use_enable wavpack) \
+ --enable-formats=dyn \
+ --with-distro="Gentoo"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}