summaryrefslogtreecommitdiff
path: root/media-sound/soundconverter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /media-sound/soundconverter
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'media-sound/soundconverter')
-rw-r--r--media-sound/soundconverter/Manifest4
-rw-r--r--media-sound/soundconverter/soundconverter-3.0.0.ebuild2
-rw-r--r--media-sound/soundconverter/soundconverter-3.0.2.ebuild63
3 files changed, 67 insertions, 2 deletions
diff --git a/media-sound/soundconverter/Manifest b/media-sound/soundconverter/Manifest
index e0e6fca31ab0..10e824ebe742 100644
--- a/media-sound/soundconverter/Manifest
+++ b/media-sound/soundconverter/Manifest
@@ -1,3 +1,5 @@
DIST soundconverter-3.0.0.tar.xz 201548 BLAKE2B bdca42d22d2e497b807149dcd5c8f911519b71dc7e836ad359831d0b7cd2241f58f8f9f60fa4580e2f038528e9c249dfa8a811d1681d0c8dead2c53e0f58f7ce SHA512 6f5518711c76e7748447805dbf16ac8622c5041c3f3cac2de6f31968aab4eff43a2fde2da48c47d12093ce1732208923d83d57b6a97ea99fbf882dfef239a62d
-EBUILD soundconverter-3.0.0.ebuild 1797 BLAKE2B f83a22a7acd5914b385d2eb4cad0ff74e03e9061956e02a5ad5e4715ccf15370a4e1c1e4dbf63a931a90a66d037f4d3ef23c2f478cc347871c36a0248d5babab SHA512 222d2ef0e3a993a28da7f8d033135dad5da098fbaaa37aaba0b682ac771ef002b5bd149f7914d52c114ae3717e9a33de76f2a928b2beccbb467cc514816c5367
+DIST soundconverter-3.0.2.tar.xz 208440 BLAKE2B e7817648fe27b2083629ea718b0479f7b9e2607a017868b1e1ce3fb0407a84a548bd007647e73a1d4163a7f51b162a89e3914419ccdbfd07586c2a94a23f4af2 SHA512 0746395de412a4d845e3df4d6cce0dbcba266c9efc8db71663dd1c751d2a5de5b0dc266f24bbfe6c00f69428801ce5f9558fc8e5e2f5d5e6be8562085cd7fe92
+EBUILD soundconverter-3.0.0.ebuild 1795 BLAKE2B 9708f0fed867b06009862386e4c375292e70e9d5dd25507ee3ad2eb902ca6a58e5a83570e23a07ce1f6a3c138b62088ad47a24d0dd0c33e2b6a76779d8e171fd SHA512 69f83e8ef303fcd0432113eb39de60665471e7c8c8bd1c3080a34954fb031817101d4af7ebdfec0badfb9b46f1054a13ddf8f9a8de91c246ea321f9674be891f
+EBUILD soundconverter-3.0.2.ebuild 1796 BLAKE2B e21ce025bedb8290992dc8503b2a76b56cb0ce049a02e27a43e3c03dabb811edc66686a7dcd6d81e2279a4dbe2864699e55eea7cf2de4ab640d030cdaea41123 SHA512 ad2e641ee2aff0ea2c4e7640ad1d5546d63b545b7491c307810573683fc2ca4e8ce4ecfb7adc3fe3479ab4bf725d844d5961afd290f5a7351f138f9e6587d937
MISC metadata.xml 348 BLAKE2B ca79913ada8d48522d7f0f593caff90549704f518c13f1ca79f34a1f885ffa1500d498be6fe4f70b301a3ff168235ca9e6a2642ff4c4d5a0565ad3bc8de99050 SHA512 a9daf27ee0eeb8342f28e7089b3ff3fdfafb1e19f517efc0d56f5eaae09f05b5b7309368af53fba1f46b8810349ca1f6f82aa3c14369144b22970f488c6ae1b5
diff --git a/media-sound/soundconverter/soundconverter-3.0.0.ebuild b/media-sound/soundconverter/soundconverter-3.0.0.ebuild
index 80a65a531013..58d2ba6e2c78 100644
--- a/media-sound/soundconverter/soundconverter-3.0.0.ebuild
+++ b/media-sound/soundconverter/soundconverter-3.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
inherit gnome2 python-single-r1
diff --git a/media-sound/soundconverter/soundconverter-3.0.2.ebuild b/media-sound/soundconverter/soundconverter-3.0.2.ebuild
new file mode 100644
index 000000000000..e0324bbe7b4c
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-3.0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="https://soundconverter.org/"
+MY_PV="${PV/_/-}"
+SRC_URI="https://launchpad.net/${PN}/trunk/${MY_PV}/+download/${PN}-${MY_PV}.tar.xz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+IUSE="aac flac libnotify mp3 ogg opus vorbis"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/gobject-introspection:=
+ x11-libs/gtk+:3[introspection]
+ media-libs/gstreamer:1.0[introspection]
+"
+
+# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
+# List in soundconverter/gstreamer.py
+# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/pango[introspection]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ libnotify? ( x11-libs/libnotify[introspection] )
+
+ media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
+ media-plugins/gst-plugins-meta:1.0
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+ media-libs/gst-plugins-good:1.0
+ mp3? (
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ )
+ aac? ( media-plugins/gst-plugins-faac:1.0 )
+ opus? ( media-plugins/gst-plugins-opus:1.0 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+RESTRICT="test" # broken pot files list in 3.0.0 release, making src_test fallback to "make test" which fails
+
+src_prepare() {
+ python_fix_shebang .
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize "${ED%/}"/usr/$(get_libdir)/soundconverter/python
+}