summaryrefslogtreecommitdiff
path: root/media-sound/soundconverter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-sound/soundconverter
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-sound/soundconverter')
-rw-r--r--media-sound/soundconverter/Manifest4
-rw-r--r--media-sound/soundconverter/metadata.xml1
-rw-r--r--media-sound/soundconverter/soundconverter-4.0.3.ebuild99
3 files changed, 103 insertions, 1 deletions
diff --git a/media-sound/soundconverter/Manifest b/media-sound/soundconverter/Manifest
index 4083571975b7..1ff122d85e36 100644
--- a/media-sound/soundconverter/Manifest
+++ b/media-sound/soundconverter/Manifest
@@ -1,3 +1,5 @@
DIST soundconverter-3.0.2.tar.xz 208440 BLAKE2B e7817648fe27b2083629ea718b0479f7b9e2607a017868b1e1ce3fb0407a84a548bd007647e73a1d4163a7f51b162a89e3914419ccdbfd07586c2a94a23f4af2 SHA512 0746395de412a4d845e3df4d6cce0dbcba266c9efc8db71663dd1c751d2a5de5b0dc266f24bbfe6c00f69428801ce5f9558fc8e5e2f5d5e6be8562085cd7fe92
+DIST soundconverter-4.0.3.gh.tar.gz 632495 BLAKE2B 9a2847b5ebb998b9122ff4020e47dc5b84635a6e1ae0de9061bab18e813ab3918278e940df80bc370b071de77a82a3637c376d9ebdd84d2f7b00865dda94935a SHA512 0674eb430bb3cf267ceabee8e7dbdeb2ee81e537ca093fcf6e1adab21112690ed9e3eb349a994805ddfc51b3a4f875b87a5819a1f2cf020752eb8e742665a998
EBUILD soundconverter-3.0.2-r1.ebuild 1825 BLAKE2B dfad0e7f1e681fee074bcbf0503d6b9e36b5c219e591a24cb0e436ba34f2bf3eb391cbffccce51225d5eaa447e9c9ffc4d2bebb0587603f51c757fd4f071dcb5 SHA512 6e8c1754f91e7dfb132cefed59b508014658552aa68a15f3c4de6ef1ce287bcb2390e7549f920f19c3e8f4bf1101f4c5dc084b76cc4ea3053d1df896303c10c4
-MISC metadata.xml 349 BLAKE2B 48933367cf9c097cd0f081328bb264294c3ff3c81cf8c782dca6a1528dd9e8aef406b3ee7ac561c7e6b8a69335266fc63654103b505ea9730e1262b14cc3bef8 SHA512 d9224edbd42d76ac53151c8deeb7cf5f428c020970554fb4757a4380d5e173c5a2938dd87703afd1bc9b634ffdd8b227d8eda1c6b933e341cb7cd894e82fe151
+EBUILD soundconverter-4.0.3.ebuild 2727 BLAKE2B 07d192af018bcabb475effbc8690f6f73fbb927e07b722283aee59b24bd9caf3c8e6395b7f6c8f938abe911c9af375f8653264ed0b10ca8837f2122e0656ac5b SHA512 5b9d6e578e82912b3f3d0d2778ebe191a79ffcf8087a6bfb27d1d77e90a743ad15f69d3ef0244ca06a70f10f6ef8490bdee38c2442edd3b4ed8a275c58c6f176
+MISC metadata.xml 413 BLAKE2B b72915536e7a83e087d9fbe87756b3a8ffa38265360d17bfacaadf75694a032bf55b024574813692ff91e0664ab0849584ab3027e277443260ff9a3afc31ffa4 SHA512 772a3ec6f12308dea14140a65e35c66066e7f9869e1518f92313f23f46f2a6f7b3f18f3b2650c7197c934d07219bca656c446aae7ef7532b57323f924222939e
diff --git a/media-sound/soundconverter/metadata.xml b/media-sound/soundconverter/metadata.xml
index 1fd31681d373..e16be19bd1bc 100644
--- a/media-sound/soundconverter/metadata.xml
+++ b/media-sound/soundconverter/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="launchpad">soundconverter</remote-id>
+ <remote-id type="github">kassoulet/soundconverter</remote-id>
</upstream>
</pkgmetadata>
diff --git a/media-sound/soundconverter/soundconverter-4.0.3.ebuild b/media-sound/soundconverter/soundconverter-4.0.3.ebuild
new file mode 100644
index 000000000000..5bec269e915b
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-4.0.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+inherit gnome2-utils distutils-r1 virtualx xdg
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="https://soundconverter.org/"
+SRC_URI="https://github.com/kassoulet/${PN}/archive/${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="aac flac mp3 ogg opus vorbis"
+
+# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
+# List in soundconverter/gstreamer.py
+# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
+RDEPEND="
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ ')
+ media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
+ media-plugins/gst-plugins-meta:1.0
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+ media-libs/gst-plugins-good:1.0
+ mp3? (
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ )
+ aac? ( media-plugins/gst-plugins-faac:1.0 )
+ opus? ( media-plugins/gst-plugins-opus:1.0 )
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ ')
+ test? (
+ media-plugins/gst-plugins-flac:1.0
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ media-plugins/gst-plugins-faac:1.0
+ media-plugins/gst-plugins-opus:1.0
+ )
+"
+
+# Before PEP517: tests seem to hang and also fail to find fdkaacenc from gst?
+# After: need to trick it into finding the data (inc. glade files)
+RESTRICT="test"
+
+python_prepare_all() {
+ gnome2_environment_reset
+ distutils-r1_python_prepare_all
+
+ rm -v "${S}/CHANGELOG.old" || die
+
+ # workaround incorrect behavior when LINGUAS is set to an empty string
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
+ ! [[ -v LINGUAS && -z ${LINGUAS} ]] || rm po/*.po || die
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ export GSETTINGS_SCHEMA_DIR="${S}/data"
+ "${BROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}"/data || die
+
+ "${EPYTHON}" tests/test.py || die
+}
+
+python_install_all() {
+ rm -v "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+ mv -v "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+ distutils-r1_python_install_all
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}