summaryrefslogtreecommitdiff
path: root/media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild')
-rw-r--r--media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild b/media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild
new file mode 100644
index 000000000000..3f5b02394145
--- /dev/null
+++ b/media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT=0c807e593f7571a654ad055cb126652d7f3a698d
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_SINGLE_IMPL="true"
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+inherit desktop distutils-r1
+
+DESCRIPTION="Elegant GTK+ music client for the Music Player Daemon (MPD)"
+HOMEPAGE="https://www.nongnu.org/sonata/"
+SRC_URI="https://github.com/multani/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus taglib"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/python-mpd[${PYTHON_MULTI_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_MULTI_USEDEP}] )
+ taglib? ( dev-python/tagpy[${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_install() {
+ distutils-r1_src_install
+ doicon -s 128 sonata/pixmaps/sonata.png
+ rm -r "${D}"/usr/share/sonata || die
+}