summaryrefslogtreecommitdiff
path: root/media-sound/sndio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /media-sound/sndio
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'media-sound/sndio')
-rw-r--r--media-sound/sndio/Manifest4
-rw-r--r--media-sound/sndio/files/sndiod3
-rw-r--r--media-sound/sndio/metadata.xml12
-rw-r--r--media-sound/sndio/sndio-1.7.0.ebuild47
4 files changed, 66 insertions, 0 deletions
diff --git a/media-sound/sndio/Manifest b/media-sound/sndio/Manifest
new file mode 100644
index 000000000000..255ca5c9c230
--- /dev/null
+++ b/media-sound/sndio/Manifest
@@ -0,0 +1,4 @@
+AUX sndiod 58 BLAKE2B 66ccfb1e14b145e34851bf6f06566e9c7cbeb6d5a0b4af3d1ee189133441697563b828af9fc96d6313fd7597c89821a79b0d5d67e9b15c5658891605fa54dcfc SHA512 7afae426a04482ca556c360fedfb08e92dbf54af108db3725dce5db74d5332d8fc46481f04804674bec56aa901ab679bae6fdfc21a065c91333dbc169dfdc434
+DIST sndio-1.7.0.tar.gz 147989 BLAKE2B 20f5969cfd6d6a62d9c04e493eda7648f686ad394db18e43ae574db235f31a025705f40f9c6ea821e04449bc1cdbc35c23dbeff9575b71fccc92c24140341d7e SHA512 f9db7bad5f30e8790488c4d20198c8a5a51f04f94e4b1067eadd7fe0fcc6f6ced3250173a627439d661dcf6faabc7bc4786b30af013788a5c88d972f1c9dc1f8
+EBUILD sndio-1.7.0.ebuild 862 BLAKE2B bf15daf727e3db6d19c16ddc6a67f37e8a474d20a1d536807a7686d3eb286c3645e0f4da0cec1ea8323eb60cf11f4dfd78a1a4a55540fd5a84adf4136f8e291d SHA512 b489a41cf744989b27dd089bd2a3f2b74c68fe656f9c8dde332a59a08916e71f80fa8a889e8af3f14e4b8260dd99004aef3daaccb636a4c1e3abe7e3f03bacb1
+MISC metadata.xml 379 BLAKE2B b4d62877ff242c65d08dc06b33970d51545518b5e30dc231d1b700a47b984500ca8f64a77f705913070a51d7c45be61e1b9c25d4691d62142eabfec153dde5cb SHA512 ae67be4bd206bdc709c9d78f5256c8b286eae5383453d16156ce43a5fc389208053587284dfc339a4ed65a239304cc6ad40b87e0b4a6aec4695213beb1d69aff
diff --git a/media-sound/sndio/files/sndiod b/media-sound/sndio/files/sndiod
new file mode 100644
index 000000000000..ee38dcb97d94
--- /dev/null
+++ b/media-sound/sndio/files/sndiod
@@ -0,0 +1,3 @@
+#!/sbin/openrc-run
+command="sndiod"
+command_user="sndiod"
diff --git a/media-sound/sndio/metadata.xml b/media-sound/sndio/metadata.xml
new file mode 100644
index 000000000000..9df017effeb6
--- /dev/null
+++ b/media-sound/sndio/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>contact@hacktivis.me</email>
+ <name>Haelwenn (lanodan) Monnier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-sound/sndio/sndio-1.7.0.ebuild b/media-sound/sndio/sndio-1.7.0.ebuild
new file mode 100644
index 000000000000..24f14c1d8c3a
--- /dev/null
+++ b/media-sound/sndio/sndio-1.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="small audio and MIDI framework part of the OpenBSD project"
+HOMEPAGE="http://www.sndio.org/"
+SRC_URI="http://www.sndio.org/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/7.0"
+KEYWORDS="~amd64"
+IUSE="alsa"
+
+DEPEND="
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-user/sndiod
+"
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ tc-export CC
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --privsep-user=sndiod \
+ --with-libbsd \
+ $(use_enable alsa) \
+ || die "Configure failed"
+}
+
+src_install() {
+ multilib-minimal_src_install
+
+ doinitd "${FILESDIR}/sndiod"
+}