summaryrefslogtreecommitdiff
path: root/media-sound/sndio/sndio-1.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /media-sound/sndio/sndio-1.9.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'media-sound/sndio/sndio-1.9.0.ebuild')
-rw-r--r--media-sound/sndio/sndio-1.9.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/sndio/sndio-1.9.0.ebuild b/media-sound/sndio/sndio-1.9.0.ebuild
new file mode 100644
index 000000000000..f805740ef608
--- /dev/null
+++ b/media-sound/sndio/sndio-1.9.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="small audio and MIDI framework part of the OpenBSD project"
+HOMEPAGE="http://www.sndio.org/"
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://caoua.org/git/sndio"
+ EGIT_MIN_CLONE_TYPE="single+tags"
+else
+ SRC_URI="http://www.sndio.org/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0/7.1"
+IUSE="alsa"
+
+DEPEND="
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-user/sndiod
+"
+
+PATCHES=( "${FILESDIR}"/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch )
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ tc-export CC
+
+ # Not autotools-based but a custom script.
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --privsep-user=sndiod \
+ --with-libbsd \
+ $(use_enable alsa) \
+ || die "Configure failed"
+}
+
+src_install() {
+ multilib-minimal_src_install
+
+ doinitd "${FILESDIR}/sndiod"
+}