summaryrefslogtreecommitdiff
path: root/media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild')
-rw-r--r--media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild b/media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild
new file mode 100644
index 000000000000..946196cd2f67
--- /dev/null
+++ b/media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small collection of programs that use libsndfile"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile/tools/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/erikd/sndfile-tools.git"
+else
+ SRC_URI="http://www.mega-nerd.com/libsndfile/files/${P}.tar.bz2 -> ${P}a.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="jack"
+
+DEPEND="
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ x11-libs/cairo
+ sci-libs/fftw:3.0=
+ jack? ( virtual/jack )
+"
+RDEPEND="${DEPEND}
+ !<media-libs/libsamplerate-0.1.9-r1
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable jack)
+}