summaryrefslogtreecommitdiff
path: root/media-sound/sidplayfp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /media-sound/sidplayfp
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'media-sound/sidplayfp')
-rw-r--r--media-sound/sidplayfp/Manifest3
-rw-r--r--media-sound/sidplayfp/files/sidplayfp-1.4.4-musl-limits.patch11
-rw-r--r--media-sound/sidplayfp/sidplayfp-1.4.4.ebuild9
3 files changed, 21 insertions, 2 deletions
diff --git a/media-sound/sidplayfp/Manifest b/media-sound/sidplayfp/Manifest
index 7be12ac76082..0cc03c3dc251 100644
--- a/media-sound/sidplayfp/Manifest
+++ b/media-sound/sidplayfp/Manifest
@@ -1,3 +1,4 @@
+AUX sidplayfp-1.4.4-musl-limits.patch 263 BLAKE2B bd9c7d93bb0743d94451d4379baa598265ea95bb5717a31770d85b91a3ef8e0fa222fb4c506b6d36c41354b0ddc821ed531e394e6a4db8e52eeeebd7a17168d6 SHA512 2fe65a56bca1e6f1b898ccc6a2ad0c0d2c38fcfb0a9e5a781e515214f616cee1380b4f80c0df54986d43f30fb85f62c88b73706e5db5e1f89bc0f054d805283e
DIST sidplayfp-1.4.4.tar.gz 183711 BLAKE2B 31ff002d4cd54e827117e2b2f86d253ee1e0bc07fb6ac777653109585c059311205e141e339a8d8cde08209e1c35776d6f0a0ccf0ad754f78eb5e5f4bafd3cfb SHA512 8375a249da80a10d9c0ef55b35c5b047bf0249393026ad8ff25fb8a2660151f1d482fe581a85c6982b3c70ea257807ce17e1c6011874f10c64bec54a1982ec04
-EBUILD sidplayfp-1.4.4.ebuild 880 BLAKE2B 4cd44b11980ba9ede820c59c0eddf795d7eda5bce49e351f1340c159b718f24a0e124c01d5279e9e9a0eeeaa211c1be781e8644a26e1f7845cf7a3867503ec59 SHA512 bed6279bea87e497e959af4ac3d6467fd79e4b2ab3f54747dc0d4f99fe2d434ef7299c0a6155580c58bc87962b1a14a445f48712e9f7d74e00ef64f0eecf9d4f
+EBUILD sidplayfp-1.4.4.ebuild 941 BLAKE2B 2ba28162b5ba5b5b621fc2e54370afc9f472fe471cbd0cca64b90408d58beeda45d20a375ba4cd02e55acbbe690edec09591e8a49b92d543b92d938b801f5433 SHA512 c4f52b48bcfd49d20e908e11ff24494d31358072061e1bb720a4d7f9e33b61622028ca6e803be6d9e94f254504ecb90f9d2e9d381442e2f92d5cfa39448aaae4
MISC metadata.xml 339 BLAKE2B 79d766f101909c202affb7cc72bbefdfb8d5b44fcbf74f17f98e665351384a8110aec7ddec0c685fb328198d29ae4953ce341cda3dd4abd2a67f157d90628175 SHA512 172879da9ed0be1ff48d75d23d3b23e3070247b4ef1decb291b020f7bc1522dd033e78f92d38511eedaae7c1944edc5bb05ff763f4d20a6b7015198ebd38f16f
diff --git a/media-sound/sidplayfp/files/sidplayfp-1.4.4-musl-limits.patch b/media-sound/sidplayfp/files/sidplayfp-1.4.4-musl-limits.patch
new file mode 100644
index 000000000000..ad810d66f5b5
--- /dev/null
+++ b/media-sound/sidplayfp/files/sidplayfp-1.4.4-musl-limits.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/764113
+--- a/src/IniConfig.cpp
++++ b/src/IniConfig.cpp
+@@ -36,6 +36,7 @@
+ # include <sys/types.h>
+ # include <sys/stat.h> /* mkdir */
+ # include <dirent.h> /* opendir */
++# include <limits.h>
+ #else
+ # include <windows.h>
+ #endif
diff --git a/media-sound/sidplayfp/sidplayfp-1.4.4.ebuild b/media-sound/sidplayfp/sidplayfp-1.4.4.ebuild
index 40dc1277bbd0..caff4726ef0c 100644
--- a/media-sound/sidplayfp/sidplayfp-1.4.4.ebuild
+++ b/media-sound/sidplayfp/sidplayfp-1.4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,11 +22,17 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.4-musl-limits.patch
+)
+
src_prepare() {
default
+
if ! use alsa; then
sed -i -e 's:alsa >= 1.0:dIsAbLe&:' configure || die
fi
+
if ! use pulseaudio; then
sed -i -e 's:libpulse-simple >= 1.0:dIsAbLe&:' configure || die
fi
@@ -34,5 +40,6 @@ src_prepare() {
src_configure() {
export ac_cv_header_linux_soundcard_h=$(usex oss)
+
econf
}