summaryrefslogtreecommitdiff
path: root/media-sound/scmpc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-sound/scmpc
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-sound/scmpc')
-rw-r--r--media-sound/scmpc/Manifest3
-rw-r--r--media-sound/scmpc/files/scmpc-0.4.1-fno-common.patch103
-rw-r--r--media-sound/scmpc/scmpc-0.4.1.ebuild5
3 files changed, 109 insertions, 2 deletions
diff --git a/media-sound/scmpc/Manifest b/media-sound/scmpc/Manifest
index bd34850a51f4..61dde7bded61 100644
--- a/media-sound/scmpc/Manifest
+++ b/media-sound/scmpc/Manifest
@@ -1,4 +1,5 @@
+AUX scmpc-0.4.1-fno-common.patch 1953 BLAKE2B 37a5009a622a9b192867db03a66ac434f775c54b62cad308e4edaf9b26a3edeaa249fb94ef1a39009b37ff8dfbbc96e6f39353f0ffda179676eaf8db280ae5b2 SHA512 9cc2df98bbb571506b196b78d77e60fad1c556fd656370d4cfcb24b32117b130386f40d2fbf569e1e44749663358de59a0607aa035c97ba1a7b467f9270d5731
AUX scmpc-2.init 317 BLAKE2B 4b6f9aad5b4f993b5e34ec35aaf1af67a2407e815ba51942e3634451b0bb814e6dec10004e9df43df5aa3ffae4f1ef84899438dd704748d0e5925e4a6156481c SHA512 58cd9269acbdb92bd4ab0ae23c1f5a07909debf9b37131824827089aece9552493b984f5d73c654a7f6ef47e7bb496e424cbe3885db932ab5554bee9f296f0df
DIST scmpc-0.4.1.tar.bz2 88288 BLAKE2B 6502b21b512604e611f2d6a3210b3f5d64d3dd476b5c17e7e92480478b1488220147ccaa3b43f838fcae646c6c501f6b4bdaaf543df05151782f46bf689cd25d SHA512 7d9f8aad29d58f2227a6149a6b4c9bfc4d400946ac316cbb34482feffd71619c1f311cb1ce6f02c22912793e866661e4d976c8f4ee99ffd1e76be65c9a06d876
-EBUILD scmpc-0.4.1.ebuild 633 BLAKE2B 1c610892a7f1ba3e68fc3f57f0e5a4095fe3a32de4dbd6a16cb6696dce01a14d5de25a83c2707e3c52a7b778223c56a8bcd38f1e36fed64769b9c11175a15f87 SHA512 a08429f1c4f8e7da4b8b7e9b1050f36978feef9c450f75015f53638540b5b7d304e881b15b1cfff64018e6e833643afe21a3646648228bd34d2cc256b1ec9c08
+EBUILD scmpc-0.4.1.ebuild 689 BLAKE2B c9048555227ed15468b535392c4650275bcf56ad9bb8da54fc06e67a2875e2753ff7e501df902bf3738584f4bd9e5663014f713f2f592ed8bcefa3864ce14442 SHA512 f4c7347814996f9b4f122a7be939ab2194e504f40bb3875442ae1de7606c3335a0a6bd3bff131f0308c29b5b5a13798849298a90303cacb76cdc615d47fff9cc
MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/media-sound/scmpc/files/scmpc-0.4.1-fno-common.patch b/media-sound/scmpc/files/scmpc-0.4.1-fno-common.patch
new file mode 100644
index 000000000000..22cd4621e745
--- /dev/null
+++ b/media-sound/scmpc/files/scmpc-0.4.1-fno-common.patch
@@ -0,0 +1,103 @@
+--- a/src/audioscrobbler.c
++++ b/src/audioscrobbler.c
+@@ -50,6 +50,9 @@
+ #define API_KEY "3ec5638071c41a864bf0c8d451566476"
+ #define API_SECRET "365e18391ccdee3bf820cb3d2ba466f6"
+
++static struct as_conn_t as_conn;
++gchar *buffer;
++
+ gboolean as_connection_init(void)
+ {
+ as_conn.handle = curl_easy_init();
+--- a/src/audioscrobbler.h
++++ b/src/audioscrobbler.h
+@@ -37,19 +37,19 @@
+ /**
+ * Last.fm connection data
+ */
+-struct {
++struct as_conn_t {
+ gchar *session_id;
+ gint64 last_auth;
+ gint64 last_fail;
+ connection_status status;
+ CURL *handle;
+ struct curl_slist *headers;
+-} as_conn;
++};
+
+ /**
+ * cURL data buffer
+ */
+-gchar *buffer;
++extern gchar *buffer;
+
+ /**
+ * Initialize cURL
+--- a/src/mpd.c
++++ b/src/mpd.c
+@@ -37,6 +37,8 @@
+ static gboolean mpd_parse(GIOChannel *source, GIOCondition condition,
+ gpointer data);
+
++struct mpd_t mpd;
++
+ gboolean mpd_connect(void)
+ {
+ mpd.conn = mpd_connection_new(prefs.mpd_hostname, prefs.mpd_port,
+--- a/src/mpd.h
++++ b/src/mpd.h
+@@ -32,7 +32,7 @@
+ /**
+ * MPD connection data
+ */
+-struct {
++struct mpd_t {
+ struct mpd_connection *conn;
+ struct mpd_status *status;
+ struct mpd_song *song;
+@@ -42,7 +42,9 @@
+ guint idle_source;
+ guint check_source;
+ guint reconnect_source;
+-} mpd;
++};
++
++extern struct mpd_t mpd;
+
+ /**
+ * Connect to MPD
+--- a/src/preferences.c
++++ b/src/preferences.c
+@@ -36,6 +36,8 @@
+ #include "scmpc.h"
+ #include "preferences.h"
+
++struct prefs_t prefs;
++
+ static gint cf_log_level(cfg_t *cfg, cfg_opt_t *opt, const gchar *value,
+ void *result);
+ static gint cf_validate_num(cfg_t *cfg, cfg_opt_t *opt);
+--- a/src/preferences.h
++++ b/src/preferences.h
+@@ -32,7 +32,7 @@
+ /**
+ * scmpc settings
+ */
+-struct {
++struct prefs_t {
+ gchar *mpd_hostname;
+ gushort mpd_port;
+ gushort mpd_timeout;
+@@ -48,7 +48,9 @@
+ gchar *cache_file;
+ guint queue_length;
+ guint cache_interval;
+-} prefs;
++};
++
++extern struct prefs_t prefs;
+
+ /**
+ * Initialize preferences
diff --git a/media-sound/scmpc/scmpc-0.4.1.ebuild b/media-sound/scmpc/scmpc-0.4.1.ebuild
index 7eee1b1aa5be..2b76d4155534 100644
--- a/media-sound/scmpc/scmpc-0.4.1.ebuild
+++ b/media-sound/scmpc/scmpc-0.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,6 +18,9 @@ RDEPEND="
net-misc/curl:="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.1-fno-common.patch
+)
src_install() {
default