summaryrefslogtreecommitdiff
path: root/media-sound/saydate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /media-sound/saydate
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'media-sound/saydate')
-rw-r--r--media-sound/saydate/Manifest2
-rw-r--r--media-sound/saydate/saydate-0.3.0.ebuild40
2 files changed, 23 insertions, 19 deletions
diff --git a/media-sound/saydate/Manifest b/media-sound/saydate/Manifest
index 663dab12fd2a..004b109e294a 100644
--- a/media-sound/saydate/Manifest
+++ b/media-sound/saydate/Manifest
@@ -1,3 +1,3 @@
DIST saydate-0.3.0.tar.gz 137732 BLAKE2B 4de22e65b2cc9255ce961168ebec693e367720d95cc1c25d62d565b1612b26dee0209963474541e3217fff878f903a735b59e673c589ebe78e85b40b8fd67a5a SHA512 b53bc6037f4f757deefba54855036b25287c721f424a53858d038362b1b0c42d27bf7e72739768362c3b02cc9cca13945fb33dc6f3df9c1e76dba23b1cedbd71
-EBUILD saydate-0.3.0.ebuild 924 BLAKE2B c40739ffd6282cb2bc9f122df98c0ef7f1a24a7462e9edee28a2358e80fcd32d50662be69e553923157f115fb4d8faf9071ec61f901901904e7a7fd16723ebe1 SHA512 5f31382fe97ac0b6247b1f9a739caa12b8230793ead3828ca8b5ccc10aabd254fc044478bde50c26cd7110d0390ffa4580401674d8753b5abe173025170de44d
+EBUILD saydate-0.3.0.ebuild 809 BLAKE2B 80b9344b21afcc91df4af0ffb3dc9a923c7719978b4084962152547fe3d13ab153fa10a56b806820718e1b1ed27b4a6bac92ab63f546e57adeeccb59ee5a0a68 SHA512 c0e4b1c3f8abcf6bdf829f0c29a84ea00d360b9f46cc7954a247d4c418a9ab2a0b0f0d1d4dcad14f63145d1966f198d590e8f230aa898fd3c25fcacf8b2d740c
MISC metadata.xml 249 BLAKE2B f7f8f071ecba933f3d39b0b60983281d59299b92de9375a60ab4109d7202800cb790bce0c426227f04b3e2624b1adb20876145741355abc6a4938b8b9698d144 SHA512 9a100fb26586365eda99724330a03a512f4d0be18d39c3a195ba02c2fc841edeee99d22512acf5a058a3b978d3a74f4d963a5aff9aa343b6cb4086cdfefe6343
diff --git a/media-sound/saydate/saydate-0.3.0.ebuild b/media-sound/saydate/saydate-0.3.0.ebuild
index 7b6489dbdcd8..95205e4dd16b 100644
--- a/media-sound/saydate/saydate-0.3.0.ebuild
+++ b/media-sound/saydate/saydate-0.3.0.ebuild
@@ -1,35 +1,39 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-S=${WORKDIR}/${PN}
DESCRIPTION="A Linux shell program that talks the date and system uptime"
HOMEPAGE="http://unihedron.com/projects/saydate/saydate.php"
SRC_URI="http://unihedron.com/projects/saydate/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="amd64 ~ppc ppc64 sparc x86"
-DEPEND="=sys-apps/sed-4*"
-IUSE=""
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
-# Don't leave this empty or it tries to install directly
-# on livefs
-src_compile() { :; }
+ sed -i 's:/dev/audio:/dev/dsp:' saydate au2raw DESIGN || die
+
+ # don't install pre-compressed files
+ gunzip man/{saydate,au2raw}.1.gz || die
+}
+
+src_compile() {
+ # Don't leave this empty or it tries
+ # to install directly on livefs
+ :
+}
-src_install () {
- insinto /usr/share/man/man1
- doins "${S}"/man/saydate.1.gz "${S}"/man/au2raw.1.gz
+src_install() {
+ dobin saydate au2raw
- dodir /usr/share/saydate
insinto /usr/share/saydate
- doins "${S}"/data/*.raw
+ doins data/*.raw
- sed -i "s:/dev/audio:/dev/dsp:" "${S}"/saydate
- sed -i "s:/dev/audio:/dev/dsp:" "${S}"/au2raw
- sed -i "s:/dev/audio:/dev/dsp:" "${S}"/DESIGN
+ doman man/{saydate,au2raw}.1
dodoc README TODO HISTORY DESIGN
- dobin saydate au2raw || die "dobin failed"
}