summaryrefslogtreecommitdiff
path: root/media-sound/qpwgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-03 22:19:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-03 22:19:46 +0100
commite0af729e18c4d09b3b0064cf7e706971d491a6be (patch)
tree891d53c54c2c6276451f47af90c600b8b7f25c24 /media-sound/qpwgraph
parent3349e2e53a8147dbd85c06f560e5923cf3c0fd3d (diff)
gentoo auto-resync : 03:09:2023 - 22:19:46
Diffstat (limited to 'media-sound/qpwgraph')
-rw-r--r--media-sound/qpwgraph/Manifest4
-rw-r--r--media-sound/qpwgraph/metadata.xml19
-rw-r--r--media-sound/qpwgraph/qpwgraph-0.5.2.ebuild55
-rw-r--r--media-sound/qpwgraph/qpwgraph-9999.ebuild55
4 files changed, 133 insertions, 0 deletions
diff --git a/media-sound/qpwgraph/Manifest b/media-sound/qpwgraph/Manifest
new file mode 100644
index 000000000000..1ff72bfc95ca
--- /dev/null
+++ b/media-sound/qpwgraph/Manifest
@@ -0,0 +1,4 @@
+DIST qpwgraph-v0.5.2.tar.bz2 454542 BLAKE2B aaeb947d77e5e1c41195a994193cd3de10fc8dfa798b36f90577f9a8b4037176b5465c55123ab7308691279b5c6c6c20d426cfa1ccf0836b35873b30a6f135df SHA512 0ab06d72fd3a7045f6a4f0895e9bdedeaedf97a9d948f78b763f1a46ef2444f6cf9574f02c25197249ba22bf7189b86cf4fe59dc5d091627788e3e45126809fa
+EBUILD qpwgraph-0.5.2.ebuild 1114 BLAKE2B 00e092de954d6fe65b1f4af7ef287a7006dc736bab33b1470e56a53fad4752a61593224dba85bb06ea862b7bf0b3c7fc1cc200576be5774cf7bbc473182181bd SHA512 315c3d8d4ab8d9555e8a1804478cdb7e81b57e75f8b2d351a4bf1c8d9bc5d4e404cedeed2e75acc5731bc7d98adf3f407fc03eea34035ac18b5f4f6e33e715ee
+EBUILD qpwgraph-9999.ebuild 1114 BLAKE2B 00e092de954d6fe65b1f4af7ef287a7006dc736bab33b1470e56a53fad4752a61593224dba85bb06ea862b7bf0b3c7fc1cc200576be5774cf7bbc473182181bd SHA512 315c3d8d4ab8d9555e8a1804478cdb7e81b57e75f8b2d351a4bf1c8d9bc5d4e404cedeed2e75acc5731bc7d98adf3f407fc03eea34035ac18b5f4f6e33e715ee
+MISC metadata.xml 629 BLAKE2B df24b79b85b6b142f2b55c228d76f4e2ba9235f5bc3a34db26b2d20948b6c1909fad5fc4c71836706f9b0a658a9f9c71f606c8e3f8ba2485eead035d6a6bab36 SHA512 ac48e716cb602a4d2d1b9ca47d09ec705e6597e408cc06a4ecbc15bb1a44da208b99ec1203c3ea00fa3161f71f6a4c0e5d36a141de191e0e7b3fcff54fad169e
diff --git a/media-sound/qpwgraph/metadata.xml b/media-sound/qpwgraph/metadata.xml
new file mode 100644
index 000000000000..d07baf2f954e
--- /dev/null
+++ b/media-sound/qpwgraph/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Adel Kara Slimane</name>
+ <email>adel.ks@zegrapher.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freedesktop-gitlab">rncbc/qpwgraph</remote-id>
+ <bugs-to>https://gitlab.freedesktop.org/rncbc/qpwgraph/-/issues</bugs-to>
+ </upstream>
+ <use>
+ <flag name="trayicon">Build support for tray icon</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-sound/qpwgraph/qpwgraph-0.5.2.ebuild b/media-sound/qpwgraph/qpwgraph-0.5.2.ebuild
new file mode 100644
index 000000000000..744009584113
--- /dev/null
+++ b/media-sound/qpwgraph/qpwgraph-0.5.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="PipeWire Graph Qt GUI Interface"
+HOMEPAGE="https://gitlab.freedesktop.org/rncbc/qpwgraph"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/rncbc/qpwgraph"
+else
+ SRC_URI="https://gitlab.freedesktop.org/rncbc/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="alsa trayicon qt6 wayland"
+
+BDEPEND="
+ !qt6? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+"
+DEPEND="
+ media-video/pipewire:=
+ alsa? ( media-libs/alsa-lib )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,widgets,xml,network]
+ dev-qt/qtsvg:6
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_ALSA_MIDI=$(usex alsa)
+ -DCONFIG_SYSTEM_TRAY=$(usex trayicon)
+ -DCONFIG_WAYLAND=$(usex wayland)
+ -DCONFIG_QT6=$(usex qt6)
+ )
+ cmake_src_configure
+}
diff --git a/media-sound/qpwgraph/qpwgraph-9999.ebuild b/media-sound/qpwgraph/qpwgraph-9999.ebuild
new file mode 100644
index 000000000000..744009584113
--- /dev/null
+++ b/media-sound/qpwgraph/qpwgraph-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="PipeWire Graph Qt GUI Interface"
+HOMEPAGE="https://gitlab.freedesktop.org/rncbc/qpwgraph"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/rncbc/qpwgraph"
+else
+ SRC_URI="https://gitlab.freedesktop.org/rncbc/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="alsa trayicon qt6 wayland"
+
+BDEPEND="
+ !qt6? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+"
+DEPEND="
+ media-video/pipewire:=
+ alsa? ( media-libs/alsa-lib )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,widgets,xml,network]
+ dev-qt/qtsvg:6
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_ALSA_MIDI=$(usex alsa)
+ -DCONFIG_SYSTEM_TRAY=$(usex trayicon)
+ -DCONFIG_WAYLAND=$(usex wayland)
+ -DCONFIG_QT6=$(usex qt6)
+ )
+ cmake_src_configure
+}