summaryrefslogtreecommitdiff
path: root/media-sound/qjackctl/qjackctl-0.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /media-sound/qjackctl/qjackctl-0.9.4.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'media-sound/qjackctl/qjackctl-0.9.4.ebuild')
-rw-r--r--media-sound/qjackctl/qjackctl-0.9.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/qjackctl/qjackctl-0.9.4.ebuild b/media-sound/qjackctl/qjackctl-0.9.4.ebuild
new file mode 100644
index 000000000000..15137741a070
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.9.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake
+
+DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
+HOMEPAGE="https://qjackctl.sourceforge.io/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus debug portaudio"
+
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ virtual/jack
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ portaudio? ( media-libs/portaudio )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:5
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.1-disable-git.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_ALSA_SEQ=$(usex alsa 1 0)
+ -DCONFIG_DBUS=$(usex dbus 1 0)
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_PORTAUDIO=$(usex portaudio 1 0)
+ )
+ cmake_src_configure
+}