summaryrefslogtreecommitdiff
path: root/media-sound/pulsemixer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-sound/pulsemixer
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-sound/pulsemixer')
-rw-r--r--media-sound/pulsemixer/Manifest4
-rw-r--r--media-sound/pulsemixer/metadata.xml16
-rw-r--r--media-sound/pulsemixer/pulsemixer-1.5.0.ebuild25
-rw-r--r--media-sound/pulsemixer/pulsemixer-9999.ebuild25
4 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/pulsemixer/Manifest b/media-sound/pulsemixer/Manifest
new file mode 100644
index 000000000000..c5b5c647e35c
--- /dev/null
+++ b/media-sound/pulsemixer/Manifest
@@ -0,0 +1,4 @@
+DIST pulsemixer-1.5.0.tar.gz 21557 BLAKE2B 4c6cb9a3f9701301223c259532a0803a5c3e5f3abbce6f2763b6fd987f85aba56549e66861e9b69d0bf89c116c6c7e221d11cc65eb9a531402f74e8d63e9d824 SHA512 e07556a0cf2c9f660764977158cf1e338f7d8a92eae639c4a8f355847840e3aa9fb65adf553dbde905b64f2eff57c630bbfe19cfd5420b6205b1e2f688a6de64
+EBUILD pulsemixer-1.5.0.ebuild 577 BLAKE2B 8b73807770eb336446a579febae9a28e0037f06e4fd99bd59d91bf1a0a5e9b601e0adae4494a51b128fdb679971b01baf177f6efcbccad2f37b4c169b285bfbb SHA512 2693ca3bf3366dbc9889fb40f4382cd9ab58de3a78e277aa0e73c8d90b512a226d62e0f24987ea0b6620fd687df22274efaf17b2d81cf547e64bfefe38f7adbc
+EBUILD pulsemixer-9999.ebuild 577 BLAKE2B 8b73807770eb336446a579febae9a28e0037f06e4fd99bd59d91bf1a0a5e9b601e0adae4494a51b128fdb679971b01baf177f6efcbccad2f37b4c169b285bfbb SHA512 2693ca3bf3366dbc9889fb40f4382cd9ab58de3a78e277aa0e73c8d90b512a226d62e0f24987ea0b6620fd687df22274efaf17b2d81cf547e64bfefe38f7adbc
+MISC metadata.xml 539 BLAKE2B 3c4aeb04befd6535d90492837abf142f83ca907b9d158688488537b9edea29f00973763a8d59ca3deb5bfa34a0949d1e57fa7251f014f1750f854b5ebd3044b0 SHA512 9bf6daf8ce060e87586f3c2abfe56631785624d7e449cddca3d488ec298917da2413d28db0ada915bfda40d75715a07f17db5413890fbe6a3667c34599818e0d
diff --git a/media-sound/pulsemixer/metadata.xml b/media-sound/pulsemixer/metadata.xml
new file mode 100644
index 000000000000..8878000e28fb
--- /dev/null
+++ b/media-sound/pulsemixer/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jchelmertt3@gmail.com</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">GeorgeFilipkin/pulsemixer</remote-id>
+ <changelog>https://github.com/GeorgeFilipkin/pulsemixer/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/pulsemixer/pulsemixer-1.5.0.ebuild b/media-sound/pulsemixer/pulsemixer-1.5.0.ebuild
new file mode 100644
index 000000000000..45f1ee6b0c9b
--- /dev/null
+++ b/media-sound/pulsemixer/pulsemixer-1.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="CLI and curses mixer for PulseAudio"
+HOMEPAGE="https://github.com/GeorgeFilipkin/pulsemixer"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GeorgeFilipkin/${PN}"
+else
+ SRC_URI="https://github.com/GeorgeFilipkin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="media-sound/pulseaudio"
diff --git a/media-sound/pulsemixer/pulsemixer-9999.ebuild b/media-sound/pulsemixer/pulsemixer-9999.ebuild
new file mode 100644
index 000000000000..45f1ee6b0c9b
--- /dev/null
+++ b/media-sound/pulsemixer/pulsemixer-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="CLI and curses mixer for PulseAudio"
+HOMEPAGE="https://github.com/GeorgeFilipkin/pulsemixer"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GeorgeFilipkin/${PN}"
+else
+ SRC_URI="https://github.com/GeorgeFilipkin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="media-sound/pulseaudio"