summaryrefslogtreecommitdiff
path: root/media-sound/pulseaudio/pulseaudio-13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /media-sound/pulseaudio/pulseaudio-13.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'media-sound/pulseaudio/pulseaudio-13.0.ebuild')
-rw-r--r--media-sound/pulseaudio/pulseaudio-13.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/media-sound/pulseaudio/pulseaudio-13.0.ebuild b/media-sound/pulseaudio/pulseaudio-13.0.ebuild
index d1ed1d05bf32..737b28abb7fb 100644
--- a/media-sound/pulseaudio/pulseaudio-13.0.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-13.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools bash-completion-r1 flag-o-matic gnome2-utils linux-info systemd user udev multilib-minimal
+inherit autotools bash-completion-r1 flag-o-matic gnome2-utils linux-info systemd toolchain-funcs user udev multilib-minimal
DESCRIPTION="A networked sound server with an advanced plugin system"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
@@ -202,10 +202,11 @@ multilib_src_configure() {
)
if use elogind && multilib_is_native_abi; then
+ local PKGCONFIG="$(tc-getPKG_CONFIG)"
myconf+=(
--enable-systemd-login
- SYSTEMDLOGIN_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- SYSTEMDLOGIN_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ SYSTEMDLOGIN_CFLAGS="$(${PKGCONFIG} --cflags "libelogind" 2>/dev/null)"
+ SYSTEMDLOGIN_LIBS="$(${PKGCONFIG} --libs "libelogind" 2>/dev/null)"
)
fi