summaryrefslogtreecommitdiff
path: root/media-sound/pulseaudio/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /media-sound/pulseaudio/files
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'media-sound/pulseaudio/files')
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-11.1-disable-flat-volumes.patch48
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-11.1-glibc-2.27.patch59
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-11.1-qpaeq-pyqt5-1.patch198
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-11.1-qpaeq-pyqt5-2.patch31
4 files changed, 336 insertions, 0 deletions
diff --git a/media-sound/pulseaudio/files/pulseaudio-11.1-disable-flat-volumes.patch b/media-sound/pulseaudio/files/pulseaudio-11.1-disable-flat-volumes.patch
new file mode 100644
index 000000000000..40b23ec05f2e
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-11.1-disable-flat-volumes.patch
@@ -0,0 +1,48 @@
+diff -up a/man/pulse-daemon.conf.5.xml.in b/man/pulse-daemon.conf.5.xml.in
+--- a/man/pulse-daemon.conf.5.xml.in 2016-05-26 23:21:17.000000000 -0500
++++ b/man/pulse-daemon.conf.5.xml.in 2016-05-31 10:01:55.679976730 -0500
+@@ -220,7 +220,7 @@ License along with PulseAudio; if not, s
+ <p><opt>flat-volumes=</opt> Enable 'flat' volumes, i.e. where
+ possible let the sink volume equal the maximum of the volumes of
+ the inputs connected to it. Takes a boolean argument, defaults
+- to <opt>yes</opt>.</p>
++ to <opt>no</opt>.</p>
+ </option>
+
+ </section>
+diff -up a/src/daemon/daemon-conf.c b/src/daemon/daemon-conf.c
+--- a/src/daemon/daemon-conf.c 2016-05-26 23:21:17.000000000 -0500
++++ b/src/daemon/daemon-conf.c 2016-05-31 10:01:55.680976735 -0500
+@@ -68,7 +68,7 @@ static const pa_daemon_conf default_conf
+ .realtime_priority = 5, /* Half of JACK's default rtprio */
+ .disallow_module_loading = false,
+ .disallow_exit = false,
+- .flat_volumes = true,
++ .flat_volumes = false,
+ .exit_idle_time = 20,
+ .scache_idle_time = 20,
+ .script_commands = NULL,
+diff -up a/src/daemon/daemon.conf.in b/src/daemon/daemon.conf.in
+--- a/src/daemon/daemon.conf.in 2016-05-31 10:01:55.680976735 -0500
++++ b/src/daemon/daemon.conf.in 2016-05-31 10:02:28.048133267 -0500
+@@ -57,7 +57,7 @@ ifelse(@HAVE_DBUS@, 1, [dnl
+ ; enable-lfe-remixing = no
+ ; lfe-crossover-freq = 0
+
+-; flat-volumes = yes
++; flat-volumes = no
+
+ ifelse(@HAVE_SYS_RESOURCE_H@, 1, [dnl
+ ; rlimit-fsize = -1
+diff -up a/src/pulsecore/core.c b/src/pulsecore/core.c
+--- a/src/pulsecore/core.c 2016-05-26 23:21:17.000000000 -0500
++++ b/src/pulsecore/core.c 2016-05-31 10:01:55.681976740 -0500
+@@ -135,7 +135,7 @@ pa_core* pa_core_new(pa_mainloop_api *m,
+ c->exit_idle_time = -1;
+ c->scache_idle_time = 20;
+
+- c->flat_volumes = true;
++ c->flat_volumes = false;
+ c->disallow_module_loading = false;
+ c->disallow_exit = false;
+ c->running_as_daemon = false;
diff --git a/media-sound/pulseaudio/files/pulseaudio-11.1-glibc-2.27.patch b/media-sound/pulseaudio/files/pulseaudio-11.1-glibc-2.27.patch
new file mode 100644
index 000000000000..a89167b603d0
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-11.1-glibc-2.27.patch
@@ -0,0 +1,59 @@
+From: Tanu Kaskinen <tanuk@iki.fi>
+Date: Wed, 24 Jan 2018 03:51:49 +0200
+Subject: memfd-wrappers: only define memfd_create() if not already defined
+
+glibc 2.27 is to be released soon, and it will provide memfd_create().
+If glibc provides the function, we must not define it ourselves,
+otherwise building fails due to conflict between the two implementations
+of the same function.
+
+BugLink: https://bugs.freedesktop.org/show_bug.cgi?id=104733
+(cherry picked from commit dfb0460fb4743aec047cdf755a660a9ac2d0f3fb)
+---
+ configure.ac | 3 +++
+ src/pulsecore/memfd-wrappers.h | 7 ++++---
+ 2 files changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 77b5ff5..3a71fd8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -607,6 +607,9 @@ AS_IF([test "x$enable_memfd" = "xyes" && test "x$HAVE_MEMFD" = "x0"],
+ [AC_MSG_ERROR([*** Your Linux kernel does not support memfd shared memory.
+ *** Use linux v3.17 or higher for such a feature.])])
+
++AS_IF([test "x$HAVE_MEMFD" = "x1"],
++ AC_CHECK_FUNCS([memfd_create]))
++
+ AC_SUBST(HAVE_MEMFD)
+ AM_CONDITIONAL([HAVE_MEMFD], [test "x$HAVE_MEMFD" = x1])
+ AS_IF([test "x$HAVE_MEMFD" = "x1"], AC_DEFINE([HAVE_MEMFD], 1, [Have memfd shared memory.]))
+diff --git a/src/pulsecore/memfd-wrappers.h b/src/pulsecore/memfd-wrappers.h
+index 3bed9b2..c7aadfd 100644
+--- a/src/pulsecore/memfd-wrappers.h
++++ b/src/pulsecore/memfd-wrappers.h
+@@ -20,13 +20,14 @@
+ License along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
+ ***/
+
+-#ifdef HAVE_MEMFD
++#if defined(HAVE_MEMFD) && !defined(HAVE_MEMFD_CREATE)
+
+ #include <sys/syscall.h>
+ #include <fcntl.h>
+
+ /*
+- * No glibc wrappers exist for memfd_create(2), so provide our own.
++ * Before glibc version 2.27 there was no wrapper for memfd_create(2),
++ * so we have to provide our own.
+ *
+ * Also define memfd fcntl sealing macros. While they are already
+ * defined in the kernel header file <linux/fcntl.h>, that file as
+@@ -63,6 +64,6 @@ static inline int memfd_create(const char *name, unsigned int flags) {
+ #define F_SEAL_WRITE 0x0008 /* prevent writes */
+ #endif
+
+-#endif /* HAVE_MEMFD */
++#endif /* HAVE_MEMFD && !HAVE_MEMFD_CREATE */
+
+ #endif
diff --git a/media-sound/pulseaudio/files/pulseaudio-11.1-qpaeq-pyqt5-1.patch b/media-sound/pulseaudio/files/pulseaudio-11.1-qpaeq-pyqt5-1.patch
new file mode 100644
index 000000000000..62012c121472
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-11.1-qpaeq-pyqt5-1.patch
@@ -0,0 +1,198 @@
+From: =?utf-8?q?Andrius_=C5=A0tikonas?= <andrius@stikonas.eu>
+Date: Mon, 20 Nov 2017 19:56:53 +0000
+Subject: qpaeq: port to PyQt5
+
+(cherry picked from commit 480e0e74f43565d7ece72141666961ae8cc2ed75)
+---
+ src/utils/qpaeq | 68 ++++++++++++++++++++++++++++-----------------------------
+ 1 file changed, 34 insertions(+), 34 deletions(-)
+
+diff --git a/src/utils/qpaeq b/src/utils/qpaeq
+index ac4b9e4..508b233 100755
+--- a/src/utils/qpaeq
++++ b/src/utils/qpaeq
+@@ -18,13 +18,13 @@
+
+ import os,math,sys
+ try:
+- import PyQt4,sip
+- from PyQt4 import QtGui,QtCore
++ import PyQt5,sip
++ from PyQt5 import QtWidgets,QtCore
+ import dbus.mainloop.qt
+ import dbus
+ except ImportError as e:
+ sys.stderr.write('There was an error importing needed libraries\n'
+- 'Make sure you have qt4 and dbus-python installed\n'
++ 'Make sure you have qt5 and dbus-python installed\n'
+ 'The error that occured was:\n'
+ '\t%s\n' % (str(e)))
+ sys.exit(-1)
+@@ -62,7 +62,7 @@ def connect():
+ prop_iface='org.freedesktop.DBus.Properties'
+ eq_iface='org.PulseAudio.Ext.Equalizing1.Equalizer'
+ device_iface='org.PulseAudio.Core1.Device'
+-class QPaeq(QtGui.QWidget):
++class QPaeq(QtWidgets.QWidget):
+ manager_path='/org/pulseaudio/equalizing1'
+ manager_iface='org.PulseAudio.Ext.Equalizing1.Manager'
+ core_iface='org.PulseAudio.Core1'
+@@ -70,7 +70,7 @@ class QPaeq(QtGui.QWidget):
+ module_name='module-equalizer-sink'
+
+ def __init__(self):
+- QtGui.QWidget.__init__(self)
++ QtWidgets.QWidget.__init__(self)
+ self.setWindowTitle('qpaeq')
+ self.slider_widget=None
+ self.sink_name=None
+@@ -84,50 +84,50 @@ class QPaeq(QtGui.QWidget):
+ self.setMinimumSize(self.sizeHint())
+
+ def create_layout(self):
+- self.main_layout=QtGui.QVBoxLayout()
++ self.main_layout=QtWidgets.QVBoxLayout()
+ self.setLayout(self.main_layout)
+- toprow_layout=QtGui.QHBoxLayout()
+- sizePolicy = QtGui.QSizePolicy(QtGui.QSizePolicy.Preferred, QtGui.QSizePolicy.Fixed)
++ toprow_layout=QtWidgets.QHBoxLayout()
++ sizePolicy = QtWidgets.QSizePolicy(QtWidgets.QSizePolicy.Preferred, QtWidgets.QSizePolicy.Fixed)
+ sizePolicy.setHorizontalStretch(0)
+ sizePolicy.setVerticalStretch(0)
+ #sizePolicy.setHeightForWidth(self.profile_box.sizePolicy().hasHeightForWidth())
+
+- toprow_layout.addWidget(QtGui.QLabel('Sink'))
+- self.sink_box = QtGui.QComboBox()
++ toprow_layout.addWidget(QtWidgets.QLabel('Sink'))
++ self.sink_box = QtWidgets.QComboBox()
+ self.sink_box.setSizePolicy(sizePolicy)
+ self.sink_box.setDuplicatesEnabled(False)
+- self.sink_box.setInsertPolicy(QtGui.QComboBox.InsertAlphabetically)
+- #self.sink_box.setSizeAdjustPolicy(QtGui.QComboBox.AdjustToContents)
++ self.sink_box.setInsertPolicy(QtWidgets.QComboBox.InsertAlphabetically)
++ #self.sink_box.setSizeAdjustPolicy(QtWidgets.QComboBox.AdjustToContents)
+ toprow_layout.addWidget(self.sink_box)
+
+- toprow_layout.addWidget(QtGui.QLabel('Channel'))
+- self.channel_box = QtGui.QComboBox()
++ toprow_layout.addWidget(QtWidgets.QLabel('Channel'))
++ self.channel_box = QtWidgets.QComboBox()
+ self.channel_box.setSizePolicy(sizePolicy)
+ toprow_layout.addWidget(self.channel_box)
+
+- toprow_layout.addWidget(QtGui.QLabel('Preset'))
+- self.profile_box = QtGui.QComboBox()
++ toprow_layout.addWidget(QtWidgets.QLabel('Preset'))
++ self.profile_box = QtWidgets.QComboBox()
+ self.profile_box.setSizePolicy(sizePolicy)
+- self.profile_box.setInsertPolicy(QtGui.QComboBox.InsertAlphabetically)
+- #self.profile_box.setSizeAdjustPolicy(QtGui.QComboBox.AdjustToContents)
++ self.profile_box.setInsertPolicy(QtWidgets.QComboBox.InsertAlphabetically)
++ #self.profile_box.setSizeAdjustPolicy(QtWidgets.QComboBox.AdjustToContents)
+ toprow_layout.addWidget(self.profile_box)
+
+- large_icon_size=self.style().pixelMetric(QtGui.QStyle.PM_LargeIconSize)
++ large_icon_size=self.style().pixelMetric(QtWidgets.QStyle.PM_LargeIconSize)
+ large_icon_size=QtCore.QSize(large_icon_size,large_icon_size)
+- save_profile=QtGui.QToolButton()
+- save_profile.setIcon(self.style().standardIcon(QtGui.QStyle.SP_DriveFDIcon))
++ save_profile=QtWidgets.QToolButton()
++ save_profile.setIcon(self.style().standardIcon(QtWidgets.QStyle.SP_DriveFDIcon))
+ save_profile.setIconSize(large_icon_size)
+ save_profile.setToolButtonStyle(QtCore.Qt.ToolButtonIconOnly)
+ save_profile.clicked.connect(self.save_profile)
+- remove_profile=QtGui.QToolButton()
+- remove_profile.setIcon(self.style().standardIcon(QtGui.QStyle.SP_TrashIcon))
++ remove_profile=QtWidgets.QToolButton()
++ remove_profile.setIcon(self.style().standardIcon(QtWidgets.QStyle.SP_TrashIcon))
+ remove_profile.setIconSize(large_icon_size)
+ remove_profile.setToolButtonStyle(QtCore.Qt.ToolButtonIconOnly)
+ remove_profile.clicked.connect(self.remove_profile)
+ toprow_layout.addWidget(save_profile)
+ toprow_layout.addWidget(remove_profile)
+
+- reset_button = QtGui.QPushButton('Reset')
++ reset_button = QtWidgets.QPushButton('Reset')
+ reset_button.clicked.connect(self.reset)
+ toprow_layout.addStretch()
+ toprow_layout.addWidget(reset_button)
+@@ -192,11 +192,11 @@ class QPaeq(QtGui.QWidget):
+ def save_profile(self):
+ #popup dialog box for name
+ current=self.profile_box.currentIndex()
+- profile,ok=QtGui.QInputDialog.getItem(self,'Preset Name','Preset',self.profiles,current)
++ profile,ok=QtWidgets.QInputDialog.getItem(self,'Preset Name','Preset',self.profiles,current)
+ if not ok or profile=='':
+ return
+ if profile in self.profiles:
+- mbox=QtGui.QMessageBox(self)
++ mbox=QtWidgets.QMessageBox(self)
+ mbox.setText('%s preset already exists'%(profile,))
+ mbox.setInformativeText('Do you want to save over it?')
+ mbox.setStandardButtons(mbox.Save|mbox.Discard|mbox.Cancel)
+@@ -217,7 +217,7 @@ class QPaeq(QtGui.QWidget):
+ profile=self.profile_box.itemText(x)
+ self.filter_state.load_profile(profile)
+ def select_channel(self,x):
+- self.filter_state.channel = self.channel_box.itemData(x).toPyObject()
++ self.filter_state.channel = self.channel_box.itemData(x)
+ self._set_profile_name()
+ self.filter_state.readback()
+
+@@ -295,13 +295,13 @@ class QPaeq(QtGui.QWidget):
+ self.profile_box.blockSignals(False)
+
+
+-class SliderArray(QtGui.QWidget):
++class SliderArray(QtWidgets.QWidget):
+ def __init__(self,filter_state,parent=None):
+ super(SliderArray,self).__init__(parent)
+ #self.setStyleSheet('padding: 0px; border-width: 0px; margin: 0px;')
+ #self.setStyleSheet('font-family: monospace;'+outline%('blue'))
+ self.filter_state=filter_state
+- self.setLayout(QtGui.QHBoxLayout())
++ self.setLayout(QtWidgets.QHBoxLayout())
+ self.sub_array=None
+ self.set_sub_array(SliderArraySub(self.filter_state))
+ self.inhibit_resize=0
+@@ -359,11 +359,11 @@ class SliderArray(QtGui.QWidget):
+ self.set_sub_array(SliderArraySub(self.filter_state))
+ self.inhibit_resize-=1
+
+-class SliderArraySub(QtGui.QWidget):
++class SliderArraySub(QtWidgets.QWidget):
+ def __init__(self,filter_state,parent=None):
+ super(SliderArraySub,self).__init__(parent)
+ self.filter_state=filter_state
+- self.setLayout(QtGui.QGridLayout())
++ self.setLayout(QtWidgets.QGridLayout())
+ self.slider=[None]*len(self.filter_state.frequencies)
+ self.label=[None]*len(self.slider)
+ #self.setStyleSheet('padding: 0px; border-width: 0px; margin: 0px;')
+@@ -375,7 +375,7 @@ class SliderArraySub(QtGui.QWidget):
+ self.layout().addWidget(label,1,c,qt.AlignHCenter)
+ self.layout().setColumnMinimumWidth(c,max(label.sizeHint().width(),slider.sizeHint().width()))
+ def create_slider(slider_label):
+- slider=QtGui.QSlider(QtCore.Qt.Vertical,self)
++ slider=QtWidgets.QSlider(QtCore.Qt.Vertical,self)
+ label=SliderLabel(slider_label,filter_state,self)
+ slider.setRange(-1000,2000)
+ slider.setSingleStep(1)
+@@ -461,7 +461,7 @@ class SliderArraySub(QtGui.QWidget):
+ return int((x-1.0)*1000)
+ outline='border-width: 1px; border-style: solid; border-color: %s;'
+
+-class SliderLabel(QtGui.QLabel):
++class SliderLabel(QtWidgets.QLabel):
+ clicked=QtCore.pyqtSignal()
+ def __init__(self,label_text,filter_state,parent=None):
+ super(SliderLabel,self).__init__(parent)
+@@ -566,7 +566,7 @@ def subdivide(xs, t_points):
+
+ def main():
+ dbus.mainloop.qt.DBusQtMainLoop(set_as_default=True)
+- app=QtGui.QApplication(sys.argv)
++ app=QtWidgets.QApplication(sys.argv)
+ qpaeq_main=QPaeq()
+ qpaeq_main.show()
+ sys.exit(app.exec_())
diff --git a/media-sound/pulseaudio/files/pulseaudio-11.1-qpaeq-pyqt5-2.patch b/media-sound/pulseaudio/files/pulseaudio-11.1-qpaeq-pyqt5-2.patch
new file mode 100644
index 000000000000..7706bfb3416a
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-11.1-qpaeq-pyqt5-2.patch
@@ -0,0 +1,31 @@
+From: Felipe Sateler <fsateler@debian.org>
+Date: Thu, 5 Apr 2018 15:44:26 -0300
+Subject: Use the pyqt5 dbus mainloop integration
+
+Forwarded: https://bugs.freedesktop.org/show_bug.cgi?id=102572
+---
+ src/utils/qpaeq | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/utils/qpaeq b/src/utils/qpaeq
+index 508b233..a319dad 100755
+--- a/src/utils/qpaeq
++++ b/src/utils/qpaeq
+@@ -20,7 +20,7 @@ import os,math,sys
+ try:
+ import PyQt5,sip
+ from PyQt5 import QtWidgets,QtCore
+- import dbus.mainloop.qt
++ import dbus.mainloop.pyqt5
+ import dbus
+ except ImportError as e:
+ sys.stderr.write('There was an error importing needed libraries\n'
+@@ -565,7 +565,7 @@ def subdivide(xs, t_points):
+ return left+right
+
+ def main():
+- dbus.mainloop.qt.DBusQtMainLoop(set_as_default=True)
++ dbus.mainloop.pyqt5.DBusQtMainLoop(set_as_default=True)
+ app=QtWidgets.QApplication(sys.argv)
+ qpaeq_main=QPaeq()
+ qpaeq_main.show()