summaryrefslogtreecommitdiff
path: root/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild')
-rw-r--r--media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
index 56a66ff8e9e3..4b41f381f58c 100644
--- a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
+++ b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils readme.gentoo-r1
+inherit cmake readme.gentoo-r1
DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth"
HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
@@ -51,6 +51,14 @@ load-module module-bluetooth-discover
.endif
"
+src_prepare() {
+ cmake_src_prepare
+
+ # pulseaudio headers needed to build
+ rmdir pa/ || die
+ ln -s ../pulseaudio-${PULSE_VER}/ pa || die
+}
+
src_configure() {
local mycmakeargs=(
-DCODEC_AAC_FDK=$(usex fdk "ON" "OFF")
@@ -60,19 +68,11 @@ src_configure() {
-DNATIVE_HEADSET=$(usex native-headset "ON" "OFF")
-DOFONO_HEADSET=$(usex ofono-headset "ON" "OFF")
)
- cmake-utils_src_configure
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # pulseaudio headers needed to build
- rmdir pa/ || die
- ln -s ../pulseaudio-${PULSE_VER}/ pa || die
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
readme.gentoo_create_doc
}