summaryrefslogtreecommitdiff
path: root/media-sound/puddletag/puddletag-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /media-sound/puddletag/puddletag-2.0.1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'media-sound/puddletag/puddletag-2.0.1.ebuild')
-rw-r--r--media-sound/puddletag/puddletag-2.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/puddletag/puddletag-2.0.1.ebuild b/media-sound/puddletag/puddletag-2.0.1.ebuild
new file mode 100644
index 000000000000..51eb70028ff7
--- /dev/null
+++ b/media-sound/puddletag/puddletag-2.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="Audio tag editor"
+HOMEPAGE="http://docs.puddletag.net/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acoustid quodlibet"
+
+DEPEND=""
+RDEPEND="
+ >=dev-python/configobj-5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.4.7[${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-5.15.2[${PYTHON_USEDEP},svg]
+ >=media-libs/mutagen-1.45.1[${PYTHON_USEDEP}]
+ acoustid? ( >=media-libs/chromaprint-1.4.3 )
+ quodlibet? ( >=media-sound/quodlibet-4.3.0[${PYTHON_USEDEP}] )
+ >=dev-python/sip-4.19.22:0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.5.2[${PYTHON_USEDEP}]
+"
+# docs
+# >=dev-python/wheel-0.35.1[${PYTHON_USEDEP}]
+# >=dev-python/markdown-3.1.1[${PYTHON_USEDEP}]
+# >=dev-python/sphinx-1.4.8[${PYTHON_USEDEP}]
+# >=dev-python/sphinx-bootstrap-theme-0.4.13[${PYTHON_USEDEP}]
+# >=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
+
+DOCS=(changelog NEWS THANKS TODO)