summaryrefslogtreecommitdiff
path: root/media-sound/pms
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /media-sound/pms
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'media-sound/pms')
-rw-r--r--media-sound/pms/Manifest4
-rw-r--r--media-sound/pms/pms-0.42_p20170508.ebuild21
-rw-r--r--media-sound/pms/pms-9999.ebuild18
3 files changed, 21 insertions, 22 deletions
diff --git a/media-sound/pms/Manifest b/media-sound/pms/Manifest
index 6e9c05373927..81daab6356c1 100644
--- a/media-sound/pms/Manifest
+++ b/media-sound/pms/Manifest
@@ -1,4 +1,4 @@
DIST pms-0.42_p20170508.tar.gz 140157 BLAKE2B c4c3ff916a9aa36522f48636cca97f22069219ebfc25e219d4aff3d0ca5bf20d80d343d224996db82fb6e8fb13cd9f38f7fc860683bc574124aaf0315d3f2dcb SHA512 686a5e265ebad418a153b9888cc213bbf8cca5aa2d398206848823105edac16e298431c288dc0a74adb23d327c75845cdec1680a6a2a2ae40bc7b41c55ca163c
-EBUILD pms-0.42_p20170508.ebuild 749 BLAKE2B 72a6f5f9766ba8d6458ea909bef58022dd14885634be9658c453f44907e859501e2c4ba3e001be3ab5d4bb9ac8fc9ecaf9a4399a54abd45c2aee2203e9bf2772 SHA512 26d99bc5f34ce213c00e33fa81e9c14828bda5ed3d15e67c92b3a2e05cce82dba4369d87728ccb7ca55eee658786e058864efa57c04434676bfc46233fdbcf8a
-EBUILD pms-9999.ebuild 719 BLAKE2B f874718f9a1a625c51fa164d61a551b8c6ed5a425199bf9b83f9f7f97f703b78649f8158e4b2d230c774f950371a47e5ff20269eb26a9a470dc6bd13d5fada19 SHA512 4404ea4fc14b16fa98967da327ffa74a6e860849ce8a8785d813a6d7a2c32994ea93504812640fd8e720b80a25419056fed439b9f00384b30426fbf5117cd5a3
+EBUILD pms-0.42_p20170508.ebuild 749 BLAKE2B 325998faf7d0881c250168b421f751c7781867310019012233537f155b68d34c7b05e554716bacb85423008ab6185d3923bee7dd5f14fe625e58242291220335 SHA512 11659f220e1253e23b02d760ef77959e0cfbd770831ac14628d24087582794ad448462a181ece145702d12b55e857b480c836ef6e56f09b576919b941ff66566
+EBUILD pms-9999.ebuild 713 BLAKE2B eadbbca9f443e79c5c6bacfa846b98c7764cdbd36de972dcc673f147521ff895eae5916a8f90a4f707ac575f3115f1b4aa721097f41b7b9732cd535053c256c0 SHA512 b2be07fb6ef262c353727df6a4fb87f2bc78b7bfb39c31bf9cc2ff34e9b27b16a8fe6f97e4c2b1cf4cbb9641fe128bd1e7b29c1672208cae97cf1a82ed837b47
MISC metadata.xml 326 BLAKE2B 46ebd520822a0ddd4ac8dafee3358ce36fee3c07654ab135a36713172eb1978c7320e8f86538175a840e3c46d4c30148e105f1d8d7d83ee360dd414f868bd4e4 SHA512 7aa51dedca6dc6308866e597aa169a5714559e3c25c13c40ad11356ee0dcc13042ddc4a3388d4a7687a43a7847cd8f37b36f1a8ed3ee3c4b4e125a8f4d0abf48
diff --git a/media-sound/pms/pms-0.42_p20170508.ebuild b/media-sound/pms/pms-0.42_p20170508.ebuild
index 13f5072cbc92..5fff6b4dc85c 100644
--- a/media-sound/pms/pms-0.42_p20170508.ebuild
+++ b/media-sound/pms/pms-0.42_p20170508.ebuild
@@ -1,30 +1,29 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils vcs-snapshot
+inherit cmake vcs-snapshot
REF="8c8918488a4a22924ee04442dc5e5216783d51ff"
-
DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
HOMEPAGE="https://ambientsound.github.io/pms"
-SRC_URI="https://github.com/ambientsound/${PN}/tarball/${REF} -> ${P}.tar.gz"
+SRC_URI="https://github.com/ambientsound/${PN}/archive/${REF}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+regex doc"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/pandoc )
+"
RDEPEND="
sys-libs/ncurses:0=[unicode]
media-libs/libmpdclient
"
-DEPEND="
- virtual/pkgconfig
- doc? ( app-text/pandoc )
- ${RDEPEND}
-"
+DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(
@@ -32,5 +31,5 @@ src_configure() {
-DENABLE_REGEX=$(usex regex)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-sound/pms/pms-9999.ebuild b/media-sound/pms/pms-9999.ebuild
index 2a0de1e38b9c..4260a7d72b3a 100644
--- a/media-sound/pms/pms-9999.ebuild
+++ b/media-sound/pms/pms-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake git-r3
DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
HOMEPAGE="https://ambientsound.github.io/pms"
@@ -16,15 +16,15 @@ SLOT="0"
KEYWORDS=""
IUSE="+regex doc"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/pandoc )
+"
RDEPEND="
sys-libs/ncurses:0=[unicode]
media-libs/libmpdclient
"
-DEPEND="
- virtual/pkgconfig
- doc? ( app-text/pandoc )
- ${RDEPEND}
-"
+DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(
@@ -32,5 +32,5 @@ src_configure() {
-DENABLE_REGEX=$(usex regex)
)
- cmake-utils_src_configure
+ cmake_src_configure
}